Announcement

#1 2012-06-20 14:55:36

danic
Guest

Exif extension not available

Hi Friends
My admin paneh warning that (Exif extension not available, admin should disable exif use)
How i available this item?

 

#2 2012-06-20 15:02:41

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Exif extension not available

if you have access to php.ini you must add or uncomment this line

Code:

extension=php_exif.dll

you you don't have access to this file (mostly the case on shared hosts) try to contact your host

Offline

 

#3 2012-06-20 15:18:57

danic
Guest

Re: Exif extension not available

Thanks :)
Now it say You need to define Captcha keys :/
how i can take it?

 

#4 2012-06-20 15:28:58

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Exif extension not available

do you use the plugin reCaptcha ?
I think all is explained on the plugin page

you have to register here http://www.google.com/recaptcha

Offline

 

#5 2012-06-23 19:51:34

danic
Guest

Re: Exif extension not available

Hi My Friends
I Create New User But i Coudent Login By New user/pass.
My New User status is user group.

 

#6 2012-07-09 05:47:29

Jaanus
Guest

Re: Exif extension not available

Hi,
in another thread
http://piwigo.org/forum/viewtopic.php?id=17562

I suggested one library that could make Piwigo independent of php exif extension. Any progress with implementing this? It could be solution to such issues :)

 

#7 2012-12-06 20:08:18

Jon Waller
Guest

Re: Exif extension not available

I've just installed Piwigo on my IIS 6.0 machine. I had this extension problem harassing me for days. The final solution is in the php.ini file. Extensions in the php.ini are listed in alphabetical order. However php_exif.dll is dependant on php_mbstring.dll. So even if php_exif.dll is enabled, it will fail to load until php_mbstring.dll is not enabled first.

My solution:
Modify php.ini and move php_mbstring.dll to the position before the exif dll:
  extension=php_mbstring.dll
  extension=php_exif.dll

Save the file.

Restart IIS to reload php.ini.

I hope this helps some with the problem.

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact