Announcement

  •  » Miscellaneous
  •  » how to allow the users to upload without the webmster access

#1 2011-10-21 06:07:48

karan2003
Member
1970-01-01
7

how to allow the users to upload without the webmster access

HI i am new here. new version of piwigo is awesome loved the android app great job and impressive.

now how can i allow users to upload the pictures the only way user can upload if i will give them webmaster access
but i am afraid user won't go into setting and not mess up LOL as we all know.

i just want all of the register users to upload to assign albums. can someone help me how to configure this i am
sure there's got to be a way to set this up. i just want users to upload without giving them complete access to
backend settings.

help will be appreciated

thanks

Offline

 

#2 2011-10-21 10:51:04

Billr
Piwigo Team, forum moderator
2011-06-22
144

Re: how to allow the users to upload without the webmster access

Install the Community Plugin.

Offline

 

#3 2011-10-21 19:13:17

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13277

Re: how to allow the users to upload without the webmster access

And I confirm that [extension by plg] Community is compatible with remote software upload (such as iPhone/Android/pLoader/Lightroom/Shotwell/Digikam...)

Offline

 

#4 2013-01-27 17:41:07

NateHoy
Member
2013-01-27
1

Re: how to allow the users to upload without the webmster access

I wasn't sure which thread to post this to, so I'll refer to the other thread where this issue is reported as well.

http://piwigo.org/forum/viewtopic.php?pid=130580

I'm experiencing the same problem the folks in the other thread are.  I've created a non-administrative account in my Piwigo gallery and set up Community so that "all registered users" can upload pictures to any gallery (with "low trust" so I can approve any pictures).

When I start the Piwigo app on my Android phone and log in as that user, however, I cannot choose any albums to upload my photos to.  I have a choice between "-----" and "undefined".  I can successfully select "Create a new album" and I have confirmed that the album is actually created (so I know the Community plugin is allowing some of the permissions), but I can never seem to choose any albums, even the one I just created.

When I log in as an Administrative user, the upload works perfectly.

Could there possibly be a bug in the album selection algorithm somewhere?

Thanks very much for an awesome gallery software package, by the way.

EDIT:  I just tried it using the same account on Shotwell in Linux, and even though the user was set up with "low trust", the album and picture appeared on the site immediately with no approval required.

Last edited by NateHoy (2013-01-27 21:08:36)

Offline

 
  •  » Miscellaneous
  •  » how to allow the users to upload without the webmster access

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact