Announcement

#1 2014-01-21 15:32:02

faqvideo
Member
2012-01-21
114

2.6 Installation Trouble

Hello,

My Piwigo album http://ottawastockimages.com is installed at DreamHost.com as "one-click-install".

I have it upgraded automatically, or so I thought. There are some changes to the interface, although:

1. The UI reports shows "A new version of Piwigo is available" and that I still have a 2.5.3 version installed (see attached image). The link is unclickable though, I can't do any upgrades from this page.

2. Some menu items are unavailable, i. e. when I click on Albums => Manage, i see this message:

"Fatal error: Call to undefined function query2array() in /home/ottawastockimages/ottawastockimages.com/admin/cat_list.php on line 265"

After I click on Configuration => Themes, I see this message:

"Fatal error: Class 'ThemeMaintain' not found in /home/ottawastockimages/ottawastockimages.com/admin/include/themes.class.php on line 28"

3. I see no changes in the SmartPocket theme at all. Basically it works as it used to on the user side, but there some issues on the Admin side.


Uploaded Images

Offline

 

#2 2014-01-21 15:45:12

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: 2.6 Installation Trouble

Hello

your update is incomplete, you are missing functions added in the new package

downloaded it again and overwrite all files
if you use a bytecode cache on PHP you obviously need to reset it

Offline

 

#3 2014-01-21 15:47:30

faqvideo
Member
2012-01-21
114

Re: 2.6 Installation Trouble

I would not normally download it, but use the Upgrade button within the Piwigo interface. Do you suggest I need to re-install it manually instead?

Offline

 

#4 2014-01-21 15:58:23

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: 2.6 Installation Trouble

I don't suggest anything, I say it's what you must do (cf many topics about that)

Offline

 

#5 2014-01-21 16:15:37

faqvideo
Member
2012-01-21
114

Re: 2.6 Installation Trouble

mistic100 wrote:

Hello

your update is incomplete, you are missing functions added in the new package

downloaded it again and overwrite all files
if you use a bytecode cache on PHP you obviously need to reset it

I take it as a suggestion to install it manually - correct? I tried to upgrade it automatically, and something went wrong. If I knew the way to reverse the action, I would have done so. Since it is impossible, I guess  my only option is to re-install it manually?

Offline

 

#6 2014-01-21 16:40:00

flop25
Piwigo Team
2006-07-06
6918

Re: 2.6 Installation Trouble

noooo the option here is to "downloaded it again -on your computer- and overwrite all files -by sending them by Ftp-" That's all


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2014-01-23 20:53:05

faqvideo
Member
2012-01-21
114

Re: 2.6 Installation Trouble

flop25 wrote:

noooo the option here is to "downloaded it again -on your computer- and overwrite all files -by sending them by Ftp-" That's all

Just to be clear - I downloaded the piwigo2.6.zip file and extracted it. I understand if I delete all my files on the server, that will mean I will have to start from scratch?

I am looking at the Manual Upgrade manual here:

http://piwigo.org/basics/upgrade_manual

Most of it is abra-cadabra for me. I understand that I don't want to delete following folders:
galleries
upload
plugins
template-extension
local

Is there anything else I need to worry about? Can you explain it in plain English SVP? I am not a programmer, mostly photographer with access to Filezilla.

Merci.

Offline

 

#8 2014-01-26 01:31:10

faqvideo
Member
2012-01-21
114

Re: 2.6 Installation Trouble

My second Piwigo project crashed after automatic upgrade to 2.6.1.

http://andreifiles.com/ brings me to:


Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND ic.image_id NOT IN (122,123,124,125,126,127,128,129,130,131,132,162,163,16' at line 5

SELECT tag_id, COUNT(DISTINCT(it.image_id)) AS counter
  FROM piwigo_image_category ic
    INNER JOIN piwigo_image_tag it
    ON ic.image_id=it.image_id
   WHERE  (category_id NOT IN (1,6,10,11,12,14,18,19,20,21,22,23,24,25,26,27,28,29,31,32,35,38,39,41,42,46,47,52,58,59,60,61,63,65,66,69,70,73,74,75,76,77,78,79,82,83,84,85,86,87,88,97,103,105,107,108,109,111,112,113,2,9,13,49,110,) AND ic.image_id NOT IN (122,123,124,125,126,127,128,129,130,131,132,162,163,165,175,176,177,178,179,180,181,182,183,184,185,186,187,188,189,190,191,192,193,194,195,196,202,204,206,210,213,215,216,217,218,219,221,224,227,228,229,237,240,241,247,249,255,256,257,258,259,260,262,263,264,270,271,272,273,274,276,277,278,279,280,281,282,284,285,286,287,288,289,290,291,433,434,435,436,437,438,439 in /home/piwigo/andreifiles.com/include/dblayer/functions_mysqli.inc.php on line 798


Fatal error: Call to a member function fetch_assoc() on a non-object in /home/piwigo/andreifiles.com/include/dblayer/functions_mysqli.inc.php on line 181

My second project, the http://ottawastockimages.com/, is a hybrid now, it is not 2.5, but not quite 2.6. Automatic upgrade stopped half way through, most of the back end features are unavailable.

I have a feeling that open source platform is not for everyone.

Offline

 

#9 2014-01-26 04:27:40

drmaemo
Member
2013-07-11
13

Re: 2.6 Installation Trouble

faqvideo wrote:

flop25 wrote:

noooo the option here is to "downloaded it again -on your computer- and overwrite all files -by sending them by Ftp-" That's all

Just to be clear - I downloaded the piwigo2.6.zip file and extracted it. I understand if I delete all my files on the server, that will mean I will have to start from scratch?

I am looking at the Manual Upgrade manual here:

http://piwigo.org/basics/upgrade_manual

Most of it is abra-cadabra for me. I understand that I don't want to delete following folders:
galleries
upload
plugins
template-extension
local

Is there anything else I need to worry about? Can you explain it in plain English SVP? I am not a programmer, mostly photographer with access to Filezilla.

Merci.

Hi faqvideo,

This may be a bit late; however, it is highly recommended to back up the website files and database. Use FileZilla (ftp client) to copy the entire piwigo directory stored on the server to your local hard drive, which will back up the website files.

Because your Piwigo thinks there is an update, click on the Update link. Look for a link that will download/backup the current database. I recall seeing this option when I did my update from 2.5 to 2.6 this morning. If you see the option in the Piwigo Update page to download/backup the database do it.

After successfully backing up both the website and website database, you have two approaches to consider.

1. Based on the image posted, it appears your website files are 2.6. I wonder if the upgrade prompt is due to the database not getting upgraded. You could use FileZilla to do a quick check of select files on the server are indeed 2.6. If so, you could try Step 7 Database repair and the update.php script, and if that fails, try the Optimize and Repair tool in the Piwigo Maintenance administration page.

2. You can simply use FileZilla to copy over the 2.6 extracted files over to the website server, which should just add new files or overwrite files on the server (but not delete). If FileZilla asks you to delete, say no. The second option is to follow the manual installation instructions beginning with step 4.

What happens if both options fail horribly?
That's okay, you can return to the current state by restoring the database and the website files that were backed up originally.

What to do if the database cannot be backed up using the Piwigo Upload page?
Your website host should have a utility that will backup the website database. Will need to consult with your host on how to use it. You should become familiar with your host database utility as it is the tool needed to restore website databases. If you cannot backup the database, then it seems Option 1 above would be my first step.

All the best.

Al

Offline

 

#10 2014-01-28 05:32:44

faqvideo
Member
2012-01-21
114

Re: 2.6 Installation Trouble

Thank you all. I managed to recover the http://ottawastockimages.com/

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact