Announcement

#1 2013-12-08 15:35:04

faqvideo
Member
2012-01-21
114

Facebook preview trouble

Hello,

It has started recently - Facebook woul'd not generate a thumbnail preview of any picture page from the Piwigo album. I followed experts suggestion and tried the FB Debugger (https://developers.facebook.com/tools/debug).

Here is the message:

***
Critical Errors That Must Be Fixed
Error Linting URL    An internal error occurred while linting the URL.
(see the image attached).
***

I don't get it - whether this is a FB internal error, or if there is something wrong on my server?
Any ideas?


Uploaded Images

Offline

 

#2 2013-12-08 15:43:44

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Facebook preview trouble

Perhaps FB returns this error because the is nothing to analyse : OG are not integrated in Piwigo

[Github] Piwigo issue #239

Offline

 

#3 2013-12-08 15:50:24

faqvideo
Member
2012-01-21
114

Re: Facebook preview trouble

It has just stopped working two days ago. Until then everything went smooth.

Offline

 

#4 2013-12-08 15:51:48

faqvideo
Member
2012-01-21
114

Re: Facebook preview trouble

Oh yes, my site is http://ottawastockimages.com/

Offline

 

#5 2013-12-12 03:39:22

faqvideo
Member
2012-01-21
114

Re: Facebook preview trouble

Bumping it up. The problem persists - Facebook stopped showing the preview images from my pages. Really cold turkey with no warning one day it's just stopped working.

I am still capable posting links form other sources with no troubles. Is there something with the server or Piwigo installation? Please help if you can.

Offline

 

#6 2013-12-18 00:00:26

faqvideo
Member
2012-01-21
114

Re: Facebook preview trouble

The DreamHost support semi-final verdict goes like this:

"Hm... I'm not sure what could be blocking the images...

I found this link (which is rather old), where they had the same issue as
you:

http://forum.bytesforall.com/showthread.php?t=4528

This leads me to believe that it might be an issue between the theme you
are using, a plugin that is enabled, or it is facebook. Also check to see
if there is any hotlinking protection on your installation, which could
prevent FB from accessing the images. If there is anything else you need
help with, please let me know! Thanks! Have a great day!"

So it does not look like something has gone wrong on the server. I don't remember doing any major Piwigo upgrades within last two or three weeks. There must be something happening behind the Facebook lines.

If anyone figures what is the trouble and how to fix it, please let me know. And again - am I the only victim of this glitch?

Merry Christmas!

Offline

 

#7 2014-01-17 14:51:32

faqvideo
Member
2012-01-21
114

Re: Facebook preview trouble

The silence on this matter is very intriguing.  Am I the only Piwigo user having trouble with Facebook preview thumbnails? Or rather with their absence?

I still can't figure what may be the problem. Few possibilities here:

1. Piwigo code
2. Theme code (Stripped & Columns)
3. Facebook code (still no reply from the FB support after 3 inquiries)
4. Problem with the server (the Dreamhost support team could not find any)
5. All of the above
6. Nothing of the above

Please share your experience with posting links to your pages at Facebook.

Offline

 

#8 2014-01-29 00:18:47

faqvideo
Member
2012-01-21
114

Re: Facebook preview trouble

Bumping it up one more time.

I was hoping for the 2.6 upgrade, but not much has changed. Facebook would not show previews from my Piwigo page links. Can anybody try to reproduce the problem?

I am still trying to figure what is the problem, whether it's Facebook, or Piwigo, or my server.

Offline

 

#9 2014-03-11 20:35:31

faqvideo
Member
2012-01-21
114

Re: Facebook preview trouble

Thanks everybody - the Facebook preview started working seemingly by itself.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact