Announcement

  •  » Extensions
  •  » Images crashing when using plugin Twitter Cards

#1 2014-04-24 19:48:55

marenninni
Member
2014-04-24
8

Images crashing when using plugin Twitter Cards

Hi!

Does anyone know why the images keep "disappearing" when I install the Twitter Card plugin (http://piwigo.org/ext/extension_view.php?eid=759)?
I have validated my domain for twitter cards, but twitter keeps saying invalid image format, and the Twitter Card plugin keep giving me this (see image):


Uploaded Images

Offline

 

#2 2014-04-24 20:00:21

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Images crashing when using plugin Twitter Cards

I notified the author

Offline

 

#3 2014-04-24 20:41:01

umrysh
Member
2014-03-20
9

Re: Images crashing when using plugin Twitter Cards

Ahoy marenninni,

I have updated the extension to use the IMAGES_TABLE constant instead of hard coding the table name.

Thank you mistic100 for the recommendation :)

Please update and let me know if you encounter any more issues. My apologizes for the inconvenience and thank you for bringing this to my attention.

Offline

 

#4 2014-04-24 21:03:05

marenninni
Member
2014-04-24
8

Re: Images crashing when using plugin Twitter Cards

Thanks!

But: I still can't get the twitter card to function.

http://marenlockertsen.com/ImageGallery

Any suggestion to what I'm doing wrong?
I've validated marenlockertsen.com, and everything seems okay, apart from the error message saying invalid image format (see image).


Uploaded Images

Offline

 

#5 2014-04-24 22:17:24

umrysh
Member
2014-03-20
9

Re: Images crashing when using plugin Twitter Cards

Hey marenninni,

I entered a url to one of your photos on the "validate & apply" tab and it is saying the "twitter:title" field is missing.

This may be the issue.

I noticed on the photo in question you do not have a title entered in Piwigo. Would you be able to edit the photo and enter a title and then test it's url in the validator?

If this fixes the issue I may need to adjust the code to deal with the possibility of blank photo tiles.

Thanks marenninni


Uploaded Images

Offline

 

#6 2014-04-24 22:26:32

marenninni
Member
2014-04-24
8

Re: Images crashing when using plugin Twitter Cards

I tried with another photo with title now (http://marenlockertsen.com/ImageGallery … ategory/10), and the same happens.

:(

Sorry!
Other suggestions?

(I've updated all titles that were just space, to something else to try and fix it from my end)

Last edited by marenninni (2014-04-24 22:39:12)

Offline

 

#7 2014-04-24 22:44:18

umrysh
Member
2014-03-20
9

Re: Images crashing when using plugin Twitter Cards

No need to apologize. I am confident we will figure this out :)

I just tried to open the link to the thumbnail and I am getting a 404 error

(http://marenlockertsen.com/upload/2014/ … _thumb.jpg)

Could you verify that the above file does indeed exist on your server?

If it exists, we may simply have a permissions issue.

If it doesn't exist then I have some coding to do :)

Last edited by umrysh (2014-04-24 22:49:59)

Offline

 

#8 2014-04-24 22:55:47

marenninni
Member
2014-04-24
8

Re: Images crashing when using plugin Twitter Cards

Yes it does indeed exist.
:D

(see image)

Permission 0644


Uploaded Images

Last edited by marenninni (2014-04-24 22:58:45)

Offline

 

#9 2014-04-24 23:11:02

umrysh
Member
2014-03-20
9

Re: Images crashing when using plugin Twitter Cards

Good news is I figured out the issue. Bad news is I have a few things I need to get done at my day job before I can work on it.

My code is not adding in "ImageGallery" to the url of the thumbnail.

It should be displaying the following:

http://marenlockertsen.com/ImageGallery … _thumb.jpg

I will post back when I push an update for the extension.

Thanks for all your help

Offline

 

#10 2014-04-24 23:14:16

marenninni
Member
2014-04-24
8

Re: Images crashing when using plugin Twitter Cards

And thank you for responding so quickly and for making this work!

Great work!

Offline

 

#11 2014-04-25 04:51:50

umrysh
Member
2014-03-20
9

Re: Images crashing when using plugin Twitter Cards

Good evening marenninni,
When you get a chance to test I have pushed an update to the extension.

It should now be aware if Piwigo is installed in a sub-directory and adjust the urls accordingly :)

Thanks again marenninni

Offline

 

#12 2014-04-25 10:34:24

marenninni
Member
2014-04-24
8

Re: Images crashing when using plugin Twitter Cards

Hi and good morning!

I have tried now (deleted the plugin and installed it anew just to be sure), but it still seems like it cannot find the image format or something.

See images.

And thank you for doing all this work, the plugin and all!


Uploaded Images

Offline

 

#13 2014-04-25 11:22:06

marenninni
Member
2014-04-24
8

Re: Images crashing when using plugin Twitter Cards

Wohoo! It works!

Thank you once again!

(update: strange. It worked and then i did not work. It worked on the images in one album, but not in another. I'm starting to believe something's wrong with the new twitter layout or something)


Uploaded Images

Last edited by marenninni (2014-04-25 11:30:24)

Offline

 

#14 2014-04-26 03:42:10

umrysh
Member
2014-03-20
9

Re: Images crashing when using plugin Twitter Cards

Awesome :)

I seem to remember back when I had first gotten Twitter to validate my site it didn't always work. Sometimes I would have to delete the tweet and re-tweet the link so it would "catch".

I haven't had that happen for sometime now though so the issues may be based on how long your site has been validated for.

Have a great weekend!

Offline

 
  •  » Extensions
  •  » Images crashing when using plugin Twitter Cards

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact