Announcement

#1 2014-10-01 10:16:36

waldemars
Guest

Update to 2.7 error

Hello/Hi/Greetings,

I am trying to update my Piwigo v 2.4.5 to 2.7 on the "Piwigo update" tab. I get the following error message: Abort pclzip.lib.php : Missing zlib extensions.

What can i do?

Piwigo version: 2.4.5
PHP version: 5.3.27
MySQL version: 5.5.20
Piwigo URL: http://

 

#2 2014-10-01 11:01:15

flop25
Piwigo Team
2006-07-06
6932

Re: Update to 2.7 error

Hello
maybe you could search before asking, so you could find the Upgrade guide, and see that you can do a manual update...


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2014-10-01 11:21:28

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13192

Re: Update to 2.7 error

Hi waldemars,

Give a look at [Forum, topic 24493] Upgrade zlib error?

Offline

 

#4 2014-10-06 08:22:05

waldemars
Guest

Re: Update to 2.7 error

This fixed the problem:

1. Please go \\Your_IP\Web\piwigo\admin\include\ and open the “pclzip.lib.php” file.
2. Find “if (!function_exists('gzopen'))” and change it to “if (!function_exists('gzopen64'))”, then save it.
3. Go to Administration > Tools > Updates and follow the guide.

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact