Piwigo.org

You are not logged in. (Register / Login)

Announcement

#1 2017-04-20 23:21:15

cyberbud
Member
Registered: 2017-04-20
Posts: 2

Notification email contains port

Hello,

I am quite new to Piwigo and I try to resolve an issue for which I can't find a solution, either on the forum (even if I may didn't search well) nor on google.

I just tried to get a notification email from my piwigo gallery, and in it, there is some links.
Unfortunately, my gallery is in https and the links received in the email are all followed by the port ":80" like https://mydomain.com:80
When clicking on it, I get an error page, as https should be redirected on port 443.

Where can I configure the links not to add the port at the end of them, or to set the right port?

Emails are using the "clear" template

Piwigo version: 2.8.6
PHP version: 5.6
MySQL version: 5.6

Many thanks for any help

cyberbud

Offline

 

#2 2017-04-21 09:43:23

cyberbud
Member
Registered: 2017-04-20
Posts: 2

Re: Notification email contains port

Hello

I was able to solve it.
In the template "notification_by_mail.tpl" file, I can see
<a href="{$UNSUBSCRIBE_LINK}">{$UNSUBSCRIBE_LINK}</a>

Then I was able to see that this UNSUBSCRIBE_LINK variable refers to get_gallery_home_url() function, but I am not yet able how to force the return of this variable.

It is linked to the $conf['gallery_url'] parameter, that is present in the include/config_default.inc.php file

:-)

Last edited by cyberbud (2017-04-21 09:48:50)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact