Announcement

#1 2017-08-17 10:25:04

axe1987
Member
2017-08-16
2

[resolved] No Galleries or Images after Update to 2.9.1

Greetings,

since my piwigo is update to version 2.9.1 only I can see albums or images (me as being webmaster).
Normal users can not see my albums nor their own.
If I switch a user to webmaster everything works fine. But I do not want to make everyone a webmaster.

I did check the permissions:
All albums are private!
All albums can be seen by my group family!
All users are in the family group!
I did always set the rights recusivly!

All I could figure out is that the array of forbidden_categories is always filled with all category id's. This would explain why no other user can see albums and images. But why is that array filled wrong and therefore saved in the database user cache table.

Any Ideas? Hints?

Greetings axe1987

Piwigo version: 2.9.1
PHP version: 5.6.30-
MySQL version: mysql  Ver 15.1 Distrib 10.0.32-MariaDB
Piwigo URL: http://

Offline

 

#2 2017-08-17 11:46:17

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13082

Re: [resolved] No Galleries or Images after Update to 2.9.1

Hi axe1987,

Did you "lock" albums? If yes, then unlock them. Locking an album means only webmaster/administrator can see it.


Latest blog post (March 23th 2017) Piwigo.com Enterprise plans, now official!

Offline

 

#3 2017-08-17 11:50:14

axe1987
Member
2017-08-16
2

Re: [resolved] No Galleries or Images after Update to 2.9.1

Hey,

I guess another webmaster must have fiddled with the albums in that way.
I didn't even check that..

Thanks so much, it is working now.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact