Piwigo.org

You are not logged in. (Register / Login)

Announcement

#1 2017-03-29 05:52:49

matt
Member
Registered: 2017-03-29
Posts: 1

LDAP Support

Greetings,

I need LDAP support for Piwigo.  The existing extension with various tweaks don't work correctly.  When I try to save the settings, it tells me the plugin is not activated.  Or the original version says successful, but the string is wrong (like ldaps:\\ldaps:\\servername) and cannot login.

I tried Apache authentication, but I don't have $conf[‘apache_authentication’  in the config_default.inc.php file.

Piwigo is so good, so functional, but LDAP needs addressing!!

Piwigo version: 2.8.6
PHP version: 5.3.3
MySQL version: 5.1.73
Piwigo URL: http:// private

Can anyone help?  Funding might be available!

Thanks,

Matt

Offline

 

#2 2017-06-30 09:41:15

teekay
Member
Registered: 2013-06-12
Posts: 286

Re: LDAP Support

I guess it shouldn't be too hard to extend the Piwigo-Social-Connect plugin for a generic OpenID provider and use Keycloak with LDAP user federation.

Last edited by teekay (2017-06-30 09:49:10)

Offline

 

#3 2017-08-20 03:16:33

svoeth
Member
Registered: 2017-08-20
Posts: 1

Re: LDAP Support

hey,

it took me some time, but in the end i found a working ldap plugin. It is based on the old Ldap_Login by december22 but adapted to work with the current version of piwigo.

https://github.com/kvakanet/ldap_login/tree/config2base
or direct link: https://github.com/kvakanet/ldap_login/ … g2base.zip

unzip and move the extracted folder (ldap_login-config2base) to the plugin directory (usually /var/www/piwigo/plugins/)
rename folder to ldap_login

go to the admin interface and activate.

Then go to plugin-settings and adapt to our LDAP.

Important:
The settings in "Server Settings -> Base DN" and "LDAP User -> User Branch" stack.
in my example all my users are in "ou=users,dc=example,dc=com"

So i set my Base DN to "dc=example,dc=com" (both in Server Settings and also in Ldap attributes.
in "LDAP Users -> Users Branch" i set "ou=users"

AND IT WORKS! :)

P.S. you also need to have php-ldap/php5-ldap (depends on your system) installed

Last edited by svoeth (2017-08-20 03:18:29)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact