Piwigo.org

You are not logged in. (Register / Login)

Announcement

#31 2017-08-24 15:06:43

russmcclay
Member
Registered: 2017-08-24
Posts: 20

Re: Everthing "works" but loads of errors at top of pages.

That plugin is disabled and the output from:


  $date = str2DateTime($original, $format); -----> Line 649

   print_r($lang);

is:

Array ( )
Notice: Undefined index: day in /home/winggang/public_html/gallery/include/functions.inc.php on line 667

Notice: Undefined index: month in /home/winggang/public_html/gallery/include/functions.inc.php on line 673
Array ( )
Notice: Undefined index: day in /home/winggang/public_html/gallery/include/functions.inc.php on line 667

Notice: Undefined index: month in /home/winggang/public_html/gallery/include/functions.inc.php on line 673

Warning: Cannot modify header information - headers already sent by (output started at /home/winggang/public_html/gallery/include/functions.inc.php:651) in /home/winggang/public_html/gallery/include/page_header.php on line 101

Last edited by russmcclay (2017-08-24 15:07:37)

Offline

 

#32 2017-08-24 15:12:49

flop25
Piwigo Team
Registered: 2006-07-06
Posts: 6603
Website

Re: Everthing "works" but loads of errors at top of pages.

Thank you
Are you the admin of the server? can you set a different Php version?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#33 2017-08-24 15:27:50

russmcclay
Member
Registered: 2017-08-24
Posts: 20

Re: Everthing "works" but loads of errors at top of pages.

I own the VPS under which many sites exist.  I can't change the PHP version; maybe the host can (Hostforweb) but I don't think so.  It's late here in Taiwan.  I've had enough of Piwigo for one day.  I will continue to try to help my friend have a Piwigo photo gallery tomorrow. Thank you for your help.

Maybe Rob can change his PHP version since he has the exact same problem that I have.

Last edited by russmcclay (2017-08-24 15:31:42)

Offline

 

#34 2017-08-24 15:32:20

flop25
Piwigo Team
Registered: 2006-07-06
Posts: 6603
Website

Re: Everthing "works" but loads of errors at top of pages.

Thanks a lot
If you are on a VPS you can set enable php version which can be chosen by the website/Virtualhost

I don't understand that issue which sounds like a Php mistake


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#35 2017-08-25 02:09:25

russmcclay
Member
Registered: 2017-08-24
Posts: 20

Re: Everthing "works" but loads of errors at top of pages.

What PHP version do you suggest? I would be concerned about changing the PHP version just for Piwigo since none of my client accounts are having any problems with their sites. 

I find it so odd that only Rob, who started this thread, and I have this problem and that no one at Piwigo understands the issue.

Here is my environment:

Piwigo 2.9.1
Operating system: Linux
PHP: 5.4.44 (Show info) [2017-08-25 00:07:08]
MySQL: 5.6.28 [2017-08-24 20:07:08]
Graphics Library: ImageMagick 6.7.2-7

Offline

 

#36 2017-08-25 02:13:19

flop25
Piwigo Team
Registered: 2006-07-06
Posts: 6603
Website

Re: Everthing "works" but loads of errors at top of pages.

"no one at Piwigo understands the issue." well I'm by far the less qualified and I asked for help. That's the holidays so don't expect anything soon

about Php i don't want to trouble you. That's ok, forget it. If you have other servers you could test Piwigo on them


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#37 2017-08-25 04:06:56

russmcclay
Member
Registered: 2017-08-24
Posts: 20

Re: Everthing "works" but loads of errors at top of pages.

RobPatton wrote:

Adding $conf['show_php_errors'] = E_ALL & ~E_NOTICE;

(after turning on the plugin, and creating a file)

Has made all the errors stop.

This is just hiding the error, Rob.  Question, if you go to the Configuration page,
.../admin.php?page=configuration

Under Miscellaneous, do you see anything in the dropdown for Week Starts On?

Please refer to the screenshot.

If not, it is probably related to the errors you and I have with Undefined index for day and month values.


Uploaded Images

Last edited by russmcclay (2017-08-25 04:08:08)

Offline

 

#38 2017-08-25 04:12:04

russmcclay
Member
Registered: 2017-08-24
Posts: 20

Re: Everthing "works" but loads of errors at top of pages.

flop25 wrote:

"no one at Piwigo understands the issue." well I'm by far the less qualified and I asked for help. That's the holidays so don't expect anything soon

about Php i don't want to trouble you. That's ok, forget it. If you have other servers you could test Piwigo on them

I do appreciate all the help you have offered, flop25. And I know you've been helping people here for a long while. 

I am determined to solve this problem because after seeing some of the functionality of Piwigo as a first-time user, I really want it to work!  I use Gallery 2 on other sites, but I wanted to try another type of gallery.

My programming team will be looking at the problem today, maybe we'll find something.  Otherwise, I'll hide the errors and live with it until maybe some of your team mates can offer some comments or suggestions.

Last edited by russmcclay (2017-08-25 04:12:39)

Offline

 

#39 2017-08-25 11:30:23

russmcclay
Member
Registered: 2017-08-24
Posts: 20

Re: Everthing "works" but loads of errors at top of pages.

I have solved the problem!

It was a permission setting for the language directory.

Originally it was this:

drw-r--r-- 72 winggang winggang  4096 Apr 20 01:08 language/

Then I ran this:

chmod 755 language/

drwxr-xr-x 72 winggang winggang  4096 Apr 20 01:08 language/

--

All errors are gone and the month shows in all the places it was missing before.

Problem solved, case closed!

Offline

 

#40 2017-08-25 13:31:21

flop25
Piwigo Team
Registered: 2006-07-06
Posts: 6603
Website

Re: Everthing "works" but loads of errors at top of pages.

what? just simple as that? I... erh...
https://media.giphy.com/media/3jN3GziOKUEmI/giphy.gif

all folders should be 755 and files 644

was your installation a netinstall?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#41 2017-08-26 04:21:42

russmcclay
Member
Registered: 2017-08-24
Posts: 20

Re: Everthing "works" but loads of errors at top of pages.

Hi flop25,

I was as astounded as you.  I installed Piwigo via CPanel's Softaculous app installer.

I'm not sure if the permissions for that directory were original as I had trouble the first day trying to upload photos. The host provider (Host for Web) said they adjusted the file permission and it might've been right there that the incorrect permissions were set.

The upload problem was due to mod security rules being too restricted. The host whitelisted the offending rules.

My clue that language was where to look was those tests we did in the code.  The problem code used the $lang var.  So when I went to add a new language (my site is single language English), I noticed there were none set.  And when I tried to set one it failed. That led to your colleague to have me check the file permissions. 

What a world.

Thanks again.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact