Piwigo.org

You are not logged in. (Register / Login)

Announcement

#1 2017-08-16 06:51:11

executive
Member
Registered: 2017-08-16
Posts: 47

[Community 2.9.a-beta] Error: post_max_size

Hello

I am getting errors when trying to upload photos with a non-admin account

- I click "Upload Photos" from the left side menu bar
- Upload page loads, but "drag files here" box is missing. Instead, there is a message "Your browser doesn't have HTML5 support."
- When I click the "Add Photos" button, the page reloads and I get a red error message:
    "The uploaded files exceed the post_max_size directive in php.ini: 8MB"
- Uploading photos works normally when logged in with admin account.

In cpanel PHP options the "file_uploads" directive is enabled. "upload_max_filesize" directive is set to 32M.

Environment:
    Piwigo 2.9.1
    Operating system: Linux
    PHP: 5.6.31 (Show info) [2017-08-16 04:41:33]
    MySQL: 5.6.35 [2017-08-15 21:41:33]
    Graphics Library: ImageMagick 6.9.4-10

Piwigo URL: http://mountainmanjoe.ca/gallery/


Uploaded Images

Offline

 

#2 2017-08-16 10:20:10

plg
Piwigo Team
Location: Nantes, France, Europe
Registered: 2002-04-05
Posts: 13080
Website

Re: [Community 2.9.a-beta] Error: post_max_size

OK, perfectly reported. I have added a link to this forum topic on the related issue [Github] Piwigo-community issue #31


Latest blog post (March 23th 2017) Piwigo.com Enterprise plans, now official!

Offline

 

#3 2017-09-04 15:59:10

plg
Piwigo Team
Location: Nantes, France, Europe
Registered: 2002-04-05
Posts: 13080
Website

Re: [Community 2.9.a-beta] Error: post_max_size

I'm working on this issue, but I can't reproduce it :-/ I have installed a fresh Piwigo 2.9.1 + Community 2.9.a-beta but I have no problem to see the upload form and upload some photos with a non admin user.

Can you give me more details? What is the status of the user? Do you see anything in the web browser console (like a javascript error)?


Latest blog post (March 23th 2017) Piwigo.com Enterprise plans, now official!

Offline

 

#4 2017-09-04 20:58:23

executive
Member
Registered: 2017-08-16
Posts: 47

Re: [Community 2.9.a-beta] Error: post_max_size

:-/
Je sais pas, Pierrick!
When I test it now, there is no problem. When I made this post, I had a brand new installation of Piwigo. Since then I have made many, many changes, so it's hard to say what might have affected it.

I will try again with a fresh installation when I have time.

Offline

 

#5 2017-09-13 22:00:07

Will
Member
Registered: 2014-08-19
Posts: 6

Re: [Community 2.9.a-beta] Error: post_max_size

Hi,

I am getting this exact problem from users I've created on my board.  If I log in as me, the admin, I can upload images.

But if I log in as one of my students, The upload screen says the browser doesn't have html5 support. When I click 'add photos' I get this:
The uploaded files exceed the post_max_size directive in php.ini: 105MB

I'm running:
Piwigo 2.9.1
Operating system: Linux
PHP: 5.6.31 (Show info) [2017-09-13 12:50:06]
MySQL: 5.6.34-log [2017-09-13 12:50:06]
Graphics Library: ImageMagick 6.7.7-10

I've attached a screen shot of the plugins I'm currently running

I tried disabling all my plugins except for Community and the error remains.

Thanks for your help,
Will

PS The users are all in a group with the privacy level set to 'family'

thanks again

Last edited by Will (2017-09-13 22:05:19)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact