Announcement

#1 2015-10-29 00:11:50

damon18
Member
Memphis, TN USA
2015-10-28
5

Missing titles and descriptions after menalto2piwigo import

Hello, thanks for creating Piwigo and making this support forum available.

I have been using Menalto Gallery 2 for many years, embedded in my website

http://www.thebeachcats.com/pictures

the actual gallery installation is here

http://www.thebeachcats.com/gallery2/main.php

As you can see, the gallery is quite large are 10+ years of member uploads with over 20,000 images.

Info from the Gallery install.
Rows in GalleryAccessMap table = 1677
Rows in GalleryAccessSubscriberMap table = 21203
Rows in GalleryUser table = 9663
Rows in GalleryItem table = 21071
Rows in GalleryAlbumItem table = 1265
Rows in GalleryCacheMap table = 0

I installed a fresh Piwigo on a new subdomain and used the menalto2piwigo extension to import from a copy of the Gallery 2 database, after a few glitches because of spaces in stored filenames were resolved I was able to import everything and maintain the album structure, very nice!

Only two problems remain I hope you will help with.

1. The import didn't bring in any of the Titles, Summaries,  or Descriptions of the albums and items that are stored in the Gallery 2 database. The albums and items are only titled with their actual filenames.

Can I get the Titles, Summaries, and Descriptions into Piwigo?

2. The sizes of the images. In my Gallery install most albums are setup to limit/resize the largest image to 1600 max pixels and to also create a thumbnail and midsize (700 pixel) version.

See these two image pages of the same thing from Gallery 2 and Piwigo
http://www.thebeachcats.com/pictures?g2_itemId=109639 (max size 1600 px)
http://piwigo.thebeachcats.com/picture. … egory/1651 (max size 792 px)

Is there a way to get the full size images into Piwigo? Or maybe this is a theme issue?

Piwigo version
Piwigo 2.7.4
Environment
Operating system: Linux
PHP: 5.3.29 (Show info) [2015-10-28 18:44:53]
MySQL: 5.5.45-cll [2015-10-28 17:44:53]
Graphics Library: External ImageMagick 6.7.2-7

Offline

 

#2 2015-11-03 14:21:15

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Missing titles and descriptions after menalto2piwigo import

Hi damon18,

damon18 wrote:

1. The import didn't bring in any of the Titles, Summaries,  or Descriptions of the albums and items that are stored in the Gallery 2 database. The albums and items are only titled with their actual filenames.

Can I get the Titles, Summaries, and Descriptions into Piwigo?

menalto2piwigo should handle them! I remember it was working fine on my test.

Did you modify the directory name on your filesystem? This is what Piwigo uses to match with your Menalto database.

damon18 wrote:

2. The sizes of the images. In my Gallery install most albums are setup to limit/resize the largest image to 1600 max pixels and to also create a thumbnail and midsize (700 pixel) version.

See these two image pages of the same thing from Gallery 2 and Piwigo
http://www.thebeachcats.com/pictures?g2_itemId=109639 (max size 1600 px)
http://piwigo.thebeachcats.com/picture. … egory/1651 (max size 792 px)

Is there a way to get the full size images into Piwigo? Or maybe this is a theme issue?

On Piwigo, you seem to have hidden the size selector. Here I see the Medium size and you should be able to display a bigger size.


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#3 2015-11-03 20:09:19

damon18
Member
Memphis, TN USA
2015-10-28
5

Re: Missing titles and descriptions after menalto2piwigo import

Thanks for your help, I'm new to Piwigo but have tried to read everything I can find in the docs.

plg wrote:

Hi damon18,
Did you modify the directory name on your filesystem? This is what Piwigo uses to match with your Menalto database.

Not sure which directory name you mean.
Here are the steps I used to build Piwigo and do the import.

1. Used the Piwigo netinstaller to install Piwigo to the root of a new subdomain. http://piwigo.thebeachcats.com

2. Copied my Gallery 2 data directory to the root of the subdomain. (it has a unique name for security on Gallery 2)

3. Copied the contents of the Gallery 2 albums directory into the Piwigo galleries directory.

4. Installed the menalto2piwigo extension and ran the import.

plg wrote:

On Piwigo, you seem to have hidden the size selector. Here I see the Medium size and you should be able to display a bigger size.

I've only used the themes that came with Piwigo and haven't modified them at all, is there a setting?

Where are the resize sizes set in administration? I've attached a screenshot of my
configuration - Photo Sizes page but all I see is the setting for max size.

This and the other screenshot attached also show some glitches with the install where I'm getting wrong characters from the font-awesome icons and broken images although the images that are broken are indeed where they should be. For instance http://piwigo.thebeachcats.com/admin/th … n/help.png does exist.

Where are the actual resized images stored in the Piwigo file system?

I think I don't quite understand how Piwigo handles all this compared to Gallery 2.

Thanks for any help you can offer.


Uploaded Images

Last edited by damon18 (2015-11-03 20:11:35)

Offline

 

#4 2015-11-05 02:34:36

erAck
Member
2015-09-06
158

Re: Missing titles and descriptions after menalto2piwigo import

damon18 wrote:

1. Used the Piwigo netinstaller to install Piwigo to the root of a new subdomain.
2. Copied my Gallery 2 data directory to the root of the subdomain. (it has a unique name for security on Gallery 2)
3. Copied the contents of the Gallery 2 albums directory into the Piwigo galleries directory.

Likely the combination was the problem. The G2 data directory contains the albums and images, but all metadata like tags, titles and descriptions are in the SQL database. If the G2 data path/name differed from the configured one, things probably go awry. Check in your gallery2/config.php (your G2 installation IS reachable for the m2p import script, isn't it?) that the database is accessible on your new subdomain as indicated, and the $gallery->setConfig('data.gallery.base', '...') points to the actual location of the data directory on the subdomain's server.

Pre-populating Piwigo's galleries directory is at least unnecessary if not getting in the way.. the m2p import copies the albums and images to the galleries directory so you end up with Piwigo physical categories (aka albums).

Did the m2p import actually do anything? i.e. did it find the G2 database and the data directory? If yes, maybe it skipped every image that was already present under galleries. What you see in Piwigo might just be what you copied into the galleries directories.

If things are just too twisted then install Piwigo on the same subdomain (but different path of course, e.g. one that you later want to make the new subdomain's documentroot, or you'll have to move things after import) G2 is on, so the m2p import can find the G2 installation and database. Piwigo should be relocatable (hopefully ;-)


Running Piwigo at https://erack.net/gallery/

Offline

 

#5 2015-11-11 23:44:32

damon18
Member
Memphis, TN USA
2015-10-28
5

Re: Missing titles and descriptions after menalto2piwigo import

erAck, Thanks for the additional info on how the import works.

I didn't realize the step of copying the contents of /data/albums into /galleries was optional.

And yes I think the menalto2piwigo script was able to connect to the (copy) of the gallery 2 database.

I'm going to try this again from scratch.

On the original Gallery 2 install that I'm trying to reproduce on Piwigo (on the new subdomain)

Gallery 2 is installed in the /home/domain/public_html/gallery2 directory
Gallery 2 data directory is above the site root at /home/domain/data

When I did the transfer installed Piwigo directly in the public_html directory of the new subdomain, and copied
/home/old-domain/data
to
/home/new-domain/public_html/data

I didn't actually setup a working Gallery 2 in the new subdomain, just made a copy of it's database in the cPanel/phpMyAdmin of the subdomain for Piwigo to connect to.

Any other suggestions would be appreciated, I'm going to try this again from scratch and better match the paths to the old setup. I'll also use the full download instead of the installer, maybe that will help with the unavailable icons (permission problems) I've got.

Offline

 

#6 2015-11-12 02:00:02

damon18
Member
Memphis, TN USA
2015-10-28
5

Re: Missing titles and descriptions after menalto2piwigo import

One more thing please before I try this again.

In the docs on Github under "Finishing Up" there is a note that I'll need the "Extended Comments" extensions for descriptions to show up.

I can't seem to find that. I've found "Extended Descriptions" at http://piwigo.org/ext/extension_view.php?eid=175 is that the one that is required?

Offline

 

#7 2015-11-12 17:16:25

erAck
Member
2015-09-06
158

Re: Missing titles and descriptions after menalto2piwigo import

erAck wrote:

Pre-populating Piwigo's galleries directory is at least unnecessary if not getting in the way.. the m2p import copies the albums and images to the galleries directory so you end up with Piwigo physical categories (aka albums).

Sorry, this seems to be wrong, I misremembered the steps I did. It indeed seems to be necessary to copy menalto/albums/* to piwigo/galleries/

Again, sorry for misleading you.


Running Piwigo at https://erack.net/gallery/

Offline

 

#8 2015-11-12 18:18:54

erAck
Member
2015-09-06
158

Re: Missing titles and descriptions after menalto2piwigo import

damon18 wrote:

One more thing please before I try this again.

In the docs on Github under "Finishing Up" there is a note that I'll need the "Extended Comments" extensions for descriptions to show up.

I can't seem to find that. I've found "Extended Descriptions" at http://piwigo.org/ext/extension_view.php?eid=175 is that the one that is required?

That seems to be necessary only if you want album descriptions to be different outside (i.e. a short description) and within (i.e. a longer description) the album, or use other features of the plugin. Conversion went alright for me without, including album and image descriptions.


Running Piwigo at https://erack.net/gallery/

Offline

 

#9 2015-11-12 23:30:20

damon18
Member
Memphis, TN USA
2015-10-28
5

Re: Missing titles and descriptions after menalto2piwigo import

Thanks, I got a little frustrated, tried to do the import a bunch of times without copying the albums.

When I tried it that way I was getting php errors, kept checking everything and trying again until finally just copied the albums and it worked.

But in the end I was able to convert my Gallery 2 install to Piwigo! Only some minor edits now for sort order and it doesn't look like the album highlights were brought forward in every case.

I also have some albums where the users put BBCODE into the titles, this worked in Gallery 2 but not in Piwigo. (which is fine, I never wanted them to do it anyway, just have to clean it up.)

Anyway, maybe it will help another Gallery 2 user to know it is possible.

Here is my old Gallery 2 install.
http://piwigo.thebeachcats.com/gallery2/main.php

and the same on Piwigo
http://piwigo.thebeachcats.com/piwigo/

Thanks for your support.

Last edited by damon18 (2015-11-12 23:31:18)

Offline

 

#10 2016-02-24 14:30:06

mcgeepj2
Member
2016-01-25
28

Re: Missing titles and descriptions after menalto2piwigo import

I'm just now trying to do this with my G3 album (http://www.f-106deltadart.com/photo_gallery/ ) with the same result of no Titles or Descriptions importing.  I am sure however, that I'm doing something wrong.

I copied the contents of var/albums/ into piwigo/galleries and then ran Synchronise.  However, when I tried to run the Import I got an error 'No Menalto tables found!'.  So I know it connected to the _gll5 database where the gallery 3 is stored, but it didn't find Menalto tables?

What am I doing wrong?

Offline

 

#11 2016-02-25 05:33:46

mcgeepj2
Member
2016-01-25
28

Re: Missing titles and descriptions after menalto2piwigo import

GOT IT!  Yahoo

Offline

 

#12 2017-10-10 23:22:09

Steel Rat
Member
2017-10-10
11

Re: Missing titles and descriptions after menalto2piwigo import

plg wrote:

Did you modify the directory name on your filesystem? This is what Piwigo uses to match with your Menalto database.

I know this is an old thread, but hoping I can get some help.

I actually moved the G2 album contents to the galleries folder under piwigo. A lot of files came in fine, but I got a lot of "wrong filename" errors, and no descriptions or anything but the photos. Is it because the albums and photos didn't exist in the original spot where Gallery2 could find them?

I can try again, but will have to upload all the files again from my PC.

Thanks!

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact