Announcement

#1 2018-02-26 16:10:47

pjgaus
Member
Pittsburgh, PA
2015-12-23
12

Update to 2.9.3, now jplayer broke

Hello/Hi/Greetings,

Just upgraded to Piwigo version 2.9.3.  Now jplayer is broke.  When i choose a video file to view, the screen goes to white with the following error message:

Fatal error: 'break' not in the 'loop' or 'switch' context in /home2/paus/public_html/gauwigo/plugins/piwigo-jplayer/include/getid3/getid3.lib.php on line 285

Is this something that I should wait for jplayer to be modified for the new Piwigo, or is it something I need to fix?

Piwigo version: 2.9.3
PHP version: 7.0.25
MySQL version: 5.5.51-38.2

Offline

 

#2 2018-02-26 19:30:05

executive
Member
2017-08-16
400

Re: Update to 2.9.3, now jplayer broke

I'm not sure, but you should post plugin related questions in the 'Extensions' section.

There is a bug report for the problem you describe:
[Github] piwigo-jplayer issue #14

Just looking at the plugin page, it says it hasn't been updated since 2013, so I wouldn't expect much.

Maybe try the "piwigo-videojs" plugin? It is more recent.

Online

 

#3 2018-02-26 21:02:11

pjgaus
Member
Pittsburgh, PA
2015-12-23
12

Re: Update to 2.9.3, now jplayer broke

Sorry for posting to trouble shooting.

I did figure out a solution.  I changed from php 7.0 to php 5.4.

Everything now works.

Offline

 

#4 2018-02-28 01:48:05

erAck
Member
2015-09-06
135

Re: Update to 2.9.3, now jplayer broke

pjgaus wrote:

I changed from php 7.0 to php 5.4.

You should switch to PHP 5.6 (currently 5.6.33 latest), everything earlier is horribly outdated, unmaintained and full of holes.


Running Piwigo at https://erack.net/gallery/

Offline

 

#5 2018-02-28 02:13:15

pjgaus
Member
Pittsburgh, PA
2015-12-23
12

Re: Update to 2.9.3, now jplayer broke

Thanks for the advise.   DONE

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact