Announcement

  •  » Themes
  •  » modus theme vs "default theme" issue (solved)

#1 2018-03-04 20:03:54

gernoth
Member
2018-03-04
1

modus theme vs "default theme" issue (solved)

Dear all,

I am running latest piwigo with modus theme and what I love most is its responsive design - it looks great on smartphones.

Now, I have observed a bad behaviour. I have seen it first 2018-02-26, cannot say if it appeared before.
I was able to resolve this issue myself but I thought I'd share my observation in case anyone else runs into it.

On a smartphone, FOR ANONYMOUS USERS, the html renders for full width in a strange theme I do not know.. Same for a normal web browser of which I resize the window to make it e.g. 400px wide
on the contrary, when I LOG IN with my ADMIN USER, the modus theme is applied and everything looks perfect.

It appeared that my selection of modus theme is NOT applied to anonymous sessions.

and then I looked in the themes admin panel. modus is the ONLY theme listed as "active". BUT it did not say "modus (default), instead I had a "default" button BELOW the theme thumbnail.
(think: which OTHER theme is taken if there is only one active theme? :))
now I pressed that "default" BUTTON, and now the theme title reads "modus (default)" and everything works again as it should

can it be that a new flag was introduced in the recent version?
Anyway, when there is only ONE theme it should always be used for anonymous sessions?!?

all the best and thanks for a happy user!!




Piwigo version: 2.9.3
my gallery: http://www.fournoses.at/gallery/
modus theme version 2.9.a

Offline

 
  •  » Themes
  •  » modus theme vs "default theme" issue (solved)

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact