Announcement

#1 2018-02-27 17:51:20

Zakky24
Member
2017-09-13
11

Blank Screen when attempting login

Hi,

I've been running Piwigo for 3-4 years now, but all of a sudden the site has started to fail.  I cannot log in - I just get a blank page.

I've asked for support from my hosting company and I've been told that the error is;

"I have had a look at your case and it appears that the issue is occurring once the website tries to make a connection via a fetch_row function to your database in order to check for existing user within the database, however, it fails and thus opens a white page.

Furthermore, the exact error message which I have located is:

[message] => Call to a member function fetch_row() on boolean
    [file] => ~/public_html/include/dblayer/functions_mysqli.inc.php
    [line] => 231
"

I can't check the version etc. as I'm unable to login!  Nothing has been changed in this php file.

Please help!!

Thanks,

Zakky24

Piwigo version:
PHP version:
MySQL version:
Piwigo URL: http://www.hydeimagelibrary.com

Offline

 

#2 2018-02-27 20:58:53

executive
Member
2017-08-16
258

Re: Blank Screen when attempting login

Offline

 

#3 2018-02-28 13:38:01

Zakky24
Member
2017-09-13
11

Re: Blank Screen when attempting login

Thanks for the information.  Unfortunately my hosting business doesn't seem to offer a "repair" function on databases (not that I can see), so I'm currently waiting for a response from them...

If anyone has any other ideas I'd appreciate hearing them!

Thanks.

Offline

 

#4 2018-03-01 09:37:25

flop25
Piwigo Team
2006-07-06
6799

Re: Blank Screen when attempting login

if it suddenly changed it's mostly a server change made by your hostingcompany

currently their mysql server is off
[mysql error ]
Can't connect to server

#1    my_error /var/sites/h/hydeimagelibrary.com/public_html/include/common.inc.php(128)
#2    include_once /var/sites/h/hydeimagelibrary.com/public_html/index.php(26)


which webhosting company is it ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#5 2018-03-01 10:31:35

Zakky24
Member
2017-09-13
11

Re: Blank Screen when attempting login

Hi,

Thanks for the response.  It is hosted by TSOHost who are pretty reliable.  I think something has gone wrong with the SQL database as I've been unable to login to it via phpMyAdmin.  I asked them to create a copy which seems to be complete, but obviously has a different name/IP address.

I've tried to repoint Piwigo to this new database - and now I get the error you see.  All looks fine from the hosting side (I can acces the database and have run a repair utility which highlighted no errors).

With the (very) little knowledge I have I'm now out of ideas as to what to do next - short of deleting the whole thing and starting again.  This is something I want to avoid as I had 6,000+ images (18gb) and 100 users.

If I do have to reset is there a database I can access to recover the users?  The images I have backups of which will just need to be reuploaded.

Thanks for your help - it's very very much appreciated.

John

Offline

 

#6 2018-03-01 10:42:47

flop25
Piwigo Team
2006-07-06
6799

Re: Blank Screen when attempting login

Zakky24 wrote:

I've tried to repoint Piwigo to this new database - and now I get the error you see.

so the informations are incorrect :the system can't connect to the mysql server


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2018-03-01 10:52:13

Zakky24
Member
2017-09-13
11

Re: Blank Screen when attempting login

I've now tweaked the settings and no longer get the error - just back to the blank screen that started the whole problem!!

Offline

 

#8 2018-03-01 10:59:43

flop25
Piwigo Team
2006-07-06
6799

Re: Blank Screen when attempting login

there are several message on the forum dealing with blank screen: it happens when the server crash without any proper error message handling
check server logs and try to change the graphic library used by Piwigo


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#9 2018-03-01 11:35:23

Zakky24
Member
2017-09-13
11

Re: Blank Screen when attempting login

Unfortunately I can't get access to the old database, and the duplicate has 0 events shown.

Piwigo is set up to 'auto' in terms of the graphic library.  I've tried changing it to 'gd' as a fallback and it made no difference.

Offline

 

#10 2018-03-01 12:01:10

flop25
Piwigo Team
2006-07-06
6799

Re: Blank Screen when attempting login

check with imagick too

you probably need that your hoster checks its internal logs


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#11 2018-03-02 00:16:32

executive
Member
2017-08-16
258

Re: Blank Screen when attempting login

You never told us your PHP version.

Offline

 

#12 2018-03-02 10:16:40

Zakky24
Member
2017-09-13
11

Re: Blank Screen when attempting login

According to the back office on the host it's 5.6.  I believe they tried changing it to 7.0 when I first had the failure, but it made no difference.  Is there a setting within a config file that needs changing?

Thanks.

Offline

 

#13 2018-03-04 08:50:14

Zakky24
Member
2017-09-13
11

Re: Blank Screen when attempting login

Finally got this resolved.  It was 100% the fault of the hosting company.  They had a disk failure which left my database corrupt/part complete (it only had tables up to piwigo_history for example).

I finally managed to get a backup copy of the database from them from a month or so ago.  Everything now seems to be working fine.

I would just like to thank flop25 & executive for being so responsive and helpful - thank you, without your suggestions I would've probably wiped the entire database and started again!

Next time I'll look more closely at the host and not Piwigo!!

Thanks,

John

Offline

 

#14 2018-03-04 21:53:42

executive
Member
2017-08-16
258

Re: Blank Screen when attempting login

Glad you got it figured out, and thanks for following up here.

This is also a reminder to me that I should make regular database backups.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact