Announcement

#1 2018-04-05 00:32:12

HARW
Member
UK
2018-04-04
3

Ajax error on User List

Hi,

I am getting the following error when I open the Manage Users screen:

DataTables warning: table id=userList - Ajax error. For more information about this error, please see http://datatables.net/tn/7

[img]ajaxerror1.jpg[/img]
I followed the datatables.net link but I'm none the wiser.

If I OK the alert then the users are not displayed, but I can still use the Select All option and successfully apply actions to the "invisible" users.

Browser debugging indicates a 403 error in user_list_backend.php. From the Network/Headers tab in the debugger:
General
Request URL: https://thepicturetree.co.uk/gallery/ad … ackend.php
Request Method: POST
Status Code: 403
Remote Address: 151.252.3.12:443
Referrer Policy: no-referrer-when-downgrade
Response Headers
accept-ranges: bytes
alt-svc: quic=":443"; ma=2592000; v="35,37,38,39"
cache-control: private, no-cache, no-store, must-revalidate, max-age=0
content-length: 1139
content-type: text/html
date: Wed, 04 Apr 2018 22:27:58 GMT
pragma: no-cache
server: LiteSpeed
status: 403
Request Headers
:authority: thepicturetree.co.uk
:method: POST
:path: /gallery/admin/user_list_backend.php
:scheme: https
accept: application/json, text/javascript, */*; q=0.01
accept-encoding: gzip, deflate, br
accept-language: en-US,en;q=0.9,en-GB;q=0.8
content-length: 677
content-type: application/x-www-form-urlencoded; charset=UTF-8
cookie: roundcube_cookies=enabled; pwg_id=aca8ka33htajecqikm1kt4mok3
origin: https://thepicturetree.co.uk
referer: https://thepicturetree.co.uk/gallery/ad … =user_list
user-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36
x-requested-with: XMLHttpRequest


Browsing to https://thepicturetree.co.uk/gallery/ad … ackend.php displays:

Notice: Undefined index: sSearch in /home/ggohmeaa/public_html/gallery/admin/user_list_backend.php on line 107
Notice: Undefined variable: sOrder in /home/ggohmeaa/public_html/gallery/admin/user_list_backend.php on line 146
Notice: Undefined index: sEcho in /home/ggohmeaa/public_html/gallery/admin/user_list_backend.php on line 169

plus some (valid) JSON containing the user list.

This is a clean install of Piwigo with no active plugins. I have tried uninstalling/reinstalling, but the error remains. Being new to Piwigo and PHP, and not having found this particular error in the forum or documentation, I'm struggling to see what is causing it.

Any help will be gratefully received!


Piwigo 2.9.3
Operating system: Linux
PHP: 7.0.28 (Show info) [2018-04-04 12:09:08]
MySQL: 5.5.5-10.1.32-MariaDB [2018-04-04 12:09:08]
Graphics Library: External ImageMagick 6.7.8-9
Piwigo URL: https://thepicturetree.co.uk/gallery/


Uploaded Images

Offline

 

#2 2018-04-05 09:24:50

flop25
Piwigo Team
2006-07-06
6801

Re: Ajax error on User List

Hello

i'm quite surprised: the server returns a 403 but, when you are logged as admin, you get a result

i'm notifying "my superior" ^^


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2018-04-05 10:13:22

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13132

Re: Ajax error on User List

What does your web browser says in the "response" tab for the Ajax POST request?


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#4 2018-04-05 11:42:41

HARW
Member
UK
2018-04-04
3

Re: Ajax error on User List

Hi

Thanks for responding.

plg, this is the content of the response tab:

Code:

<!DOCTYPE html>
<html style="height:100%">
<head><title> 403 Forbidden
</title></head>
<body style="color: #444; margin:0;font: normal 14px/20px Arial, Helvetica, sans-serif; height:100%; background-color: #fff;">
<div style="height:auto; min-height:100%; ">     <div style="text-align: center; width:800px; margin-left: -400px; position:absolute; top: 30%; left:50%;">
        <h1 style="margin:0; font-size:150px; line-height:150px; font-weight:bold;">403</h1>
<h2 style="margin-top:20px;font-size: 30px;">Forbidden
</h2>
<p>Access to this resource on the server is denied!</p>
</div></div><div style="color:#f0f0f0; font-size:12px;margin:auto;padding:0px 30px 0px 30px;position:relative;clear:both;height:100px;margin-top:-101px;background-color:#474747;border-top: 1px solid rgba(0,0,0,0.15);box-shadow: 0 1px 0 rgba(255, 255, 255, 0.3) inset;">
<br>Proudly powered by  <a style="color:#fff;" href="http://www.litespeedtech.com/error-page">LiteSpeed Web Server</a><p>Please be advised that LiteSpeed Technologies Inc. is not a web hosting company and, as such, has no control over content found on this site.</p></div></body></html>

Offline

 

#5 2018-04-05 22:51:33

HARW
Member
UK
2018-04-04
3

Re: Ajax error on User List

Aha! It looks like this issue is down to a ModSecurity rule being applied by my hosting provider. Temporarily disabling ModSecurity through cPanel allows the User List to be displayed. I will raise this with my provider, so hopefully they can amend the rules.

Offline

 

#6 2018-04-06 10:58:18

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13132

Re: Ajax error on User List

Thank you for this feedback. I had no idea why it occured!


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#7 2018-04-06 15:44:08

flop25
Piwigo Team
2006-07-06
6801

Re: Ajax error on User List

ha I should have remembered this!
It already happened; usually it come from lengthy arguments


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact