Announcement

#1 2017-11-13 23:20:54

magnum2k
Member
2017-11-13
2

Notice: Undefined index: day / month / year

Hi

I'm a new/old user of Piwigo.. I've had Piwigo installed on my server before and then deleted it. I've recently installed 2.9.2 and installed some plugins..

All was working well, then suddenly I started getting these errors when I go to my galleries.
This only happens when I click on any picture within my albums.

Notice: Undefined index: day in ...../public_html/piwigo/include/functions.inc.php on line 665

Notice: Undefined index: month in ...../public_html/piwigo/include/functions.inc.php on line 671

Notice: Undefined index: day in ...../public_html/piwigo/include/functions.inc.php on line 665

Notice: Undefined index: month in ...../public_html/piwigo/include/functions.inc.php on line 671

I also see a similar error in the configuration page/Options General tab where there is the "week starts on"

Notice: Undefined index: day in ...../public_html/piwigo/admin/configuration.php on line 366

Notice: Undefined index: day in ...../public_html/piwigo/admin/configuration.php on line 367

I've tried checking the mysql (mariadb) tables and those that reference day, month, year is the history.summary and they are blank.

I'm think if dropping the piwigo database and rebuilding the installation again, but I want to understand what happened and try to fix or avoid it next time.

Piwigo version: 2.9.2
PHP version: 7.1
MySQL version: MariaDB 10.2

Offline

 

#2 2017-11-14 05:54:38

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6717

Re: Notice: Undefined index: day / month / year

Hi :-)

Your' create new language ?

Language default ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#3 2017-11-14 06:19:32

magnum2k
Member
2017-11-13
2

Re: Notice: Undefined index: day / month / year

Hi..

I figured out why I got those errors.

I was deleting all  unused languages, including English (UK)

Only kept English (US), Francais (QC) and Italiano and that's when the problem happened.

I added back English (UK) and it fixed the problem.

Perhaps include a note or fix for  the next revision..

Thanks

Offline

 

#4 2018-05-22 22:51:21

Marcet
Member
2018-05-22
1

Re: Notice: Undefined index: day / month / year

Thanks for reporting.

I was facing the same issue.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact