Announcement

#1 2018-05-22 06:54:03

phnord
Member
2018-05-22
3

Random images showing as broken links

Hi,

I just set up piwigo on AWS and everything seemed to be working until I changed to the modus theme. Now random images are showing up as broken links. If I refresh the page a few times I can get them to show up normally. I have tried clearing cache and using different computers. The issue is also present with the Bootstrap Darkroom theme but I have not encountered it with the original elegant theme.  If I try to click on the broken link images I get this error message:


Warning: mysqli::__construct(): (HY000/2002): No such file or directory in /var/www/html/photos/include/dblayer/functions_mysqli.inc.php on line 67

Warning: my_error(): Couldn't fetch mysqli in /var/www/html/photos/include/dblayer/functions_mysqli.inc.php on line 837

Warning: my_error(): Couldn't fetch mysqli in /var/www/html/photos/include/dblayer/functions_mysqli.inc.php on line 837
Piwigo encountered a non recoverable error
[mysql error ]
Can't connect to server

#1    my_error /var/www/html/photos/include/common.inc.php(128)
#2    include_once /var/www/html/photos/picture.php(25)

Can anyone assist? I would much prefer the modus theme.


Piwigo version: Latest
PHP version: 7
MySQL version: 5+
Piwigo URL: http://

Thanks!

Offline

 

#2 2018-05-23 03:30:40

phnord
Member
2018-05-22
3

Re: Random images showing as broken links

I saw a comment elsewhere suggesting I may have been running out of RAM which caused MySQL to crash. I added an extra gig of swap file space to my server and I think it has resolved the issue.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact