Announcement

  •  » Engine
  •  » Missing EXIF data

#1 2018-06-05 16:48:35

marfig
Member
2013-12-12
38

Missing EXIF data

Hello,

since I've upgraded my favorite photo editor (Zoner Photo Studio) to the latest version, Piwigo (PHP) doesn't see GPS data in EXIF.
I'm aware that Piwigo isn't directly responsible for this issue, as metadata.php doesn't show any GPS data. It seems to be due to bug in PHP itself. Something like
https://bugs.php.net/bug.php?id=50660&edit=3

Unfortunately I can update PHP version, as it's running on Synology NAS and there isn't any update available (at least I didn't find any way how to update it).

Do you see any idea, workaround how to help piwigo to read GPS data again?

I tried to open not working files via several EXIF editors and resave them, but without any success. Issue in JPEG seems to happen during conversion from RAW to JPEG.

Piwigo version: 2.9.3
PHP version: 7.0.28-0025

Thank you
Best regards
Martin

Offline

 

#2 2018-06-06 09:29:20

teekay
Member
2013-06-12
390

Re: Missing EXIF data

marfig wrote:

PHP version: 7.0.28-0025

That's good enough, I guess.

Please use ExifTool to check if GPS metadata really got added.

If that's the case, you could try one of those extensions, in order:
https://piwigo.org/ext/extension_view.php?eid=850 (with ExifTool from https://www.cphub.net/?p=exiftool)
https://piwigo.org/ext/extension_view.php?eid=858 (with ImageMagick)

Last edited by teekay (2018-06-06 09:36:18)

Offline

 

#3 2018-06-06 10:36:51

marfig
Member
2013-12-12
38

Re: Missing EXIF data

@teekay: thank you so much, it works :) :)

regards
Martin

Offline

 
  •  » Engine
  •  » Missing EXIF data

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact