Announcement

#1 2018-06-13 22:40:24

ra6768
Member
2018-01-08
17

Slow upload with SSL

Hello/Hi/Greetings,

I'm having trouble uploading pictures when using SSL pages. It can take up to 4 minutes to load 2 pictures. First the progress bar goes all the way and then hangs in there for quite some time. If I disable the SSL redirect then pictures are uploaded lightning fast. Is there anything in the configuration of piwigo that I need to modify when using SSL on the pages? If so, can you point me out to what? I search the forum and Google as well, but no clue.
Regards,
VV

Piwigo 2.9.3
Operating system: Linux
PHP: 7.2.5-0ubuntu0.18.04.1 (Show info) [2018-06-13 20:36:09]
MySQL: 5.7.22-0ubuntu18.04.1 [2018-06-13 20:36:09]
Graphics Library: ImageMagick 6.9.7-4

Offline

 

#2 2018-06-15 06:23:17

ra6768
Member
2018-01-08
17

Re: Slow upload with SSL

Hi,
I can see there are no answers, perhaps I didn't explain the problem properly. So, one more try, perhaps I get better luck this time, I don't believe I'm the only one with this kind of problems anyway.
If I use a non secured site like this one the pictures get uploaded almost instantly. However, as soon as I redirect http:// to https:// the pictures loads also very quickly. The progress bar goes full instantly and the orange circle in the tab shows 100% and gets stuck there. If I leave the page a warning comes up and if I ignore and go to the first page the picture is there!
If you have any ideas or anybody else who is using secure pages is not experiencing these problems and can share some information, please do so.
This is a fresh install of piwigo from scratch, the database is empty (only one picture when I took the screenshots) and the database return healthy parameters. I also attached a picture of my currently activated plugins, but if I remove all the plugins the situation is the same anyway.
Regards,
VV


Uploaded Images

Offline

 

#3 2018-06-17 01:06:19

Zentalquabula
Member
2014-05-10
79

Re: Slow upload with SSL

You problem has nothing to do with Piwigo. Check your apache config.

Make sure you are redirecting all traffic from port 80 to 443:

Code:

<VirtualHost *:80>
  ServerName your.host
  RewriteEngine On
  RewriteCond %{HTTPS} off
  RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI}
</VirtualHost>

Better yet, just turn off port 80 completely, and use https and http/2 exclusively.

Offline

 

#4 2018-06-17 13:18:36

erAck
Member
2015-09-06
98

Re: Slow upload with SSL

If you don't have permissions to modify the apache configuration you can use this .htaccess approach, though the VirtualHost in .conf is better suited.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact