Announcement

#1 2019-01-13 02:56:52

spiked
Member
2019-01-13
2

Synology NAS Install - "Cannot connect to server"

Hello/Hi/Greetings,

Trying to get Piwigo working on my Synology NAS DS218plus.

Piwigo files have been placed in a folder in my NAS web server directory (note the web server and MariaDB are currently working fine with a Webtrees installation), and file permissions set for all the folders and descendants. Created database using phpMyAdmin in MariaDB, and created a new database user and password, with all privileges.

When I run the setup by invoking the URL, I get the setup page. I enter localhost, the new db user name and password, the database name, and the default folder prefix ('piwigo_').

In response I get 'Cannot connect to server'.

Any idea what I'm doing wrong? I see others in the forums have had similar problems, but see no forum replies which have given any solutions. I also see some here and around the web who claim to have successfully installed Piwigo on a Synology NAS, and have it working.

If any of those who got it working are reading this, was there any special config necessary to do so? Am I overlooking something?

Thanks for any help!

Neil

Piwigo version: 2.9.4
PHP version: 7.0.30
MySQL version: MariaDB 10.3.7
Piwigo URL: http://

Offline

 

#2 2019-01-14 05:35:16

spiked
Member
2019-01-13
2

Re: Synology NAS Install - "Cannot connect to server"

I managed to get both Piwigo and Zenphoto to work on my Synology NAS. It was a database socket issue.

To fix, from the Synology DSM webpage:

Open Web Station config.

PHP settings

For each PHP version/profile you have installed, select it, click Edit, then select the Core tab. Search on 'socket'. Select mysql.default_socket and enter this value, without the quotes: '/run/mysqld/mysqld10.sock'. Do the same for mysqli.default_socket if present.

Both Piwigo and Zenphoto were able to access their databases after making this change.

Enjoy!

Neil

Offline

 

#3 2019-01-15 09:41:54

bsdll
Member
2019-01-15
2

Re: Synology NAS Install - "Cannot connect to server"

Just adding this in for future reference for anyone else trying to set piwigo up on a Synology NAS.

I didn't do the step you mentioned, you just have to reference the port in the server name:

127.0.0.1:3307

Since it's MariaDB not MySQL it's a different port.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact