Announcement

#1 2019-04-03 17:14:06

mikekiwi
Member
2019-03-14
5

YATT - Exif/IPTC; I'm close but it still doesn't work like it should

Hi,

I've recently setup a Piwigo install and am now finetuning looks and use. I'm pretty much getting the hang of it, but the metadata still is not working like it should. I've read the wiki, adjusted the localfiles according to it, but still no 100% succes.

Below you can find the url to my testsetup with one album with three images (2 with IPTC-info, 1 with exif, please refer to the filename  to see which is which).

IPTC-looks pretty fine

The other image contains a lot of Exif-info, but is not shown. Somehow I can't figure out why not. I think I have all show/use-fields mentioned but nothing appears on the website.

Can you please help me out?


    Piwigo 2.9.4
    Operating system: Linux
    PHP: 7.1.27 (Show info) [2019-04-03 15:03:11]
    MySQL: 5.7.25-0ubuntu0.16.04.2 [2019-04-03 17:03:11]
    Graphics Library: ImageMagick 6.8.9-9

Piwigo URL: http://piwigo.h2824128.stratoserver.net/

Code:

<?php

$conf['derivative_url_style'] = 1;


$conf['use_exif'] = true;
$conf['show_exif'] = true;

$conf['show_exif_fields'] = array(
  'DateTimeOriginal',
  'Make',
  'Model',
  'ExposureProgram',
  'FocalLengthIn35mmFilm',
  'FNumber',
  'ExposureTime',
  'ISOSpeedRatings',
  'Flash',
  'WhiteBalance',
  'UserComment'
  );

$conf['use_iptc'] = true;

$conf['use_iptc_mapping'] = array(
  'author'          => '2#080',
  'author'          => '2#085',
  'name'            => '2#005',
  'comment'         => '2#120',
  'keywords'        => '2#025',
  );

$conf['show_iptc'] = true;

$conf['show_iptc_mapping'] = array(
  'iptc_creator'         => '2#080',
  'iptc_title'           => '2#005',
  'iptc_headline'        => '2#105',
  'iptc_description'     => '2#120',
  'iptc_keywords'        => '2#025',
  );

$conf['tags_default_display_mode'] = 'groups';
$conf['sync_chars_regex'] = '/^[a-zA-ZäÄëËöÖüÜ0-9-_. \']+$/';
$conf['piwigo_privacy_allow_whitespaces'] = true;
$conf['piwigo_privacy_allow_special_chars'] = true;
?>

Offline

 

#2 2019-04-03 18:05:08

flop25
Piwigo Team
2006-07-06
6948

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

Hello
have you tried to use the file /tools/metadata.php ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2019-04-03 18:12:57

mikekiwi
Member
2019-03-14
5

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

flop25 wrote:

Hello
have you tried to use the file /tools/metadata.php ?

Well, I've used the read-metadata-plugin and that shows all the exif-information correctly (there is much more then is shown in the attachment)


Uploaded Images

Last edited by mikekiwi (2019-04-03 18:13:58)

Offline

 

#4 2019-04-03 18:24:07

flop25
Piwigo Team
2006-07-06
6948

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

for me when I go to your website and click on the icon to show the metadata I get a strange behavior where nothing happens, nothings changes ...


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#5 2019-04-03 18:42:13

mikekiwi
Member
2019-03-14
5

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

flop25 wrote:

for me when I go to your website and click on the icon to show the metadata I get a strange behavior where nothing happens, nothings changes ...

Exactly, that's my experience as well...hence my post here. I even have the "Alwaysshowmetadata"-plugin installed since today and that doesn't change the situation.

I tried several themes (Elegant is now default), but that doesn't make any difference

Offline

 

#6 2019-04-03 18:46:20

flop25
Piwigo Team
2006-07-06
6948

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

have you synchronized the metadata after changing the config?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2019-04-03 18:48:03

mikekiwi
Member
2019-03-14
5

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

flop25 wrote:

have you synchronized the metadata after changing the config?

Yep, and that worked correctly according to the now correctly displayed IPTC-information

Offline

 

#8 2019-04-03 19:22:26

executive
Member
2017-08-16
591

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

I uploaded your exiforg image to my Piwigo and it worked fine.

What happens if you put Piwigo back to a "factory" state? Try to disable all metadata related plugins, and localfiles editor, and choose some basic theme.
Does it display exif then?

Offline

 

#9 2019-04-03 20:29:55

mikekiwi
Member
2019-03-14
5

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

executive wrote:

What happens if you put Piwigo back to a "factory" state? Try to disable all metadata related plugins, and localfiles editor, and choose some basic theme.
Does it display exif then?

Well, that helped! I delete all text from the localfile-editor and the site started moaning about a "derivative_url_style"-line not being present. This was for the piwigo_privacy plugin.
I deactivated the plugin et voila, all EXIF-information present.

So I was looking at the metadata-settings while it was this plugin causing the trouble. (activating the plugin immediately starting the same issues).

So that's clear, now to find an alternative way to enhance security or make this plugin work (I can see some information on the Github-site of the plugin)... As in the definitive site we are going to publish original very large files we need to protect them...

Offline

 

#10 2019-04-03 23:25:26

flop25
Piwigo Team
2006-07-06
6948

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

From the description of the privacy plugin I don't see why it's better than https://piwigo.org/ext/extension_view.php?eid=216


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#11 2019-05-14 19:27:08

EdwinKort
Translation Team
Rhoon, the Netherlands
1970-01-01
88

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

mikekiwi wrote:

Hi,


Code:

<?php

$conf['derivative_url_style'] = 1;


$conf['use_exif'] = true;
$conf['show_exif'] = true;

$conf['show_exif_fields'] = array(
  'DateTimeOriginal',
  'Make',
  'Model',
  'ExposureProgram',
  'FocalLengthIn35mmFilm',
  'FNumber',
  'ExposureTime',
  'ISOSpeedRatings',
  'Flash',
  'WhiteBalance',
  'UserComment'
  );

$conf['use_iptc'] = true;

$conf['use_iptc_mapping'] = array(
  'author'          => '2#080',
  'author'          => '2#085',
  'name'            => '2#005',
  'comment'         => '2#120',
  'keywords'        => '2#025',
  );

$conf['show_iptc'] = true;

$conf['show_iptc_mapping'] = array(
  'iptc_creator'         => '2#080',
  'iptc_title'           => '2#005',
  'iptc_headline'        => '2#105',
  'iptc_description'     => '2#120',
  'iptc_keywords'        => '2#025',
  );

$conf['tags_default_display_mode'] = 'groups';
$conf['sync_chars_regex'] = '/^[a-zA-ZäÄëËöÖüÜ0-9-_. \']+$/';
$conf['piwigo_privacy_allow_whitespaces'] = true;
$conf['piwigo_privacy_allow_special_chars'] = true;
?>

Thanks. This helped me figuring the wy to display exif as well ;) Nice site, btw


My Gallery
Hosted with: Surpass Hosting since 2004

Offline

 

#12 2019-05-19 23:12:04

EdwinKort
Translation Team
Rhoon, the Netherlands
1970-01-01
88

Re: YATT - Exif/IPTC; I'm close but it still doesn't work like it should

Since adding the above in the local file editor, not all photo's are displayed anymore.


Using version 2.9.5 of Piwigo and the GreyDragon theme


My Gallery
Hosted with: Surpass Hosting since 2004

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact