Announcement

#1 2019-10-08 20:05:38

Knitter
Member
Denmark
2016-05-26
87

Upgrade went wrong

Hello/Hi/Greetings,

How can I turn my Piwigo back to an earlier version? 
I upgraded to v. 2.10.0, and my site was totally destroyed. Now I want to go back to my earlier version, but how can I do that?
Please help me  :(

Piwigo version: 2.10.0
PHP version: 7.1.32
MySQL version: 5.5.5.-10.3.18-MariaDB
Piwigo URL: http://soejberg.com

Offline

 

#2 2019-10-08 20:09:25

homdax
Member
Sweden
2015-02-02
107

Re: Upgrade went wrong

It seems to work?

The upgrade encourages you to backup the database. You should do that as a minimum, but also consider backing up all files too. Then you can restore it if something goes wrong.

Offline

 

#3 2019-10-09 05:27:03

Jan Becket
Member
2015-01-17
22

Re: Upgrade went wrong

My sympathies. When that happens, we ALL wish we had the foresight to do a massive backup ...

I had what might be a similar issue when I upgraded today. The Piwigo home screen of my site was completely filled with error messages. It turned out to be an incompatibility with Firefox and disappeared when I accessed the site with Safari - on my Mac. As part of your troubleshooting, try another browser. Good luck.

Offline

 

#4 2019-10-09 12:08:35

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13271

Re: Upgrade went wrong

Hi Knitter,

I see you're now in Piwigo 2.10.0 and it seems to work fine, as homdax says.

What was the problem? how did you solve it? (it might help other users).

Cheers,

Offline

 

#5 2019-10-09 16:53:55

Knitter
Member
Denmark
2016-05-26
87

Re: Upgrade went wrong

Thank you all for answering me. =)
It is not an error message, but the design.
I can best illustrate, what I mean by showing some screenshots of my site before and after.
I can say that I don't like masonry style, it does not serve my purpose, and I certainly do not like the square photos


Uploaded Images

Offline

 

#6 2019-10-09 16:57:29

Knitter
Member
Denmark
2016-05-26
87

Re: Upgrade went wrong

The first 2 screenshots are after the change, and the last two are before, and almost like I prefer

Offline

 

#7 2019-10-09 20:40:55

erAck
Piwigo Team
2015-09-06
277

Re: Upgrade went wrong

Check Admin -> Configuration -> Themes, maybe your previous theme was deactivated and now the modus theme is active.


Running Piwigo at https://erack.net/gallery/

Online

 

#8 2019-10-09 20:49:02

Jan Becket
Member
2015-01-17
22

Re: Upgrade went wrong

That is exactly what happened with one of my upgrades to 2.10. The Modus theme replaced the Elegant theme I had been using. However, in my case the Modus looks better and I switched all Piwigo installations to that theme :)

Offline

 

#9 2019-10-09 21:21:19

Knitter
Member
Denmark
2016-05-26
87

Re: Upgrade went wrong

@ erAck

thank you very much, that did the trick.  I thought that I had checked the themes and found that they had not been updated, but they had anyway.

Offline

 

#10 Yesterday 21:01:54

AlgoNatural
Member
2019-10-14
2

Re: Upgrade went wrong

Hello
I'm also a newbie and also my theme was disactiveted
But I don't find the place where install a new theme

In attachment how I see my backend

Can you help me?

Thanks

Offline

 

#11 Today 09:54:28

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13271

Re: Upgrade went wrong

erAck wrote:

Check Admin -> Configuration -> Themes, maybe your previous theme was deactivated and now the modus theme is active.

That is what happened, let me tell everybody how the upgrade process works, for themes:

1) all "not embedded by default" themes are deactivated. In Piwigo 2.10, themes embedded by default are : modus, elegant, smartpocket.

2) if the default user (guest, id=2) is not using an active theme, switch it to modus.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact