Announcement

#1 2006-04-15 12:07:15

Hardcorehansi
Member
2006-04-15
4

Skript doesnt find Thumbnails - but they exist ???

i have create the thumbnails once with the skript and once without
and in both cases i getr these error:

[./galleries/sports/00001.jpg] PWG-UPDATE-2 (missing thumbnail)

please  help me!!

--------------------------------
Environment

        * Operating system: Linux
        * PHP: 5.0.4 (Show info)
        * MySQL: 4.1.16-log
----------------------------------

I´m from Austria so my english is not so good, sorry that ;-)
friebdly regards Hardcorehansi

Offline

 

#2 2006-04-15 13:05:02

volcom
Former Piwigo Team
2005-01-24
489

Re: Skript doesnt find Thumbnails - but they exist ???

hi,

Do you have GD Library installed with PHP ? You could see that with Show Info in admin page. You need it to create thumbnails.

Offline

 

#3 2006-04-16 11:25:28

Hardcorehansi
Member
2006-04-15
4

Re: Skript doesnt find Thumbnails - but they exist ???

i think i have this GD installed, because the thumbnails were produced correctly.
there are thumbnails in the direktory were it should be
gallery\sports\thumbnails

GD is shurly installed (cheked with php info link in Administrtion)
but is there any problem with "php safe mode on" ???

Last edited by Hardcorehansi (2006-04-16 11:37:17)

Offline

 

#4 2006-04-16 12:07:39

volcom
Former Piwigo Team
2005-01-24
489

Re: Skript doesnt find Thumbnails - but they exist ???

Did you create the thumbnail with the prefix set in config_local.inc.php ? What are their names ?

Offline

 

#5 2006-04-16 12:20:24

Hardcorehansi
Member
2006-04-15
4

Re: Skript doesnt find Thumbnails - but they exist ???

for exampel:
pic: 000014
thumb: TN-000014


it seems there is a general problem with that thumbnail creation.

here is a screen:
http://www.peter.dreamteam.at/chunk/screen.jpg

Last edited by Hardcorehansi (2006-04-16 12:36:14)

Offline

 

#6 2006-04-19 10:11:57

Hardcorehansi
Member
2006-04-15
4

Re: Skript doesnt find Thumbnails - but they exist ???

no one has a solution for me ;-(
thats very bad 4 me

Offline

 

#7 2006-04-19 12:05:21

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: Skript doesnt find Thumbnails - but they exist ???

Hardcorehansi wrote:

[./galleries/sports/00001.jpg] PWG-UPDATE-2 (missing thumbnail)

PWG Logic:
- galleries
        |-> sports
        |          |-> thumbnail

00001.jpg is in sports directory

Depending on value of
$conf['prefix_thumbnail'] = 'TN-';
Your thumb would be in thumbnail directory with name of thumbnail/TN-00001.jpg
or thumbnail/TN-00001.png

Check the value of $conf['prefix_thumbnail'], you should find it :
in include/config_local.inc.php (if that module exists)
or in include/config_default.inc.php (if config_local.inc.php does not exist)

http://www.peter.dreamteam.at/chunk/screen.jpg shows that your thumbnails have been created successfully
But usually you will get size information as for example:

generated in      filesize           width          height
149.19 ms          2 KB              150             87

So, I think thumbs aren't correctly generated, check if they are available in thumbnail directory.
If they aren't.
Maybe you have to create thumbnail directory manually and if rigths are corrects (CHMOD 755 for thumbnail directory).

Another way is to create picture and thumbnail via FTP and ...
Synchronize in the Admin menu without simulation.

Enjoy PWG !!!


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#8 2006-04-20 11:32:39

mathiasm
Former Piwigo Team
2006-02-06
2648

Re: Skript doesnt find Thumbnails - but they exist ???

Hi Hardcorehansi

Simply check that your directory is named thumbnail, without the s at the end. From what you said, this is the main error I see.

Regards

Offline

 

#9 2008-08-26 00:50:45

nogard999
Member
2008-08-25
2

Re: Skript doesnt find Thumbnails - but they exist ???

I used to have the same problem, this is what I did to fix it:


1) Creater your directories via FTP.
2) Also create the "thumbnail" directory
3) Change the CHMOD to 777 for the "thumbnail" directory.
4) Create thumbnails via PHPWebGallery
5) Change CHMOD to 755 for the "thumbnail" directory via FTP
6) Syncronize via PHPWebGallery , and you are done!.


Hope it helps.

Nogard

PS: Excellent work PHPWebGallery is the best!

Offline

 

#10 2008-08-27 01:01:48

rio
Piwigo Team
Paris
2006-07-24
1430

Re: Skript doesnt find Thumbnails - but they exist ???

:-/
only perform a simulation (no change in database will be made) active or not?


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Offline

 

#11 2008-08-27 03:31:06

nogard999
Member
2008-08-25
2

Re: Skript doesnt find Thumbnails - but they exist ???

rio wrote:

:-/
only perform a simulation (no change in database will be made) active or not?

Uncheck it.

Offline

 

#12 2008-08-27 07:48:46

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: Skript doesnt find Thumbnails - but they exist ???

Frequent error is to forget the thumbnail prefix: TN-

VDigital wrote:

Your thumb would be in thumbnail directory with name of thumbnail/TN-00001.jpg
or thumbnail/TN-00001.png

Depending on value of
$conf['prefix_thumbnail'] = 'TN-';

which could be ''.

8-)


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact