Changeset 18775


Ignore:
Timestamp:
Oct 28, 2012, 10:25:43 PM (8 years ago)
Author:
rvelices
Message:

feature 2771: added backward compatibility with pre jquery ui 1.9 effect file naming (combine script id issues)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/include/template.class.php

    r18760 r18775  
    599599      }
    600600    }
     601
     602    // TEMP in 2.5 for backward compatibility
     603    if(!empty($params['require']))
     604    {
     605      $params['require'] = str_replace('jquery.effects.', 'jquery.ui.effect-', $params['require'] );
     606      $params['require'] = str_replace('jquery.effects', 'jquery.ui.effect', $params['require'] );
     607    }
     608
    601609    $this->scriptLoader->add( $params['id'], $load,
    602610      empty($params['require']) ? array() : explode( ',', $params['require'] ),
     
    681689    if ( !empty($content) )
    682690    { // second call
     691
     692      // TEMP in 2.5 for backward compatibility
     693      if(!empty($params['require']))
     694      {
     695        $params['require'] = str_replace('jquery.effects.', 'jquery.ui.effect-', $params['require'] );
     696        $params['require'] = str_replace('jquery.effects', 'jquery.ui.effect', $params['require'] );
     697      }
     698
    683699      $this->scriptLoader->add_inline(
    684700        $content,
Note: See TracChangeset for help on using the changeset viewer.