Changeset 21236


Ignore:
Timestamp:
Mar 6, 2013, 9:56:04 AM (7 years ago)
Author:
plg
Message:

bug 2861: avoid "invalid password" with manual upgrade and admin session expired

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/2.5/include/functions_user.inc.php

    r20545 r21236  
    11551155    }
    11561156   
    1157     if ($check and isset($user_id) and !$conf['external_authentification'])
    1158     {
     1157    if ($check)
     1158    {
     1159      if (!isset($user_id) or $conf['external_authentification'])
     1160      {
     1161        return true;
     1162      }
     1163     
    11591164      // Rehash using new hash.
    11601165      $hash = pwg_password_hash($password);
Note: See TracChangeset for help on using the changeset viewer.