Changeset 22005


Ignore:
Timestamp:
Apr 4, 2013, 12:56:51 PM (7 years ago)
Author:
plg
Message:

merge r21236 from branch 2.5 to trunk

bug 2861: avoid "invalid password" with manual upgrade and admin session expired

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/include/functions_user.inc.php

    r21802 r22005  
    11621162    }
    11631163
    1164     if ($check and isset($user_id) and !$conf['external_authentification'])
    1165     {
     1164    if ($check)
     1165    {
     1166      if (!isset($user_id) or $conf['external_authentification'])
     1167      {
     1168        return true;
     1169      }
     1170     
    11661171      // Rehash using new hash.
    11671172      $hash = pwg_password_hash($password);
Note: See TracChangeset for help on using the changeset viewer.