Ignore:
Timestamp:
Mar 28, 2010, 9:46:42 PM (11 years ago)
Author:
grum
Message:

Update the plugin for compatibility with Piwigo 2.1

File:
1 edited

Legend:

Unmodified
Added
Removed
  • extensions/UserStat/maintain.inc.php

    r4270 r5433  
    1616if (!defined('PHPWG_ROOT_PATH')) { die('Hacking attempt!'); }
    1717
    18 define('USERSTAT_DIR' , basename(dirname(__FILE__)));
    19 define('USERSTAT_PATH' , PHPWG_PLUGINS_PATH . USERSTAT_DIR . '/');
     18if(!defined('USERSTAT_DIR')) define('USERSTAT_DIR' , basename(dirname(__FILE__)));
     19if(!defined('USERSTAT_PATH')) define('USERSTAT_PATH' , PHPWG_PLUGINS_PATH . USERSTAT_DIR . '/');
    2020
    2121
     
    2323
    2424/* -----------------------------------------------------------------------------
    25 AStat-2 needs the Grum Plugin Classe
     25UserStat needs the Grum Plugin Classe
    2626----------------------------------------------------------------------------- */
    2727$gpc_installed=false;
     
    2929{
    3030  @include_once(PHPWG_PLUGINS_PATH.'grum_plugins_classes-2/main.inc.php');
    31   // need GPC release greater or equal than 2.0.1
    32   if(checkGPCRelease(2,0,1))
     31  // need GPC release greater or equal than 2.0.5
     32  if(checkGPCRelease(2,0,5))
    3333  {
    3434    @include_once("userstat_aim.class.inc.php");
     
    3939function gpcMsgError(&$errors)
    4040{
    41   array_push($errors, sprintf(l10n('us_gpc2_not_installed'), "2.0.1"));
     41  array_push($errors, sprintf(l10n('us_gpc2_not_installed'), "2.0.5"));
    4242}
    4343// -----------------------------------------------------------------------------
Note: See TracChangeset for help on using the changeset viewer.