Differences

This shows you the differences between two versions of the page.

Link to this comparison view

user_documentation:learn:install:before [2018/03/14 15:36]
plg
user_documentation:learn:install:before [2018/07/18 11:20] (current)
plg update PHP version required and recommended
Line 7: Line 7:
   * a webserver like Nginx or Apache   * a webserver like Nginx or Apache
   * MySQL **5** (or the equivalent with MariaDB)   * MySQL **5** (or the equivalent with MariaDB)
-  * PHP **5.2** (recommended 7.0)+  * PHP **5.3** (recommended 7.0 or 7.1)
   * A graphic library: ImageMagick is recommended (better performances and image quality) or GD which is often bundled with PHP.   * A graphic library: ImageMagick is recommended (better performances and image quality) or GD which is often bundled with PHP.
   * an FTP client software will be required to upload the files (netinstall or full package) : Piwigo team recommends FileZilla as FTP client software, because it is free as Piwigo is, and compatible with Windows, Mac and Linux. \\ Piwigo is also included in Softaculous or other auto-installer system, if available on your hosting : that way you don't need any FTP client software, but you might need one later.   * an FTP client software will be required to upload the files (netinstall or full package) : Piwigo team recommends FileZilla as FTP client software, because it is free as Piwigo is, and compatible with Windows, Mac and Linux. \\ Piwigo is also included in Softaculous or other auto-installer system, if available on your hosting : that way you don't need any FTP client software, but you might need one later.
 
Back to top
user_documentation/learn/install/before.txt · Last modified: 2018/07/18 11:20 by plg
 
 
github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact