Announcement

Post a reply

Write your message and submit

Click in the dark area of the image to send your post.

Go back

Topic review (newest first)

plg
2009-09-27 14:38:21

rub wrote:

demos were not updated!

demo upgraded to 2.0.4, nicely done with extension:302 of course :-) Thank you rub for reminding (I've added an "update the demo" section in the private wiki page "how to release")

rub
2009-09-27 09:47:25

demos were not updated!

tarroz
2009-09-26 01:44:51

P@t wrote:

Can you try to update autoupdate plugin (manually by  FTP) with this file
This version try to change chmod of needed files if extration fail... This version work on 1and1 server even if chmod of files is 644...

I still get an error with the autoupdate_test in the quoted attachment.  I uninstalled the autoupdate 2.0.e plugin, though didn't delete the files so its still in the autodate folder and I used FTP to update the files.  Reinstalled and activated autoupdate test and went to Administration, clicked on the link and go the error: "An error occured during extract. Please check files permissions of your piwigo installation.
Click here to show log error." The following was inside the error log file:

The log_error.txt:
././tools/pwg_rel_create.sh: write_protected
././tools/create_listing_file.php: write_protected
././template/yoga/rating.js: write_protected
././template/yoga/menubar_tags.tpl: write_protected
././admin/extend_for_templates.php: write_protected
././admin/template/goto/plugins_new.tpl: write_protected
././admin/template/goto/plugins_update.tpl: write_protected
././admin/template/goto/intro.tpl: write_protected
././admin/template/goto/install.tpl: write_protected
././admin/template/goto/theme/roma/theme.css: write_protected
././admin/menubar.php: write_protected
././admin/include/pclzip.lib.php: write_protected
././admin/include/functions.php: write_protected
././admin/include/plugins.class.php: write_protected
././language/de_DE/admin.lang.php: write_protected
././language/de_DE/help.html: write_protected
././language/de_DE/install.lang.php: write_protected
././language/it_IT/admin.lang.php: write_protected
././language/it_IT/upgrade.lang.php: write_protected
././include/functions_mail.inc.php: write_protected
././include/smarty/libs/plugins/function.math.php: write_protected
././include/smarty/libs/Smarty.class.php: write_protected
././include/smarty/libs/Config_File.class.php: write_protected
././include/smarty/libs/Smarty_Compiler.class.php: write_protected
././include/smarty/NEWS: write_protected
././include/smarty/README: write_protected
././include/config_default.inc.php: write_protected
././include/constants.php: write_protected
././include/functions_user.inc.php: write_protected
././include/class_smtp_mail.inc.php: write_protected
././include/ws_functions.inc.php: write_protected
././install.php: write_protected

P@t
2009-09-25 16:32:58

tarroz wrote:

Yes, All files are changed, I'm doing it in shell so I see everything turn green which means 755 or -rwxr-xr-x
I also do a ls -alrt and I see all files changed.

Can you try to update autoupdate plugin (manually by  FTP) with this file
This version try to change chmod of needed files if extration fail... This version work on 1and1 server even if chmod of files is 644...

tarroz
2009-09-25 03:21:14

P@t wrote:

When you do a chmod (755 or 777) to all the files, do you check the chmod for some files (example: include/constants.php)?
Are you sure you did  a chmod for all files (and not only directories)?

Yes, All files are changed, I'm doing it in shell so I see everything turn green which means 755 or -rwxr-xr-x
I also do a ls -alrt and I see all files changed.

P@t
2009-09-25 02:36:57

tarroz wrote:

I put back constants.php file from 2.0.3 and did a chmod -R 755 to all the files but now its not working again, I'm getting the same problem as before. It says: "Piwigo has been successfully upgraded (version 2.0.3)" but it does not change any files.

Really strange...

When you do a chmod (755 or 777) to all the files, do you check the chmod for some files (example: include/constants.php)?
Are you sure you did  a chmod for all files (and not only directories)?

tarroz
2009-09-25 01:29:01

P@t wrote:

Problem: only constants.php file has been updated...
You have to set cmod to 755 for all installation files before upgrading...
Put back old constants.php file (from 2.0.3), set chmod to 755 for entire files, et do update again.

I put back constants.php file from 2.0.3 and did a chmod -R 755 to all the files but now its not working again, I'm getting the same problem as before. It says: "Piwigo has been successfully upgraded (version 2.0.3)" but it does not change any files.

When I use the link ./admin.php?autoupdate=2.0.3_to_2.0.4 I get an error: An error occured during upgrade.

I even tried chmod -R 777 * to all file and directory and I get the same error / problem.

Do I need to try chown ?

P@t
2009-09-24 11:32:38

tarroz wrote:

Solution Found:
YES, you are correct P@t, the problem was with permission setting of include/constants.php, before the file was set with -rw-r--r-- which did not allow it to execute or write so I just set the chmod to: 777 or -rwxrwxrwx and I tried the update again in admin and it successfully updated to 2.0.4. 

Note: You could probably set it to 755 or -rwxr-xr-x and it should still work; probably should leave it at 755 for security reasons.

Problem: only constants.php file has been updated...
You have to set cmod to 755 for all installation files before upgrading...
Put back old constants.php file (from 2.0.3), set chmod to 755 for entire files, et do update again.

tarroz
2009-09-24 04:28:42

VDigital wrote:

Could you try this url from your gallery:

./admin.php?autoupdate=2.0.3_to_2.0.4


Then check inside ./_data/autoupdate/
which files are there?

Check the chmod value of  ./_data/autoupdate/

Check if your php is running in Safemode

inside ./_data/autoupdate/ had this file 2.0.3_to_2.0.4.zip size: 246880 dated yesterday 9/22/2009 but when I ran ./admin.php?autoupdate=2.0.3_to_2.0.4 that .zip file is gone now.

chmod value of ./_data/ : drwxrwxrwx

chmod value of ./_data/autoupdate/ : drwxr-xr-x

php Safemode is off

P@t wrote:

Can you manually delete files (by FTP) into _data/templates_c, an have a look in home administatration page?
Then, if it's still 2.0.3 version, can you tell me chmod value of include/constants.php file?

Yes, I'm able to delete files by FTP in _data/templates_c

chmod value of include/constants.php : -rw-r--r--

Solution Found:
YES, you are correct P@t, the problem was with permission setting of include/constants.php, before the file was set with -rw-r--r-- which did not allow it to execute or write so I just set the chmod to: 777 or -rwxrwxrwx and I tried the update again in admin and it successfully updated to 2.0.4. 

Note: You could probably set it to 755 or -rwxr-xr-x and it should still work; probably should leave it at 755 for security reasons.

Thank You, VDigital and P@t for your helping me solve this problem :)

P@t
2009-09-23 12:50:47

tarroz wrote:

I'm currently using piwigo 2.0.3 and I want to upgrade to 2.0.4.
I installed and activated Piwigo Auto Upgrade 2.0.e fine and see the note:"A new version of Piwigo is available.
Click here to upgrade automatically" on the Admin page under links, I clicked the upgrade automatically link and I get the popup: "Are you sure you want to autmatically upgrade piwigo? Warning!!! Files manually modified could be overwritten." - So I click OK and get the message: "Piwigo has been successfully upgraded (version 2.0.3)"  But the problem is I still have the same version 2.0.3, it did not upgrade anything. All the files are still the same.

Two users on french forum have same problem...
I try to find a solution ;-)

Can you manually delete files (by FTP) into _data/templates_c, an have a look in home administatration page?
Then, if it's still 2.0.3 version, can you tell me chmod value of include/constants.php file?

VDigital
2009-09-23 07:37:31

Could you try this url from your gallery:

./admin.php?autoupdate=2.0.3_to_2.0.4


Then check inside ./_data/autoupdate/
which files are there?

Check the chmod value of  ./_data/autoupdate/

Check if your php is running in Safemode

tarroz
2009-09-23 02:57:58

I'm currently using piwigo 2.0.3 and I want to upgrade to 2.0.4.
I installed and activated Piwigo Auto Upgrade 2.0.e fine and see the note:"A new version of Piwigo is available.
Click here to upgrade automatically" on the Admin page under links, I clicked the upgrade automatically link and I get the popup: "Are you sure you want to autmatically upgrade piwigo? Warning!!! Files manually modified could be overwritten." - So I click OK and get the message: "Piwigo has been successfully upgraded (version 2.0.3)"  But the problem is I still have the same version 2.0.3, it did not upgrade anything. All the files are still the same.

Note: I tried with the previous version: piwigo 2.0.2 along with Piwigo Auto Upgrade 2.0.d and it did the exact same thing: Just a message that says "Piwigo has been successfully upgraded (version 2.0.2)" but nothing is actually changed.

P.S. I tried uninstalling all the plugins but the same thing happens: Just a message that says "Piwigo has been successfully upgraded (version 2.0.2)" but nothing is actually changed.

Neutre
2009-09-19 07:02:52

Just done the upgrade ! It works well (and sorry for my english...)
Jean

ngoc
2009-09-19 04:11:22

It looks working for me the auto upgrade.

Thanks,

irohaproject
2009-09-19 03:06:15

I just upgraded and the automatic upgrade plugin worked great for me thanks

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2023 · Contact