Announcement

#1 2008-05-10 20:53:19

quixote
Member
2008-05-10
95

PWG won't synchronize! NOT running simulation!

Everything was going so well.  Now, suddenly....  I can't stand the frustration!  :S

I had a test category called "tide-pools" with 12 photos.  I uploaded 2 more directories, Fiji, and Gardens, to the same level.  I set permissions on everything to 777.  As admin, I started a synchronization, for directories and files, and simulation is UNchecked.  There are no spaces in dir or file names.  Thumbs are in subdir "thumbnail" and named "TN-same-name-as-photo.png".  According to the config_default.inc.php, that should be okay.

It always comes back with just the original test dir and its 12 photos.  There's an option on the synchro page to put everything in the existing "tide pools" category, which I do NOT want, but can't seem to change.  But even if I put the new dirs as subdirs of "tide pools" (which wouldn't do in reality, but I tried it as a test), it still does not see them.

I tried about ten times.  I tried logging all the way out and back in, just in case something was retained in cache.

Am I doing something wrong?  Is there a bug?  I don't mind wiping things out and starting over at this stage, but if I had my whole gallery set up and this happened when I wanted to add something new, I'd be upset!

Thanks for any help!

Offline

 

#2 2008-05-10 21:05:36

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: PWG won't synchronize! NOT running simulation!

Link to the gallery, maybe?

PhpWebGallery, version?


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#3 2008-05-10 21:44:42

quixote
Member
2008-05-10
95

Re: PWG won't synchronize! NOT running simulation!

Hey, I'm just testing.  I'm ashamed to link to the gallery right now....  I was playing around with thumbnails, before I had them figured out, so two of the thumbs are messed up.  Please ignore! 
http://molvray.com/galleryphp

PWG version is 1.7.1.  Downloaded, I think, Jan 24.  It says the latest version is Jan 25th, but version number and file size seem to be the same.  ...?

Offline

 

#4 2008-05-10 21:46:41

quixote
Member
2008-05-10
95

Re: PWG won't synchronize! NOT running simulation!

(Permissions are not currently at 777.)

Offline

 

#5 2008-05-10 22:09:47

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: PWG won't synchronize! NOT running simulation!

quixote wrote:

I had a test category called "tide-pools" with 12 photos.  I uploaded 2 more directories, Fiji, and Gardens, to the same level.

I didn't find your ... ./galleries/Gardens/ folder.
8-)


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#6 2008-05-10 22:12:31

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: PWG won't synchronize! NOT running simulation!

quixote wrote:

Hey, I'm just testing.  I'm ashamed to link to the gallery right now....  I was playing around with thumbnails, before I had them figured out, so two of the thumbs are messed up.  Please ignore! 
http://molvray.com/galleryphp

PWG version is 1.7.1.  Downloaded, I think, Jan 24.  It says the latest version is Jan 25th, but version number and file size seem to be the same.  ...?

http://molvray.com/galleryphp/register.php
8-)

May I have a user...
8-)


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#7 2008-05-11 00:27:23

quixote
Member
2008-05-10
95

Re: PWG won't synchronize! NOT running simulation!

I sent you a couple of emails via the contact form.  You may have seen them already?  I thought I better mention it here too ;)

Offline

 

#8 2008-05-11 05:33:49

quixote
Member
2008-05-10
95

Re: PWG won't synchronize! NOT running simulation!

Some results!

I had two problems: my thumbnails were 160x160 but the max size listed was 128x128, so it didn't process them (same as it does with any other inconsistency, such as wrong filenames).

Once I fixed that, it finally showed that the files were there, but still didn't actually process them.  So instead of telling it to sync dirs + files, I said just directories, for the hell of it.  It processed those.  Then I told it files+directories, and it processed the works.

I did use PWG to generate the thumbs.  In general I'd like to generate my own and upload the works, then sync.  I'll test out tomorrow whether I can do that if I give it the right thumbs dimensions.

I'm delighted I'm getting somewhere!  This is by far the most navigable, best organized, and best looking web gallery software out there, and I can't wait to get it exactly how I want it :D .

Offline

 

#9 2008-05-11 07:30:27

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: PWG won't synchronize! NOT running simulation!

*  [...-SF/allen's_hummingbird_strybing-2007-05-27.jpg] PWG-UPDATE-1 (wrong filename)
    *  [...-SF/anna's_male_hummingbird_strybing_05-2007-05-27.jpg] PWG-UPDATE-1 (wrong filename)

allen's_hummingbird_strybing-2007-05-27.jpg => quote is a problem so remame picture and thumbnail in
allen_s_hummingbird_strybing-2007-05-27.jpg and TN-allen_s_hummingbird_strybing-2007-05-27.jpg

Same conclusion for anna's

8-)


Don't forget the 2nd pass:
Database synchronization with files: ./galleries/
Metadata synchronization results

    * 125 elements informations synchronized with files metadata
    * 125 images candidates for metadata synchronization
    * Used metadata : filesize, width, height, high_filesize, date_creation

Could be useful...
8-)


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#10 2008-05-11 07:47:31

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: PWG won't synchronize! NOT running simulation!

Additional info:
You aren't obliged to rename your original pictures like you do...

You (as an admin) could use this page:
/galleryphp/admin.php?page=picture_modify&cat_id=1&image_id=12

and fill in "Properties"
Name     (There you can use quotes and any caracter)
Author     (There try this  "© 2008 M Molvray & P Kores")

Tags     (No tag currently defined. Use Administration>Pictures>Tags to create them)

Description (You are free to describe your pictures or not).

Anyway: asap you will discover that metadata will be usefull to add tags, define name and author...
8-)


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#11 2008-05-11 23:10:49

quixote
Member
2008-05-10
95

Re: PWG won't synchronize! NOT running simulation!

I think I'm starting to learn my way around.  I generated thumbnails, uploaded the photos and associated thumbs, synchronized ... it all seems to be working.  I even made a new "new" button ;)

Thanks for the tip about renaming single files.

Next step: figure out where all those $conf variables are...

Thanks again!

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact