Announcement

#1 2009-07-25 14:03:23

pernel
Member
2009-07-25
6

ploader windows problems

I today installed ploader on two xp-boxes. Version 2.0.3a
When I start the program the following happens:

1) Warning message box: pLoader working directory creation error
"C:\Documents and Settings\User\Local settings\Application Data\.ploader directory failed"

I ok this and then

2) Ploader information
"Cannot find translation catalog files. Use default language"

-I ok this and manage to login.

I select a picture and a category and upload button.
After some processing a new

3) Ploader information box
"%s : communication error"

and under it:

4) Image upload progress information
"1 image processed
0 images uploaded
1 images in errors and not uploaded -
500 file transfer failed
Duration : 6 second"

These errors occur on both xp-computers. They are both on SP3.

I can notice a directory structure being built on the server /upload/2009/07/25/index.htm
Nothing more in it.

In /upload/buffer directory only small xxxx... -thumb-00001.block files are created.

I have tried increasing permissions in upload directory and subfolders and files to 777 as well as to the galleries folder, subfolders and files. It does not help.

I think this problem is in the ploader installation in windos xp. It seems it can't allocate necessary working directories.

How can I get ploader properly installed and working?

Offline

 

#2 2009-07-25 14:10:47

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: ploader windows problems

Piwigo version?


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#3 2009-07-25 16:14:18

pernel
Member
2009-07-25
6

Re: ploader windows problems

piwigo version 2.0.3 downloaded and installed yesterday.

Offline

 

#4 2009-07-25 17:17:04

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13574

Re: ploader windows problems

Thanks for the accurate description of your problem pernel.

What is your Windows username? (does it contain special characters that may prevent pLoader from creating its working directory?)

Offline

 

#5 2009-07-26 09:32:09

pernel
Member
2009-07-25
6

Re: ploader windows problems

well, it's a Swedish localisation of xp. Above I translated the path. I thoght I was helpful by translating but I wasn't.

The exact path is:
"c:\Documents and settings\Per\Lokala inställningar\Application data"

So maybe the Swedish character "ä" creates the problem?

Offline

 

#6 2009-07-26 11:00:20

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13574

Re: ploader windows problems

pernel wrote:

So maybe the Swedish character "ä" creates the problem?

Yes, I'm quite sure this is the origin of the problem. I know a bug has already been fixed for accented characters in the username, but not in the full path to the pLoader working directory.

I've notified ron (pLoader developer) so that he can give a deeper analysis.

Offline

 

#7 2009-07-26 23:43:31

pernel
Member
2009-07-25
6

Re: ploader windows problems

Thanks,
The"ä" would create same problem for other Scandinavian and German users.
Pernel

Last edited by pernel (2009-07-26 23:46:14)

Offline

 

#8 2009-08-04 08:58:47

ron
Former Piwigo Team
2008-09-30
69

Re: ploader windows problems

plg wrote:

Yes, I'm quite sure this is the origin of the problem. I know a bug has already been fixed for accented characters in the username, but not in the full path to the pLoader working directory.

When pLoader fails to create its working directory it tries to use the default windows temp directory. The error you encounters seems to be a communication error with Piwigo server. Could you check for a .pLoader directory ?

Offline

 

#9 2009-08-16 11:55:33

artesin
Member
2009-08-16
2

Re: ploader windows problems

Trouble with pLoader version 2.0.3a
Installed it on two computers in a LAN. Both have Windows XP sp3.

On one PC with XP pLoader does start and allows to create categories and upload images.
The other one does not start. It installes, unpacks etc.
And the strange thing... It did work before.

There is no error message, it just does not start...

Any suggestions?

Offline

 

#10 2009-08-16 12:04:17

artesin
Member
2009-08-16
2

Re: ploader windows problems

artesin wrote:

Trouble with pLoader version 2.0.3a
Installed it on two computers in a LAN. Both have Windows XP sp3.

On one PC with XP pLoader does start and allows to create categories and upload images.
The other one does not start. It installes, unpacks etc.
And the strange thing... It did work before.

There is no error message, it just does not start...

Any suggestions?

The solution is: remove the .ploader folder from:

[HDD]:\Documents and Settings\[USER]\Local Settings\

Where [HDD] is your drive where the documents and Settings folder is stored.
And [USER] is the folder of the current user.

Problem is fixed when you run pLoader again.
( Well it did for me ;-) )

Last edited by artesin (2009-08-16 12:04:39)

Offline

 

#11 2009-08-17 09:30:43

pernel
Member
2009-07-25
6

Re: ploader windows problems

Ron, sorry for my late response. I did not realize there were more posts on this until now. I forgot to activate "subscribe to this topic".

Searched for the location of .ploader directory: It's in C:\Documents and Settings\Per\Lokala inställningar\Temp\.ploader

In the .ploader folder I find the following files and subfolders: preview, resize, thumbnails, wxthumbnails, .ploader.conf, .ploader.layout, ploader.dat

Offline

 

#12 2009-08-17 11:59:56

ron
Former Piwigo Team
2008-09-30
69

Re: ploader windows problems

pLoader has created its working directory in the alternate temp location.  The next release will fix that bug : [Bugtracker] ticket 1067 that currently prevents us from having the communication error message.

Offline

 

#13 2009-10-03 15:41:31

Pink Panther
Guest

Re: ploader windows problems

Hi, Thank you for your great work first and the ploader is perfect in my previous XP system.  However, I upgraded my pc to windows 7 rtm 7600 a few days ago.  I found that the ploader 2.0.3 is not compatible with Windows 7.  Do you have any ideas on it?

 

#14 2009-10-09 20:48:47

ron
Former Piwigo Team
2008-09-30
69

Re: ploader windows problems

I have just tried with Windows 7 Ultimate and pLoader works like a charm. Do you have a particular error message ?

Offline

 

#15 2009-10-12 17:55:59

pernel
Member
2009-07-25
6

Re: ploader windows problems

Hi again,
Is there a solution on the way for my original post?
I think ploader is a necessary tool for making piwigo useful. I will not use it as long as I have to resize all the pics manually before uploading.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact