Announcement

  •  » Extensions
  •  » pLoader can't login, "Forbidden"

#1 2009-10-29 18:31:49

cbonner
Member
New Hampshire, USA
2009-10-28
6

pLoader can't login, "Forbidden"

I have a new install of Piwigo (2.0.5, downloaded 10/10/2009) and the latest pLoader (2.0.5a, downloaded 10/27/2009).  When I try to connect with pLoader, I get the following error message:

---------------------------
Piwigo login error
---------------------------
Forbidden

Connection to http://www.hikingwithchuck.com/downloads failed
---------------------------
OK   
---------------------------

I've tried with and without the / after the URL.

I'm using the same Username and Password as the "webmaster" in Piwigo.  I can log in to Piwigo admin, but not pLoader.

When I use pLoader in offline mode, I can make changes to settings and they "stick," so I'm sure it's not an issue with local file or registry permissions.

** UPDATE **
Forgot to mention, may be important.  pLoader documentation refers to install kit, but when I downloaded it, I did not get an install kit.  I simply copied the contents of the ZIP to a folder.  I start pLoader by double-clicking the file pLoader_2.0.5a_win/bin/pLoader.exe.  Again, it works in offline mode, so I don't see why it shouldn't be able to connect to the server.  Just in case, ...
**

Ideas?

Local:
Windows Vista Home Premium (64 bit) SP-1

Server:
Architecture x86_64
Operating system Linux
Apache version 2.2.11 (Unix)
PHP version 5.2.9
MySQL version 5.0.81-community-log 
Kernel version 2.6.28-9.25.intel

Last edited by cbonner (2009-10-29 18:35:41)

Offline

 

#2 2009-10-30 02:06:17

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13574

Re: pLoader can't login, "Forbidden"

Hi cbonner,

Code:

$ perl piwigo_remote.pl --base_url=http://www.hikingwithchuck.com/downloads --action=pwg.categories.getList
$VAR1 = '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don\'t have permission to access /downloads/ws.php
on this server.</p>
<p>Additionally, a 403 Forbidden
error was encountered while trying to use an ErrorDocument to handle the request.</p>
<hr>
<address>Apache/2.2.13 (Unix) mod_ssl/2.2.13 OpenSSL/0.9.8k DAV/2 mod_auth_passthrough/2.1 FrontPage/5.0.2.2635 Server at www.hikingwithchuck.com Port 80</address>
</body></html>
';
malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "<!DOCTYPE HTML PUBLI...") at piwigo_remote.pl line 279

Can you make sure ws.php is readable for the web server?

Offline

 

#3 2009-11-03 01:04:11

cbonner
Member
New Hampshire, USA
2009-10-28
6

Re: pLoader can't login, "Forbidden"

plg,

I'm not certain I follow, being very new to Linux and to PHP and somewhat new to Web hosting, but I'll try.

If I look at the file permissions in FileZilla, it looks okay to me:  0644

The properties of the containing folder also look right: 0755

If I attempt to open the file in a Web browser, I get an error HTTP 501/HTTP 505
(That is, in MSIE I entered http://www.hikingwithchuck.com/downloads/ws.php)
But I don't know if that should work anyway.

Again, I'm able to run the Piwigo admin in a browser.  So, if this depends on ws.php, the file is indeed readable.

Does any of that help you to help me?

Thanks!

Chuck

Offline

 

#4 2009-11-03 23:52:07

bladerunner_vtx
Member
Tulsa, OK
2009-11-03
5

Re: pLoader can't login, "Forbidden"

I am having the exact same issue. I may have been entering the wrong URL though. I am entering http://www.troop313tulsa.org/secure/gallery/index.php (gallery is the directory in which piwigo is installed on my webserver)

I ahve tried any number of different versions of this URL, but none of them work. I have verified that the webmaster account is correct.

Offline

 

#5 2009-11-04 00:00:47

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
7058

Re: pLoader can't login, "Forbidden"

bladerunner_vtx wrote:

I am having the exact same issue. I may have been entering the wrong URL though. I am entering http://www.troop313tulsa.org/secure/gallery/index.php (gallery is the directory in which piwigo is installed on my webserver)

I ahve tried any number of different versions of this URL, but none of them work. I have verified that the webmaster account is correct.

It is necessary to put : http://www.troop313tulsa.org/secure/gallery/


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#6 2009-11-04 01:33:37

bladerunner_vtx
Member
Tulsa, OK
2009-11-03
5

Re: pLoader can't login, "Forbidden"

Now I get the error message "Not Acceptable connection to http://www.troop313tulsa.org/secure/gallery failed"

I have tried the webmaster login as well as creating a new user account and trying to login using that

Offline

 

#7 2009-11-04 09:26:46

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
7058

Re: pLoader can't login, "Forbidden"

Piwigo URL : http://www.troop313tulsa.org/secure/gallery/
Admin username ->     Whatever you use to log into the webmaster at gallery
Admin Password -> Whatever you use to log into the webmaster at gallery


   
Do you use a redirect to your site ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#8 2009-11-05 00:58:34

cbonner
Member
New Hampshire, USA
2009-10-28
6

Re: pLoader can't login, "Forbidden"

I've tried the suggestions offered to bladerunner_vtx, but I always get the original "forbidden" error message.

I had named the directory "galleries," and tried adding that to the URL.  I tried with and without the trailing "/".  I renamed thed directory to "gallery," tried with and without the slash, and always get the "Forbidden" error message.

I think we're getting close to the issue.

I do not use a redirect, but my "hikingwithchuck.com" domain is a subdomain on a hosting service where my "primary" domain is something else.  Still, I can access the hikingwithchuck.com domain directly.  Does it matter that it is also a subdomain of another domain?

Does it matter that Piwigo is not installed in the root of the domain?

What I really want to do:  Replace my existing photo collection with an easier to manage, more user friendly, and generally better image gallery.  In transition, I would like to leave the existing system of HTM files in place until I get all images incorporated into the image gallery.

The current photo collection is in http://www.hikingwithchuck.com/download … dIndex.htm

Piwigo is in http://www.hikingwithchuck.com/downloads/

So, what am I missing here?  Does ploader need to connect to the URL where Piwigo is installed, or in the "gallery" folder below that?  And in either case, why am I getting this "Forbidden" error, and how can I fix it?

Thanks for whatever help you can give me.

Chuck

Offline

 

#9 2009-11-05 07:54:25

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: pLoader can't login, "Forbidden"

1 - Recreate the ./galleries/ folder in downloads.

2 - Recreate the ./upload/ folder in downloads.

Piwigo needs the first one.
pLoader needs the second one.

3 - I am registered.

4 - Could you set VDigital as Administrator of your Piwigo website?  ( Admin > Identification > Users ...)

5 - I will try till tomorrow to upload one/two of your pictures by pLoader in your webpages.

Just to check if it's work.


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#10 2009-11-06 00:13:34

cbonner
Member
New Hampshire, USA
2009-10-28
6

Re: pLoader can't login, "Forbidden"

VDigital,

Done!

Thanks very much for the help.

I am still getting the "forbidden" error, but maybe you will find something that I'm missing.  I'll check tomorrow to see if you were able to accomplish anything.

For whatever it's worth, the ./upload/ folder did not exist.

To install Piwigo, I simply unzipped the file I downloaded (piwigo-2.0.5.zip) on my local PC, and copied the contents to the server by dragging them all to the server using FileZilla.  There is no ./upload/ folder in the ZIP file, so none was created on the server (until I created it manually tonight).

Is there anything else missing in the ZIP file?  Maybe I should delete it all from the server and install with the install script rather than copying the contents of the ZIP file?

Thanks again!

Chuck

Offline

 

#11 2009-11-06 07:22:01

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: pLoader can't login, "Forbidden"

I tried pLoader 2.0.5a to send 1 of your pics.

Connection failed.

I activated [extension by Piwigo Team] LocalFiles Editor

I added:

$conf['ws_enable_log'] = true;
$conf['ws_log_filepath'] = '/doc/README_fr.txt';

But nothing has been added to the README file.

I installed/activated [extension by P@t] Piwigo Auto Upgrade

And upgraded your Piwigo to 2.0.6

And still on pLoader connection I receive a Forbidden message.

http://www.hikingwithchuck.com/downloads/tools/ws.htm
And ran pwg.session.getStatus

I get the right results.
I have no further idea (maybe ron or plg will have).

I will add a first pic for tests (out of pLoader).
(I didn't load the High Def. file for now).


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#12 2009-11-06 18:29:01

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
17680

Re: pLoader can't login, "Forbidden"

I tried to reach the API by PiwigoPress and I got:

Warning: file_get_contents( http://www.hikingwithchuck.com/download … bnail=true) [function.file-get-contents]: failed to open stream: No such file or directory in...


By a direct access, it works: http://www.hikingwithchuck.com/downloads/ws.php

XML test

Which rights or chmod are associated to ./ws.php ?



NOTE: Piwigo has a bug there xmlrpc


Piwigo.com: Start and run your own photo gallery. Signup and get 30 days to try for free, no commitment.
8-)

Offline

 

#13 2009-11-10 00:17:11

cbonner
Member
New Hampshire, USA
2009-10-28
6

Re: pLoader can't login, "Forbidden"

VDigital,

I'm not sure how much of your last post was intended for me and how much for other members of your team.

About the only thing that makes sense to me is your question about permissions on the file ws.php.  According to FileZilla, it _was_ 0644.  I just changed it to 0755.

After looking around a bit, I noticed that most other .PHP files in that folder have 0755.  (The difference being that they have "Execute" permissions and ws.php does not.)

I had never explicitly set any file permissions, so this must be the way it is set in the .ZIP file from which I copied it.

So, I changed it to 0755.  I still get the same "Forbidden" error.

Is it time for me to go looking for another gallery software?

Chuck

Offline

 

#14 2009-11-10 00:58:26

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13574

Re: pLoader can't login, "Forbidden"

OK, I think I get it :-)

It seems that your hosting provider has some kind of "higher" security level enabled. When I perform an HTTP request on ws.php with a standard browser (Firefox) everything works nice. When I perform exactly the same HTTP request but with piwigo_remote.pl (the same as pLoader, without the graphical interface), I get a permission denied.

At the HTTP request level, the difference between the Firefox and the piwigo_remote.pl requests is the "user agent":

* Firefox : 'Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.15) Gecko/2009102815 Ubuntu/9.04 (jaunty) Firefox/3.0.15
* piwigo_remote.pl : "libwww-perl/5.814"

Now if I fake the user agent inside piwigo_remote.pl:

Code:

our $ua = LWP::UserAgent->new(
    agent => 'Mozilla/pLoader 2.0.5b',
);

It works nice with piwigo_remote.pl (and so it will with pLoader).

ron, can you confirm? I have the feeling that we have already met this problem before, but when I browse pLoader source code, I see no try to fake the user agent.

Offline

 

#15 2009-11-10 09:16:30

ron
Former Piwigo Team
2008-09-30
69

Re: pLoader can't login, "Forbidden"

plg wrote:

ron, can you confirm? I have the feeling that we have already met this problem before, but when I browse pLoader source code, I see no try to fake the user agent.

Yes, I confirm. We already met that kind of issue with "user agent" but I can't find the topic. It's not yet in pLoader code, but will be in next release : [Bugtracker] ticket 1234

Offline

 
  •  » Extensions
  •  » pLoader can't login, "Forbidden"

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact