Announcement

  •  » Extensions
  •  » Community plugin, new generation for Piwigo 2.2+

#226 2016-07-20 20:00:54

fundacionviztazmuseo
Guest

Re: Community plugin, new generation for Piwigo 2.2+

Good afternoon, I installed the latest version of Community plugin, is there compatibility issues in the mobile version ?. I have these problems with the plugin:

In the mobile version does not show the "add photos" and fill in the information, you have to see the gallery in version "desktop" to display the "add photos".

After sending the photo from the mobile version "desktop" not the page is "Your photos are awaiting approval."

Is there a way to always display the gallery on the phone as "desktop"?

thanks for your quick response.

 

#227 2016-08-21 03:24:32

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

For compatibility with phpBB 3.1 (and probably 3.2) you need to change the password hash line to support bcrypt instead of md5:

$conf['password_hash'] = create_function('$s', 'return password_hash($s);');

That works for me with phpBB 3.1.9 and PHP 5.6

Offline

 

#228 2016-08-21 08:44:30

eliz82
Member
Romania
2016-04-27
281

Re: Community plugin, new generation for Piwigo 2.2+

KungFuJosh, you didn't had this problems with PhpBB 3.1.9 ?

http://piwigo.org/forum/viewtopic.php?p … 12#p163412
http://piwigo.org/forum/viewtopic.php?p … 58#p164158

Login works for me in 3.0.14 , but i have many errors when try to access user list in Admin dashboard

Offline

 

#229 2016-08-21 17:33:37

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

eliz82 wrote:

KungFuJosh, you didn't had this problems with PhpBB 3.1.9 ?

http://piwigo.org/forum/viewtopic.php?p … 12#p163412
http://piwigo.org/forum/viewtopic.php?p … 58#p164158

Login works for me in 3.0.14 , but i have many errors when try to access user list in Admin dashboard

There's a million conflicts due to the phpbb_users table column named "user_id" - as a test, I changed it to "phpbb_user_id" and the user list works fine in piwigo (but obviously doesn't work in phpBB).


In my current install (including all files and a couple plugins), doing a source code search, I have:

617 references to "user_id" in piwigo
3362 references to "user_id" in phpBB

So there's the obvious source of the conflicts. Now to figure a way around it...


EDIT:
I'm pretty sure the conflicting code (for this issue) starts at line 279 of admin_permissions.php (// list of users)

Last edited by KungFuJosh (2016-08-21 18:30:18)

Offline

 

#230 2016-08-22 15:19:45

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

I posted a reply on the phpBB thread here: https://www.phpbb.com/community/viewtop … ;t=2348721

This forum is for the community plugin, and this issue isn't about the plugin.

Offline

 

#231 2016-08-23 16:44:59

eliz82
Member
Romania
2016-04-27
281

Re: Community plugin, new generation for Piwigo 2.2+

KungFuJosh wrote:

I posted a reply on the phpBB thread here: https://www.phpbb.com/community/viewtop … ;t=2348721
This forum is for the community plugin, and this issue isn't about the plugin.

I had 3 errors but I fixed 2 of them by changes to the community plugin files. So how is this not a community plugin problem?
Maybe you can make a specific thread for the External authentication + Community plugin that will help to have more concentrated discussions.

Our errors have nothing to do with Phpbb3, it's a Piwigo problem. Those errors will be to any software that has in that table ($conf['users_table'] =...) an identical column name with the ones normally used by Piwigo. And some Piwigo developers already understanded this http://piwigo.org/forum/viewtopic.php?p … 03#p155803
They are very common names to those colums, probably many software are affected by this. We already know about PHPBB and SMF.

For me the most frustraing thing is that Piwigo development seems to be dead, plg / flop25 / rvelices seems to be mostly inactive on the forum this days. I have read some more older threads regarding external authentication and they used to respond to users. Now as you can see we are talking with ourselfs.
I even reported the errors to Github and ... nothing [Github] Piwigo-community issue #15

Last edited by eliz82 (2016-08-27 21:46:28)

Offline

 

#232 2016-08-23 20:20:46

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

eliz82 wrote:

KungFuJosh wrote:

I posted a reply on the phpBB thread here: https://www.phpbb.com/community/viewtop … ;t=2348721
This forum is for the community plugin, and this issue isn't about the plugin.

I had 3 errors but I fixed 2 of them by changes to the community plugin files. So how is this not a community plugin problem?
Maybe you can make a specific thread for the External authentication + Community plugin that will help to have more concentrated discussions.

Our errors have nothing to do with Phpbb3, it's a Piwigo problem. Those errors will be to any software that has in that table ($conf['users_table'] =...) an identical column name with the ones normally used by Piwigo. And some Piwigo developers already understanded this http://piwigo.org/forum/viewtopic.php?p … 03#p155803
They are very common names to those tables, probably many software are affected by this. We already know about PHPBB and SMF.

For me the most frustraing thing is that Piwigo development seems to be dead, plg / flop25 / rvelices seems to be mostly inactive on the forum this days. I have read some more older threads regarding external authentication and they used to respond to users. Now as you can see we are talking with ourselfs.
I even reported the errors to Github and ... nothing [Github] Piwigo-community issue #15

Your other two issues were specific to the plugin, but the 3rd issue might be specific to Piwigo, exclusive of the plugin.

Basically, Piwigo should remove the use of "user_id" from the script entirely. They should have it be unique as pwg_user_id in all references to it, and that would most likely fix the issue. I might setup a test install to try that theory out if I need to (database will require changes too, so maybe a fresh install). First I'm looking at another option to read the user info from the database without using the aliasing method we're currently using.

When I changed the column name "user_id" in "phpbb_users" table in my database to something unique, the errors disappear, and the user list in Piwigo admin worked fine. So that tells us the error is specific to the use of "user_id." Obviously I had to change the column name back for phpBB to work.

Last edited by KungFuJosh (2016-08-23 20:46:22)

Offline

 

#233 2016-08-23 21:32:32

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

I mentioned something else in the other forum:

For anybody implementing this, you should make sure to also set the following:

Code:

$conf['insensitive_case_logon'] = true;

That way it doesn't matter whether you use username or username_clean from the phpBB database, and users don't have to worry about case-sensitivity with their usernames. (I don't know why this is even an option, case sensitive usernames??)

Offline

 

#234 2016-08-23 22:33:25

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

I decided to go ahead and do a test install of Piwigo, first replacing user_id with pwg_user_id in all the source code. Then I did a fresh install of my modified Piwigo version. I did the same string replace of user_id with pwg_user_id on the Community plugin.

I then exported my phpbb_users table with over 30,000 users in it, and imported it into my new Piwigo database.

I modified the config_default.inc.php file with the following code (note that my password hash is for phpBB 3.1.x, phpBB 3.0.x uses md5 instead of password_hash):

Code:

// +-----------------------------------------------------------------------+
// | phpBB MODS                                                        |
// +-----------------------------------------------------------------------+

$conf['users_table'] = 'phpbb_users';
$conf['external_authentification'] = true;
$conf['user_fields'] = array(
  'id' => 'user_id',
  'username' => 'username',
  'password' => 'user_password',
  'email' => 'user_email'
  );
$conf['password_hash'] = create_function('$s', 'return password_hash($s);');
$conf['password_verify'] = 'pwg_password_verify';
$conf['guest_id'] = 1;
$conf['default_user_id'] = $conf['guest_id'];
$conf['browser_language'] = true;
$conf['webmaster_id'] = 2;
$conf['guest_access'] = false; // change this one if you want
$conf['insensitive_case_logon'] = true;

I would not recommend using "username_clean" for the username field because that would result in all the new user albums being created with lowercase names.

I did the following as recommended, even though most of it is not necessary on a fresh install:

Code:

delete from piwigo_user_access;
delete from piwigo_user_cache;
delete from piwigo_user_feed;
delete from piwigo_user_group;
delete from piwigo_user_infos;
delete from piwigo_sessions;
delete from piwigo_rate;
update piwigo_images set rating_score = null, added_by = <webmaster_id>;
delete from piwigo_caddie;
delete from piwigo_favorites;

I then logged in with my phpBB admin username. It worked flawlessly. I was able to view the user manager page in the admin fine.

I activated the Community plugin and the user manager in the admin still worked fine. I did not need to do the other mods done before to fix the Community plugin. All errors were a result of the use of user_id in the Piwigo source code.

Obviously doing this method on the user end will need to be repeated for future updates, and Piwigo should implement it themselves and save us the trouble. I'm going to see if I can manipulate the way Piwigo is accessing the database to work better with phpBB, but I'm not sure if it will work or not. Most of what I've seen is already being aliased.

EDIT:
I did a more in depth post on the phpBB piwigo bridge forum.

Last edited by KungFuJosh (2016-08-24 19:18:20)

Offline

 

#235 2016-08-24 20:36:54

eliz82
Member
Romania
2016-04-27
281

Re: Community plugin, new generation for Piwigo 2.2+

KungFuJosh wrote:

Basically, Piwigo should remove the use of "user_id" from the script entirely.

that will fix the errors for PhpBB3, as you can see in the SMF thread it has errors because another column name is a duplicate in SMF/Piwigo , not with "user_id".
and this kind of fix can generate problems in the future when piwigo or plugins are updated.

Offline

 

#236 2016-08-24 23:24:41

jesiegel
Guest

Re: Community plugin, new generation for Piwigo 2.2+

i just installed Community plugin 2.8.a for Piwigo, when a user uploads a picture I am getting an email, even though i have the system set to high trust.  is there a way to stop the admin from getting this email?

 

#237 2016-08-25 04:31:42

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

eliz82 wrote:

KungFuJosh wrote:

Basically, Piwigo should remove the use of "user_id" from the script entirely.

that will fix the errors for PhpBB3, as you can see in the SMF thread it has errors because another column name is a duplicate in SMF/Piwigo , not with "user_id".
and this kind of fix can generate problems in the future when piwigo or plugins are updated.

Yeah, I mentioned that already. It's something that Piwigo should do themselves. They should make their IDs unique. I suggested it in their issue forum. If they want to gain popularity, they need to gain compatibility first.

Offline

 

#238 2016-08-25 23:53:13

KungFuJosh
Member
2016-08-21
28

Re: Community plugin, new generation for Piwigo 2.2+

By the way, if you're interested... It was really easy for me to integrate WordPress + bbPress with Piwigo. I put the guide here: http://piwigo.org/forum/viewtopic.php?id=26823

Offline

 

#239 2016-08-31 18:24:24

CoolTom
Member
2016-08-31
1

Re: Community plugin, new generation for Piwigo 2.2+

H, I am wondering if there is any way setup Community like:

-new user can create albums and add photos into existing aplbums in root of gallery, but only into albums he created. So on the begining he can have option new album only.

Now you can select access to COMMUNITY album and create subalbums or users folder album and create subalbums or create albums in root but with access to all already existing albums.

I would like to let user create albums in root, but see/be able upload into only him created albums ...

-------------

-another problem i am trying to solve is: when I apply SEO and edit .httaccess file, community plugin doesnt work (upload photo flash plugin not load, when click on html version it take u to the root of gallery, you can not create new album - popup box show up but when u click on create album nothing happend). I guess because of wrong rewriting rules in .htaccess.
Ho to setup it correctly?

I did this changes for SEO:

http://piwigo.org/forum/viewtopic.php?id=17268

<?php
$conf['question_mark_in_urls'] = false;
$conf['php_extension_in_urls'] = false;
$conf['category_url_style'] = 'id-name';
$conf['picture_url_style'] = 'file';
?>

and put into .htaccess lines:

RewriteEngine on
RewriteBase /
RewriteCond %{HTTP_HOST} ^fooo.com$ [NC]
RewriteRule ^(.*)$ http://www.fooo.com/$1 [R=301,L]
AcceptPathInfo On

Last edited by flop25 (2016-09-05 17:04:07)

Offline

 

#240 2016-10-02 17:20:29

procyon82
Member
2016-10-02
2

Re: Community plugin, new generation for Piwigo 2.2+

Hi,

How can I get the HTML uploader to work? I'd also like to make it the default option.

I do not have Flash on my computer (nor do I want to install it!).

Every time I click the 'Browser uploader' link it just goes to the home page, but appends &upload_mode=html to the URL.

http://www.ww2incolor.com/piwigo/
http://www.ww2incolor.com/piwigo/index/add_photos

I've tried different browsers with the same results.

Offline

 
  •  » Extensions
  •  » Community plugin, new generation for Piwigo 2.2+

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact