Announcement

#31 2012-07-25 01:08:02

flop25
Piwigo Team
2006-07-06
6965

Re: Seo clean url with image name

yep but not this one since it's not your thread


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#32 2015-05-08 12:26:13

mindhaq
Member
Berlin
2015-04-16
3

Re: Seo clean url with image name

For me, URLs without question mark stopped working after a server upgrade (Ubuntu 12.04 to 14.04).

I had errors in my logfile like this:

Code:

[negotiation:error] [pid 4018] [client xx.xx.xx.xx:65385] AH00687: Negotiation: discovered file(s) matching request: /var/www/xxxxx/index (None could be negotiated).

Luckily, I found a solution on serverfault.

http://serverfault.com/a/566548

After uncommenting the line application/x-httpd-php in /etc/mime.types and restarting apache, everything worked fine again.

Just to let you know.

Offline

 

#33 2015-09-18 23:03:59

ordually
Guest

Re: Seo clean url with image name

mindhaq wrote:

For me, URLs without question mark stopped working after a server upgrade (Ubuntu 12.04 to 14.04).
...
After uncommenting the line application/x-httpd-php in /etc/mime.types and restarting apache, everything worked fine again.

Thank you Mindhaq! I had this same trouble with 14.04 Ubuntu.

 

#34 2015-12-19 00:35:26

andrewjs18
Member
2014-10-10
40

Re: Seo clean url with image name

mindhaq wrote:

For me, URLs without question mark stopped working after a server upgrade (Ubuntu 12.04 to 14.04).

I had errors in my logfile like this:

Code:

[negotiation:error] [pid 4018] [client xx.xx.xx.xx:65385] AH00687: Negotiation: discovered file(s) matching request: /var/www/xxxxx/index (None could be negotiated).

Luckily, I found a solution on serverfault.

http://serverfault.com/a/566548

After uncommenting the line application/x-httpd-php in /etc/mime.types and restarting apache, everything worked fine again.

Just to let you know.

thank you, this fixed my problem as well.

Offline

 

#35 2016-06-06 16:10:49

helmuc
Member
Maidstone, UK
2013-05-23
73

Re: Seo clean url with image name

Added

Code:

$conf['question_mark_in_urls'] = false;
$conf['php_extension_in_urls'] = false;
$conf['category_url_style'] = 'id-name';
$conf['picture_url_style'] = 'file';

ad updated .htacess with:

Code:

AcceptPathInfo On
Options +MultiViews

--

huge thank you guys :) the urls have changed.. hopefully this will improve the rankings.. otherwise they suck big time :/

http://content.screencast.com/users/helmuc/folders/Jing/media/f809a835-ee5a-4495-92f6-90f2c4627196/artforweb-stats.png

http://content.screencast.com/users/helmuc/folders/Jing/media/427d1e8c-089c-4376-9a0c-8eaa2d1bb9d2/g-analytics-stats.png
Helmuts

p.s. despite all this - I still love piwigo and I'm not giving up my hobby project :)

Last edited by helmuc (2016-06-06 16:16:38)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact