Announcement

  •  » Extensions
  •  » Problem with building pLoader

#1 2011-05-05 17:40:39

ksraghavendra
Member
2011-04-27
9

Problem with building pLoader

Hi,
I am trying to build the pLoader src. I am on Windows and have installed Strawberry. When I run the build_pLoader.bat, I am getting the following error message-
'pp' is not recognized as an internal or external command, operable program or batch file. How do I proceed? Is there an alternate way to package the Perl code on Windows?
Thanks in advance,
Raghav

Offline

 

#2 2011-05-05 18:36:50

bjordan
Member
2011-04-25
30

Re: Problem with building pLoader

It's been a long time since I've worked in Perl but this sounds like a PATH issue. You'll need to make sure the path to your Perl directory (make sure it's the directory with pp in it) is set in your system environment.

Here's a page explaining how to change your path variable in Windows.

http://www.computerhope.com/issues/ch000549.htm

Once it's set the system should be able to find the PAR packager file to proceed.

This might be off base but it sounds like it's the issue.

Edit: Have you installed the "PAR::Packer" package?

http://par.perl.org/wiki/Main_Page

Last edited by bjordan (2011-05-05 18:54:45)

Offline

 

#3 2011-05-06 09:05:36

ksraghavendra
Member
2011-04-27
9

Re: Problem with building pLoader

Hi bjordan,
I have tried what you have suggested-
1) Set the PATH to the appropriate perl directory.

2) Install PAR::Packer - Facing the following issues with installing PAR-
a) When I try to nmake PAR-1.002, I get the following error msgs-

Microsoft (R) Program Maintenance Utility   Version 1.50
Copyright (c) Microsoft Corp 1988-94. All rights reserved.

syntax error at -e line 1, near "'755')
"
Missing right curly or square bracket at -e line 1, at end of line
Execution of -e aborted due to compilation errors.
NMAKE : fatal error U1077: 'C:\Windows\system32\cmd.exe' : return code '0xff'
Stop.

b) When I run "perl Makefile.PL" in PAR-Packer

Set up gcc environment - 4.4.3
Note (probably harmless): No library found for -lkernel32
Note (probably harmless): No library found for -luser32
Note (probably harmless): No library found for -lgdi32
Note (probably harmless): No library found for -lwinspool
Note (probably harmless): No library found for -lcomdlg32
Note (probably harmless): No library found for -ladvapi32
Note (probably harmless): No library found for -lshell32
Note (probably harmless): No library found for -lole32
Note (probably harmless): No library found for -loleaut32
Note (probably harmless): No library found for -lnetapi32
Note (probably harmless): No library found for -luuid
Note (probably harmless): No library found for -lws2_32
Note (probably harmless): No library found for -lmpr
Note (probably harmless): No library found for -lwinmm
Note (probably harmless): No library found for -lversion
Note (probably harmless): No library found for -lodbc32
Note (probably harmless): No library found for -lodbccp32
Note (probably harmless): No library found for -lcomctl32
Note (probably harmless): No library found for -lmsvcrt
Writing Makefile for the par.exe program
Writing Makefile for PAR::Packer

c) When I try to nmake PAR-Packer-1.006, I get the following error msgs-

Microsoft (R) Program Maintenance Utility   Version 1.50
Copyright (c) Microsoft Corp 1988-94. All rights reserved.

         C:\Perl\bin\perl.exe "-Minc::Module::Install" -e "extract_par(q(PAR-Pac
ker-1.006-MSWin32-x86-multi-thread-5.12.3.par))"
Set up gcc environment - 4.4.3
syntax error at -e line 1, near "'755')
"
Missing right curly or square bracket at -e line 1, at end of line
Execution of -e aborted due to compilation errors.
NMAKE : fatal error U1077: 'C:\Windows\system32\cmd.exe' : return code '0xff'
Stop.

How do I proceed?
Regards,
Raghav

Offline

 

#4 2011-05-06 09:31:30

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13606

Re: Problem with building pLoader

Hi ksraghavendra,

Which version of Strawberry Perl did you install? I think pLoader has been built with Perl 5.10 so far, not with Perl 5.12 (for example).

Offline

 

#5 2011-05-06 09:33:44

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13606

Re: Problem with building pLoader

And also: which version of the source code do you test? pLoader trunk or pLoader 1.6?

Offline

 

#6 2011-05-06 13:23:40

ksraghavendra
Member
2011-04-27
9

Re: Problem with building pLoader

Hi plg,
I have installed Strawberry 5.12.2.0 & used pLoader 1.6. Should I try with an earlier version of Strawberry? Is it possible to build the same on ActivePerl?
Regards,
Raghav

Offline

 

#7 2011-05-06 13:39:34

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13606

Re: Problem with building pLoader

I recommend you try with Strawberry Perl 5.10. I do not recommend to use ActivePerl (the build script was designed for Strawberry)

Offline

 
  •  » Extensions
  •  » Problem with building pLoader

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact