Announcement

#1 2012-07-10 10:38:22

zaphoduwe
Member
Ubstadt/Germany
2012-02-20
8

Random Photo doesn´t work with Piwigo 2.4

Hi Folks,

since Piwigo 2.4 the Random photo on my additional homepage (with additional pages) doesn´t work anymore. I took the example of

http://piwigo.com/blog/2011/07/07/a-ran … home-page/

with the code ..... [random album=42] .....

But than I get the message
"Fatal error: Call to a member function has_size() on a non-object in /var/www/web318/html/piwigo/include/derivative.inc.php on line 198 "

I think it´s because of the new multiple sizes of the pics.

I tried also the code ..... [random album=42 size=XL html=no link=no] .... which I found somewhere in the forum. But than I get only the following instead of the showing picture:

./upload/2012/02/28/20120228084453-4eeb9880.jpg

Have someone a solution for my problem?

Thanks a lot

Uwe

Last edited by zaphoduwe (2012-07-10 10:39:42)

Offline

 

#2 2012-07-10 10:43:49

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: Random Photo doesn´t work with Piwigo 2.4

the second version give this result because of "html=no"... which is meaningful I think

can we have a link to your gallery ?

Offline

 

#3 2012-07-10 11:06:18

zaphoduwe
Member
Ubstadt/Germany
2012-02-20
8

Re: Random Photo doesn´t work with Piwigo 2.4

Hi,

I changed the "html=no" to "html=yes" but all I got was the fatal error-Message

My link is http://www.immer-auf-achse.de/piwigo/

But don´t look on the pics and the structure ... I´m still in working process. :-)

Uwe

Offline

 

#4 2012-07-10 11:17:55

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: Random Photo doesn´t work with Piwigo 2.4

can you try with a public album ? like 166

Offline

 

#5 2012-07-10 11:29:19

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13573

Re: Random Photo doesn´t work with Piwigo 2.4

mistic100 wrote:

can you try with a public album ? like 166

Until now, [random album=123] was working even on private albums (I mean "not visible" to the visitor).

Offline

 

#6 2012-07-10 11:35:14

zaphoduwe
Member
Ubstadt/Germany
2012-02-20
8

Re: Random Photo doesn´t work with Piwigo 2.4

Hi,

I tried it with the public album 166.

The only change is that the link of the picture has a "_data/i/" before the former string

_data/i/upload/2012/07/09/20120709155553-9cb78e89-la.jpg


Cheers
Uwe

Offline

 

#7 2012-07-10 11:37:01

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: Random Photo doesn´t work with Piwigo 2.4

try without "html=no" should work

now we must find why it didn't work within the private album
or perhaps it's not this property which is the problem...

Offline

 

#8 2012-07-10 11:50:50

zaphoduwe
Member
Ubstadt/Germany
2012-02-20
8

Re: Random Photo doesn´t work with Piwigo 2.4

.... non .... malheureusement ..... non

the only thing is the Fatal- Error-Message.....

I delete the html=no -> fatal error
I delete the link=no -> the "_data/i/upload .... string" came ..

Salut
Uwe

Offline

 

#9 2012-07-10 12:04:15

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: Random Photo doesn´t work with Piwigo 2.4

arg

I really don't understand what's going one

Offline

 

#10 2012-07-10 12:07:53

zaphoduwe
Member
Ubstadt/Germany
2012-02-20
8

Re: Random Photo doesn´t work with Piwigo 2.4

Hi mistic100,

no problem.... perhaps I will try another start page with fixed Picture ....

It´s not that urgent !!!

Thanks a lot

Uwe

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact