Announcement

#1 2012-08-03 11:16:57

Yogie
Translation Team
Germany
2012-07-24
72

Advanced MetaData Error

Hi,

I really love the Advanced MetaData plugin but it thorws the following errors...

Notice: Array to string conversion in /is/htdocs/.../www/piwigo/plugins/AMetaData/JpegMetaData/JpegMetaData.class.php on line 782

Notice: Array to string conversion in /is/htdocs/.../www/piwigo/plugins/AMetaData/JpegMetaData/JpegMetaData.class.php on line 782

Warning: Cannot modify header information - headers already sent by (output started at /is/htdocs/.../www/piwigo/plugins/AMetaData/JpegMetaData/JpegMetaData.class.php:782) in /is/htdocs/.../www/piwigo/include/page_header.php on line 105

Is there something I do have to configure? Or can anybody explain the errors to me? As this seems not to be happen to any picture could it be that the meta data of the images are broken?

Many thanks and cheers!
Yogie

Last edited by Yogie (2012-08-03 11:27:38)

Offline

 

#2 2012-08-03 12:48:16

geoffschultz
Member
Marlborough, MA, USA
2012-07-01
148

Re: Advanced MetaData Error

Do you have "Grum Plugins Classes.3" installed & active?

-- Geoff

Offline

 

#3 2012-08-03 13:31:24

Yogie
Translation Team
Germany
2012-07-24
72

Re: Advanced MetaData Error

geoffschultz wrote:

Do you have "Grum Plugins Classes.3" installed & active?

Yes, otherwise I would have get a warning that the classes plugin is missing to activate the AMD plugin.

Offline

 

#4 2012-08-04 01:20:35

grum
Piwigo Team
Nantes
2007-09-10
1371

Re: Advanced MetaData Error

to understand the problem, I need an example of the photo producing the error message: I think there's something not recognized in the metadata and to understand why, having the photo will help me.


My pictures with Piwigo, of course !
[ www.grum.fr ] [ photos.grum.fr ]

Offline

 

#5 2012-08-05 12:14:57

Yogie
Translation Team
Germany
2012-07-24
72

Re: Advanced MetaData Error

grum wrote:

to understand the problem, I need an example of the photo producing the error message: I think there's something not recognized in the metadata and to understand why, having the photo will help me.

As it was jut on one specific photo I removed the photo and added it once again from a different source now it works, seems that the EXIF was damaged. As soon as I have another example I'll post a link with that photo.

Thanks!

Offline

 

#6 2012-08-07 10:46:31

romancos
Member
1970-01-01
9

Re: Advanced MetaData Error

I get following:

Notice: Undefined offset: 1 in /home/romancos/public_html/plugins/AMetaData/JpegMetaData/Readers/XmpReader.class.php on line 668

Notice: Undefined offset: 1 in /home/romancos/public_html/plugins/AMetaData/JpegMetaData/Readers/XmpReader.class.php on line 668

Warning: Cannot modify header information - headers already sent by (output started at /home/romancos/public_html/plugins/AMetaData/JpegMetaData/Readers/XmpReader.class.php:668) in /home/romancos/public_html/include/page_header.php on line 105

not only error message appears but also css is corrupt and full image not loading in the lightbox.


Uploaded Images

Last edited by romancos (2012-08-07 10:47:04)

Offline

 

#7 2012-08-08 20:16:51

grum
Piwigo Team
Nantes
2007-09-10
1371

Re: Advanced MetaData Error

romancos wrote:

I get following:

Notice: Undefined offset: 1 in /home/romancos/public_html/plugins/AMetaData/JpegMetaData/Readers/XmpReader.class.php on line 668

Notice: Undefined offset: 1 in /home/romancos/public_html/plugins/AMetaData/JpegMetaData/Readers/XmpReader.class.php on line 668

Warning: Cannot modify header information - headers already sent by (output started at /home/romancos/public_html/plugins/AMetaData/JpegMetaData/Readers/XmpReader.class.php:668) in /home/romancos/public_html/include/page_header.php on line 105

not only error message appears but also css is corrupt and full image not loading in the lightbox.

I've opened a feature in the bug manager ([Bugtracker, ticket 2720, fixed] When malformatted XMP rational values encountered, error message is displayed)
The problem occurs because the metadata in the file are malformatted (values does'nt respect XMP values format) and in this case, the plugin is not able to interpret correctly the value.

To fix the problem, if a value is not correctly formatted, the solution is to ignore the field with the wrong value.



What is the software you've used to set XMP metadata ?


My pictures with Piwigo, of course !
[ www.grum.fr ] [ photos.grum.fr ]

Offline

 

#8 2012-08-09 06:07:12

Yogie
Translation Team
Germany
2012-07-24
72

Re: Advanced MetaData Error

Hi,

I just tested to upload some images with the ApertureToPiwigo plugin and was looking into the results and found these photos throwing an error:

http://www.yogie.de/picture.php?/78/category/13
http://www.yogie.de/picture.php?/83/category/13
http://www.yogie.de/picture.php?/84/category/13
http://www.yogie.de/picture.php?/86/category/13
http://www.yogie.de/picture.php?/88/category/13
http://www.yogie.de/picture.php?/91/category/13
http://www.yogie.de/picture.php?/93/category/13
http://www.yogie.de/picture.php?/94/category/13

I guess that it has something to do with the "Copyright" information as the tab to show the EXIF shows just:    seq, Array

But it would be nice to eliminate the PHP error messages on top and to leave the meta data empty if it is not possible to just display it!? I've checked the difference between the other images that do not throw the error. The copyright field is just empty and the ones with the error are containing my first and last name but without any special character just a blank to divide the names.

Cheers
Yogie

Last edited by Yogie (2012-08-09 06:13:57)

Offline

 

#9 2012-08-11 22:05:13

Yogie
Translation Team
Germany
2012-07-24
72

Re: Advanced MetaData Error

grum wrote:

To fix the problem, if a value is not correctly formatted, the solution is to ignore the field with the wrong value.

Do my images have the same problem or is it different? Do you have a time line to get this fixed?

Many thanks!
Yogie

Offline

 

#10 2012-08-12 09:49:35

grum
Piwigo Team
Nantes
2007-09-10
1371

Re: Advanced MetaData Error

Here we have a different problem.

In XMP format you have 2 things:
- the content (the value)
- the container (the identifier of the the content)

The first example you gave me was a problem about the content: it was not correct, the format was not good according to XMP specification.


Here it's another problem: the container is not correctly defined, according to XMP specification.

The corrupted information is the markup dc:right container, set as SEQ (sequential array) instead of ALT (alternative array).

I think it's possible to do something for this kind of problem.
I've updated the feature [Bugtracker, ticket 2720, fixed] When malformatted XMP rational values encountered, error message is displayed to take it in account.

I'll have some time in september, so I'll try to fix this kind of problem in september.


My pictures with Piwigo, of course !
[ www.grum.fr ] [ photos.grum.fr ]

Offline

 

#11 2012-08-12 20:39:27

Yogie
Translation Team
Germany
2012-07-24
72

Re: Advanced MetaData Error

Thank you so much! looking forward to see you next version! :-)

Offline

 

#12 2012-08-12 21:37:02

grum
Piwigo Team
Nantes
2007-09-10
1371

Re: Advanced MetaData Error

mmh..

in fact, I've found some time this afternoon, a new version will be released very soon ;-)
I've tried to manage kind of case you gave me and try to improve code about other malformatted values (unknown case... ^_^), but I can't tell if it will work each times something wrong will happen with uncorrect metadata.


My pictures with Piwigo, of course !
[ www.grum.fr ] [ photos.grum.fr ]

Offline

 

#13 2012-08-12 23:53:23

grum
Piwigo Team
Nantes
2007-09-10
1371

Re: Advanced MetaData Error

release 0.7.1 is now available.


My pictures with Piwigo, of course !
[ www.grum.fr ] [ photos.grum.fr ]

Offline

 

#14 2012-08-13 06:16:22

Yogie
Translation Team
Germany
2012-07-24
72

Re: Advanced MetaData Error

grum wrote:

mmh..

in fact, I've found some time this afternoon, a new version will be released very soon ;-)
I've tried to manage kind of case you gave me and try to improve code about other malformatted values (unknown case... ^_^), but I can't tell if it will work each times something wrong will happen with uncorrect metadata.

You are a hero! :-) Your modifications are successful I have updated to your last release and the error has been gone, the EXIF data is showing correctly as it should. Many, many thanks! You rock!

Last edited by Yogie (2012-08-13 06:17:01)

Offline

 

#15 2015-04-10 12:31:54

legramo
Member
2015-04-06
5

Re: Advanced MetaData Error

Hi all,

I'm wondering if there's any alternative to Advanced Metadata in Piwigo 2.7

It's a pity that this powerful tool is not supported anymore...

Cheers,
LeGramo

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact