#1 2012-09-26 20:04:47


Linux Lockups on multi-file uploads (flash or browser) - Solved?

After most of 2012 working perfectly as far as uploading batches of jpg files, I suddenly in Sept 2012 started getting lockups at least 1 of every 2 upload attempts. By lockup I mean entire computer freezes, no mouse movement, reboot, repair all mysql piwigo tables after reboot.

I ran a bunch of tests, single files no problem, 2 files or more frequent lockups.

I increased my
post_max_size = 8M
post_max_size = 2000M

I then ran successfully 4 upload batches of around 30-40 jpg files directory size 50-60MB each.

I tried a batch totaling 208M which caused a lockup. After reboot and mysql repairing I had 4 of the files in that last batch in a funny state in piwigo (no image at all no thumbnail, no file info). I nuked the album with the last upload failures, increased

post_max_size = 20000M

and have not been able to crash it since.

I'm curious if I got a linux patch that reset my post_max_size down to 8M that causes this terrible behavior. It is possible, though very unlikely with all the tests i ran on same day - that the post_max_size is not causing the issue. Currently it seems to be the case.

I couldn't find similar issue on forums and wanted to post my possible solution in case helpful to others with same problem.



#2 2012-09-26 20:22:54


Re: Linux Lockups on multi-file uploads (flash or browser) - Solved?

Possibly the same or related problem here. Using the flash uploader fails with "IO Error". Browser uploader works OK. AFAIKT my server params are OK for the size of the files. I'm uploading large files to other php webapps with no issues. I gave up since I decided ftp sync is a better approach for my needs for now...but would like to fix this.

Machine I'm uploading from : ubuntu 12.04 64-bit and Firefox 15.0.1. Same behavior with chrome.



#3 2012-09-26 20:30:53


Re: Linux Lockups on multi-file uploads (flash or browser) - Solved?

Not sure if this is related but recently the flash uploader has stopped working for me under Safari with a similar error.  I am running OSX Mountain Lion.  I get an IO HTTP 500 error.



Board footer

Powered by FluxBB

github twitter newsletter Donate © 2002-2021 · Contact