Announcement

#1 2014-03-12 16:37:52

And
Guest

Errors after moving to new server

Hi,

Firstly, I have rather very little idea of what am I doing.
I've downloaded all the files from my old server and I've exported mysql database. After uploading, datebase has new prefix so I've changed it to new name in database.inc.php and also changed user name to new. There was still db error and I've found out there was no user assigned to piwigo db in cpanel. So I've added manualy new user to db through my cpanel. After adding the user to db, piwigo gallery has errors (bar with "Bad status for user "guest", default status will be used. Please notify the webmaster." and there are errors all over the page) and no pictures. I can't log in as admin as "Cookies are blocked or not supported by your browser. You must enable cookies to log in." message shows up.

sorry for beeing chaotic. I don't know much about all of those things so I'd be very grateful if someone could help me.

Piwigo vr: 2.3.5
Host is on the same server so I don't think that php and MySQL versions have changed.
http://100pdh.pl/piwigo/

 

#2 2014-03-12 17:29:48

rvelices
Piwigo Team
2005-12-29
1960

Re: Errors after moving to new server

It appears the db tables are not there. Did you reimport the mysql database ?
Try phpmyadmin until the tables are there with some rows ...

Offline

 

#3 2014-03-12 18:26:27

And
Guest

Re: Errors after moving to new server

You are right. Thanks! That seems to be a problem. Just found out that after reimporting database there is an error:

<!-- PMA-SQL-ERROR --> <div class="error"><h1>Błąd</h1> <p><strong>Zapytanie SQL:</strong> <a href="tbl_sql.php?sql_query=SHOW+TABLE+STATUS+FROM+%60cl103430_piwi480%60+LIKE+%27piwi_history_summary%27&amp;show_query=1&amp;db=cl103430_piwi480&amp;table=piwi_history_summary&amp;token=407aaf5d90c162c6220146edf9819c38"><span class="nowrap"><img src="themes/dot.gif" title="Edytuj" alt="Edytuj" class="icon ic_b_edit" /> Edytuj</span></a> </p> <p> <span class="syntax"><span class="inner_sql"><a href="./url.php?url=http%3A%2F%2Fdev.mysql.com%2Fdoc%2Frefman%2F5.1%2Fen%2Fshow.html&amp;token=407aaf5d90c162c6220146edf9819c38" target="mysql_doc"><span class="syntax_alpha syntax_alpha_reservedWord">SHOW</span></a> <span class="syntax_alpha syntax_alpha_reservedWord">TABLE</span> <span class="syntax_alpha syntax_alpha_reservedWord">STATUS</span> <span class="syntax_alpha syntax_alpha_reservedWord">FROM</span> <span class="syntax_quote syntax_quote_backtick">`cl103430_piwi480`</span> <a[...]

MySQL zwrócił komunikat: Dokumentacja

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<!-- PMA-SQL-ERROR -->
    <div class="error"><h1>BÅ‚Ä…d</h1>
<p><strong>Zapytan' at line 1

There is something wrong in the datebase but I can't dig anywhere what exactly. Removing <!-- PMA-SQL-ERROR --> doesn't change anything. Something with <div class="error"> ?

 

#4 2014-03-12 18:28:40

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
7056

Re: Errors after moving to new server

Hi :-)

Have you delete user directly on data base ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#5 2014-03-12 18:44:56

And
Guest

Re: Errors after moving to new server

ddtddt wrote:

Hi :-)

Have you delete user directly on data base ?

You speak in riddles ;]
Consider me dumb as I am seeing database file for the first time today.

I didn't delete anything. I've imported database from old server host. I've created new database through cpanel with the name rk10340_piwi480 as the old one I've downloaded was cl103430_piwi480. I've reimported old database through phpMyAdmin to rk10340_piwi480. Then I've created user rk10340_piwi480 in this datebase in cpanel. I've updated database.inc.php with rk10340_piwi480 user and base.

 

#6 2014-03-12 19:59:32

flop25
Piwigo Team
2006-07-06
7037

Re: Errors after moving to new server

And wrote:

You are right. Thanks! That seems to be a problem. Just found out that after reimporting database there is an error:

<!-- PMA-SQL-ERROR --> <div class="error"><h1>Błąd</h1> <p><strong>Zapytanie SQL:</strong> <a href="tbl_sql.php?sql_query=SHOW+TABLE+STATUS+FROM+%60cl103430_piwi480%60+LIKE+%27piwi_history_summary%27&amp;show_query=1&amp;db=cl103430_piwi480&amp;table=piwi_history_summary&amp;token=407aaf5d90c162c6220146edf9819c38"><span class="nowrap"><img src="themes/dot.gif" title="Edytuj" alt="Edytuj" class="icon ic_b_edit" /> Edytuj</span></a> </p> <p> <span class="syntax"><span class="inner_sql"><a href="./url.php?url=http%3A%2F%2Fdev.mysql.com%2Fdoc%2Frefman%2F5.1%2Fen%2Fshow.html&amp;token=407aaf5d90c162c6220146edf9819c38" target="mysql_doc"><span class="syntax_alpha syntax_alpha_reservedWord">SHOW</span></a> <span class="syntax_alpha syntax_alpha_reservedWord">TABLE</span> <span class="syntax_alpha syntax_alpha_reservedWord">STATUS</span> <span class="syntax_alpha syntax_alpha_reservedWord">FROM</span> <span class="syntax_quote syntax_quote_backtick">`cl103430_piwi480`</span> <a[...]

MySQL zwrócił komunikat: Dokumentacja

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<!-- PMA-SQL-ERROR -->
    <div class="error"><h1>BÅ‚Ä…d</h1>
<p><strong>Zapytan' at line 1

There is something wrong in the datebase but I can't dig anywhere what exactly. Removing <!-- PMA-SQL-ERROR --> doesn't change anything. Something with <div class="error"> ?

would mind copy/pasting the full text without html?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2014-03-12 22:07:49

And
Guest

Re: Errors after moving to new server

ok thanks for help. Thanks to you I've located the problem. I can't download whole db for some reason. I tried to download it partialy but it seems that piwi_history is too big and the download crashes every time :/

 

#8 2014-03-12 23:43:41

And
Guest

Re: Errors after moving to new server

It's working. Thanks for help. Your

would mind copy/pasting the full text without html?

made me realise that there should be no such html code in database and that my db was incomplete. I've exported it in multiple parts and then imported.

 

#9 2015-07-02 06:57:55

Nitin
Guest

Re: Errors after moving to new server

Got the same error.... then i took a back up from back option in cpanel which is downloadable in .gz format, it got successfully restored on new server.

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact