Announcement

  •  » Extensions
  •  » Possible bug with SmartAlbums 2.2.2

#1 2014-04-05 05:33:49

Mark O'Shea
Member
2013-05-27
26

Possible bug with SmartAlbums 2.2.2

Hello,

I've had a problem after installing SmartAlbums version  2.2.2

The error went away after I manually downgraded to SmartAlbums version 2.2.1.

When I pressed the button: "Administration - Albums - Manage - Regenerate photos list of all SmartAlbums", or the same button in the plugin, I got this error:


Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')
      )
  GROUP BY i.id
  ORDER BY date_creation DESC' at line 7

SELECT i.id
  FROM piwigo_images AS i
  WHERE
    i.id NOT IN (
      SELECT image_id
        FROM piwigo_image_category
        WHERE category_id IN()
      )
  GROUP BY i.id
  ORDER BY date_creation DESC
 
; in /var/www/gallery/include/dblayer/functions_mysqli.inc.php on line 798
Fatal error: Call to a member function fetch_assoc() on a non-object in /var/www/gallery/include/dblayer/functions_mysqli.inc.php on line 181


I'm going to stay with SmartAlbums Version 2.2.1 for now.

I'm running with Piwigo as follows:

Piwigo version: 2.6.2
PHP version: 5.3.3-7+squeeze15
MySQL version: 5.1.66-0+squeeze1
Graphics Library: External ImageMagick 6.6.0-4

Advanced Menu Manager    Version 3.2.6
AStat.2    Advanced statistics Version 2.4.2
Crypto Captcha Version 2.1.2
Grum Plugins Classes.3 Version 3.5.6
GThumb+    Version 2.6.b
Header Manager Version 1.1.0
Language Switch    Version 2.6.2
LocalFiles Editor    Version 2.6.0
Rotate Image    Version 2.6.a
SmartAlbums    Version 2.2.1 (no errors with this version)
Statistics    Version 2.6.a
UserAdvManager Version 2.60.2

11722 photos
44 albums including 40 physical and 4 virtual (35640 associations)

Cheers
Mark

Offline

 

#2 2014-04-05 20:20:17

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: Possible bug with SmartAlbums 2.2.2

hi

2.2.3 should be ok

Offline

 

#3 2014-04-05 21:17:32

Mark O'Shea
Member
2013-05-27
26

Re: Possible bug with SmartAlbums 2.2.2

Hi,

Thanks for looking in to this so quickly.

I've now upgraded to SmartAlbums version 2.2.3 and it's all working fine for me.

Cheers

Mark

Offline

 
  •  » Extensions
  •  » Possible bug with SmartAlbums 2.2.2

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact