Announcement

  •  » Extensions
  •  » [FIXED] [Contact Form] Not send plain - Bug?

#1 2014-05-13 11:35:08

matthys
Member
2014-04-02
147

[FIXED] [Contact Form] Not send plain - Bug?

Hello everyone,

For the Contact Form plugin I selected "Plain text" at the E-mail format configuration.

However I still receive HTML Emails and was expecting only plain text.
I checked the header and it says:
Content-Type: multipart/alternative;
    boundary="b1_417b854ea02b35c7490b9cfe547d5392"

--b1_417b854ea02b35c7490b9cfe547d5392
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

--b1_417b854ea02b35c7490b9cfe547d5392
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 8bit

But it included HTML code and therefore displayed as HTML Email.
If you use HTML code within the contact form it will work ...

But the reason I want plain text is people could inject 'bad' (read hacking/spammer) HTML code in the Email.
And I just want to avoid problems etc...
I wonder if this is as it should work or if it's a bug?

PS .. it does contain the plain text as well as the HTML text, as you can read from the header information.

Piwigo version: 2.6.2
PHP: 5.5.9-1ubuntu4 [2014-05-13 11:29:40]
MySQL: 5.5.37-0ubuntu0.14.04.1-log [2014-05-13 11:29:40]

Last edited by matthys (2014-05-13 20:20:43)

Offline

 

#2 2014-05-13 19:49:10

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: [FIXED] [Contact Form] Not send plain - Bug?

thanks

try 2.6.6

Offline

 

#3 2014-05-13 20:19:18

matthys
Member
2014-04-02
147

Re: [FIXED] [Contact Form] Not send plain - Bug?

Thanks for the quick fix, works fine now ;-)

X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Offline

 
  •  » Extensions
  •  » [FIXED] [Contact Form] Not send plain - Bug?

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact