Announcement

#1 2014-10-22 03:01:35

Mark O'Shea
Member
2013-05-27
26

Photo page icons no longer function after upgrade to 2.7.1

Hello,

I am having a problem that I have only just noticed today after upgrading to Piwigo 2.7.1 about a week ago.

The small icons at the top of each photo page are present but no longer function. The icons available for admins should be: picture size; meta info; gallery highlight; edit; and comment. The navigation arrows alongside these icons still work correctly. When I access the gallery as guest user, less icons are displayed (as I would expect) but the ones present (photo size and meta data) also do not work.

When I look at the "configuration - options - photo sizes" menu I now do not see my selected options, just a page showing the option headings but with no selection showing. The pre-selected options do display occasionally. The same goes for the options on the display menu. At a guess I would say that I have seen my ticks next to the menu items only about 5% of the time whilst I have been flicking through menus trying to workout what has gone wrong. I can not tell you what I did to make the option choices appear on the menu pages.

I know the system has remembered my selected picture sizes because my choices can be seen when I go into "batch manager - global mode" and choose to generate multiple size images.

I have tried reloading all the Piwigo files by FTP and repaired and optimized the database but still no joy.

Any ideas?

Cheers
Mark


Piwigo version: 2.7.1
PHP version: 5.3.3-7+squeeze15
MySQL version:  5.1.66-0+squeeze1
Piwigo URL: www.markoshea.co.uk/gallery/

Active Plugins
AStat.2
Crypto Captcha
Grum Plugins Classes.3
GThumb+
Header Manager   
Language Switch
LocalFiles Editor
Rotate Image 
SmartAlbums
Statistics

Inactive Plugins
Admin Tools
Advanced Menu Manager
Take A Tour of Your Piwigo
UserAdvManager

Offline

 

#2 2014-10-22 08:50:18

kuzco
Member
2013-09-17
59

Re: Photo page icons no longer function after upgrade to 2.7.1

Hello,
on which device do you have this issue ? Only on iPad ? Which theme ?
If yes with "elegant" theme, I had the same issue. I am using now the "old elegant theme 2.6.2. THis is working.

regards
kuzco

Offline

 

#3 2014-10-22 19:13:49

Mark O'Shea
Member
2013-05-27
26

Re: Photo page icons no longer function after upgrade to 2.7.1

Thanks. I noticed the problem yesterday whilst using the elegant theme on my desktop PC.

I have checked today (accessing the gallery from a different PC) and the problem is no longer present. All the icons above the photos are now working. I will try again later with the first PC and report back.

Nothing further was done to the gallery or the server after I reported the problem yesterday.

I still want to find out what caused it to go wrong. If the problem returns, I will try changing the theme in case that's the cause.

Cheers
Mark

Offline

 

#4 2014-10-22 19:43:23

kuzco
Member
2013-09-17
59

Re: Photo page icons no longer function after upgrade to 2.7.1

On a PC I do not have the issue, only on my iPad.

Offline

 

#5 2014-10-22 19:56:22

Mark O'Shea
Member
2013-05-27
26

Re: Photo page icons no longer function after upgrade to 2.7.1

I guess it's a different problem then. Thanks for the help anyway.

I'm beginning to think that this is something to do with permissions. That could explain why I couldn't use the icons, or even access the options menu to alter their properties.

Offline

 

#6 2014-10-23 01:57:54

Mark O'Shea
Member
2013-05-27
26

Re: Photo page icons no longer function after upgrade to 2.7.1

Hello,

I've done a bit more testing and it appears that I only get the problem when using Google Chrome Version 34.0.1847.131 m which unfortunately is the last version compatible with my Windows XP PC due the limitations of my ageing 32 bit processor.

On Internet Explorer 8.0.6001.18702 it works fine and also on a Windows 8.1 PC, running the latest version of Chrome.

I have activated all my a plugins now and have noticed that the functionality I lost in the icons has been replicated in the mew admin menu bar.

Anyone know if this behaviour is something I will just have to get used to?

Cheers
Mark

Offline

 

#7 2014-10-23 03:53:26

Murray
Guest

Re: Photo page icons no longer function after upgrade to 2.7.1

I have the same issue with Chrome 38.0.2125.104 m.
I lose the ability to resize while viewing in picture.php.

Windows 8.1 64

Works fine on IE 11.0.13

 

#8 2014-10-23 03:58:40

Murray
Guest

Re: Photo page icons no longer function after upgrade to 2.7.1

I just downloaded Chrome 64 Beta (Version 39.0.2171.36 beta-m (64-bit)) and guess what?  It started working again.

 

#9 2014-10-23 20:05:24

Mark O'Shea
Member
2013-05-27
26

Re: Photo page icons no longer function after upgrade to 2.7.1

How odd, because on my Windows 8.1 64 bit work PC it works correctly for me in Google Chrome Version 38.0.2125.104 m.

Cheers
Mark

Offline

 

#10 2014-10-24 20:47:18

Mark O'Shea
Member
2013-05-27
26

Re: Photo page icons no longer function after upgrade to 2.7.1

I'm going to keep my fingers crossed that someone out there knows what's causing these problems.

Just checked today and it working fine in Chrome Version 38.0.2125.104 m and in Internet Explorer 11 version 11.0.9600.17207 (Update Versions 11.0.10) on Windows 8.1 64 bit.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact