Announcement

#1 2015-04-26 21:23:26

Erik
Guest

PHP 5.5.x Deprecated Error in Smarty

Hello,

after I updated my server and get a newer, nearly up-to-date PHP version I have the following deprecated warning from a smarty function.

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/***/piwigo/include/smarty/libs/plugins/modifier.capitalize.php on line 43

At the moment I manually reduce the PHP-Error-Level inside the ./piwigo/include/config_default.php:
$conf['show_php_errors'] = E_ALL ^ E_DEPRECATED;

I don't think that should be the solution. Maybe you can update or fix the Smarty inside in a official update.

Piwigo version: 2.7.4
PHP version: 5.5.9-1ubuntu4.9
MySQL version: 5.5.43-0ubuntu0.14.04.1
Piwigo URL: http://

 

#2 2015-04-26 21:44:45

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: PHP 5.5.x Deprecated Error in Smarty

It will, in Piwigo 2.8

and DO NOT MODIFY CORE FILES (there is 'default' in the name for a reason)
there is a plugin named LocalFiles Editor to modify the advanced configuration

Offline

 

#3 2015-04-27 19:30:42

Erik
Guest

Re: PHP 5.5.x Deprecated Error in Smarty

Good to hear that.
I forgot the plugin. I use it know and reverted the core file.

 

#4 2015-08-03 01:01:52

pchowla
Guest

Re: PHP 5.5.x Deprecated Error in Smarty

Dear friends,

I am not sure if my error is the same as the one described above, because I am not sure what "Smarty" is. I am guessing it is the same for the error I get below. I have a brand new install of Piwigo (latest version 2.7.4). I get a very similar error on mouse over of images. I am using elegant theme - and on mouse over a black box rises up presumably to show caption or title. But instead it always says:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /usr/www/users/pl1552/photo/include/smarty/libs/plugins/modifier.capitalize.php on line 43

I didnt have this error on install, photo upload, album creation etc.

Piwigo 2.7.4
Operating system: FreeBSD
PHP: 5.6.11
MySQL: 5.1.56-log

Should I wait for Piwigo 2.8 for this to fix?

Many thanks for guidance.

 

#5 2015-08-03 16:19:17

pchowla
Member
2015-08-03
1

Re: PHP 5.5.x Deprecated Error in Smarty

pchowla wrote:

I didnt have this error on install, photo upload, album creation etc.

An update. I don't get this error on all photos. I did an import on 1,500 photos from a Menalto gallery. Those photos do not display the same error on mouseover, just the ones I uploaded via piwigo itself.

Piwigo location: http://www.chowla.org/photo/

Last edited by pchowla (2015-08-03 16:19:54)

Offline

 

#6 2016-01-13 16:25:16

Bredy
Guest

Re: PHP 5.5.x Deprecated Error in Smarty

If I install gdThumb I have this error:
The /e modifier is deprecated, use preg_replace_callback instead in /home/------/include/smarty/libs/plugins/modifier.capitalize.php on line 43

How can I solve this problem?
Thanks

 

#7 2016-01-14 10:46:19

flop25
Piwigo Team
2006-07-06
7037

Re: PHP 5.5.x Deprecated Error in Smarty

Erik wrote:

reduce the PHP-Error-Level inside the ./piwigo/include/config_default.php:
$conf['show_php_errors'] = E_ALL ^ E_DEPRECATED;


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact