Announcement

#1 2016-05-29 14:20:41

antigone
Member
2016-05-28
12

Can't upload any images after update to 2.8.1, gets stuck uploading

Hello,

Reposting from another thread as you said:

Hello and thanx first of all for the incredible Piwigo gallery!

I have an issue after the update to 2.8.1 that the upload gets stuck in the screen after the last file uploaded.
Nothing gets uploaded anymore!
I really love Piwigo and would love to continue using it, but I can't find a way to upload images to my gallery.
I think it is my first update from the previous version, but am not sure 100%. Previous version was working fine even with the php.ini file error I was receiving. I can't recall the exact version number but I have installed Piwigo like beginning of 2016 or a little later, so it can't be a very old version.

I reuploaded the whole installation via FTP like suggested in this thread (http://piwigo.org/forum/viewtopic.php?id=23208) and put a php.ini into the piwigo directory since I was getting the "In your php.ini file, the upload_max_filesize (128MB) is bigger than post_max_size (32MB), you should change this setting" error which reads like this:
"safe_mode=OFF
disable_functions=NONE
memory_limit = 64M
upload_max_filesize = 64M
post_max_size = 64M
date.timezone = Europe/Athens
file_uploads = On
max_execution_time = 300"

I have turned off all plug-ins, but still no luck.

Server logs show no error.

The pLoader does not work under OSX 10.11.5 so I can't try that out, either.

I attached the second uploading window where the process gets stuck

Any help is greatly appreciated!

Thank you in advance
Antigone


Piwigo version: 2.8.1
PHP version: 5.4.36
MySQL version: 5.5.45-cll-lve
Piwigo URL: http://www.i-dentity.gr/gallery_p (you need a password to login, since all files are hidden, I use the gallery for my dental clinic and everything has to be kept private)


Uploaded Images

Last edited by antigone (2016-05-29 14:27:09)

Offline

 

#2 2016-05-29 14:49:36

flop25
Piwigo Team
2006-07-06
6965

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

Thx for your great report

well well... could install a fresh 2.8.0 https://github.com/Piwigo/Piwigo/archive/2.8.0.zip (just a temporary folder and set a different table prefix) to test?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2016-05-29 16:17:06

Gloria
Guest

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

I am having the same/similar problem. When I go to upload pics it almost instantly puts caution signs on the pics file names and then locks the upload.

It's bad enough that if I try to go to maintenance or anything else, it will lock up my entires site with "This site can't be reached  /**Direct link piwigo please **/  took too long to respond.  ERR_CONNECTION_TIMED_OUT

First time I thought it was me or my service provider, but it's happened every time I've attempted to upload pics the last few Sundays. (My normal upload day) The fact it locks the whole site is extremely worrisome. 

Have loved the program so far, and hope to keep using it. Since reinstalling did not work for the gentleman who created the thread, I will wait to hear if the next solution works or not. I'm just savvy enough to get most things done, but not enough to try stuff randomly. :P

Thanks!

P.S. My piwigo is in a separate folder from the normal website

Last edited by ddtddt (2016-05-30 06:19:19)

 

#4 2016-05-31 21:32:28

antigone
Member
2016-05-28
12

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

Hello,

Update to previous:

I did a fresh installation of version 2.8.1 via cPanel and I got the yellow triangle caution sign next to every picture while uploading. Of course the upload got stuck in the second window again.

Then I did a fresh manual installation of 2.8.0 via FTP and exactly the same thing happened.

Any further ideas?

Is there any lower version I could try?

Thank you again for all your help!

Antigone

Btw. Gloria, I am a woman, not a gentleman ;)

Last edited by antigone (2016-05-31 21:34:22)

Offline

 

#5 2016-05-31 22:25:49

antigone
Member
2016-05-28
12

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

Hello again,

Update 2 to previous:

I contacted my hosting support, since I thought that maybe this could be a more general problem and they solved it.
This is what they said:

"One of ModSecurity rules have been triggered by Piwigo.
ModSecurity is an web-based firewall application that is configured to protect web applications from various attacks.
Sometimes, due to poor website coding, mod_security may incorrectly determine that a certain request is malicious, while it is legitimate actually.
So, in case of such false-positive results it is recommended just to whitelist the mod_security rule in question which we did."

Now everything is working fine. I can upload again and don't get any error messages or stuck pages.

So I guess it is a Piwigo related problem that can be solved by the hosting company until it happens again, or until the software stops triggering ModSecurity.

Antigone

Offline

 

#6 2016-06-01 10:34:44

flop25
Piwigo Team
2006-07-06
6965

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

antigone wrote:

Sometimes, due to poor website coding, mod_security may incorrectly determine that a certain request is malicious, while it is legitimate actually.

http://i.giphy.com/nqSxeI6cVrBba.gif

so no technical detail about what rules was triggered? Maybe a htaccess or php.ini at the root of your website?
And there was nothing any logs about that? Hmm Sometimes due to poor server config, people can't correctly determine what's wrong on a website...


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2016-06-05 20:49:11

antigone
Member
2016-05-28
12

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

Hello,

I'm not a software developer, nor a tech. I just said what THEY told me. Of course in an environment that is based on so many things, it is hard to figure out where the fault is. Fact is that they solved it in less than 5 minutes while I was for 3 days trying to figure out with forums what was wrong. So on the one hand you could say that they were familiar with issues like that and thats why they knew how to solve it so fast. This can be due to their coding of course, too.
But I would not expect them to explain technical issues over a costumer help line.
In the end the only thing I am interested in is, that my site works again with a gallery that I'm really much fond of and that helps me in my everyday practice.
When issues arise they need to be solved and anyone who posts questions tries to find answers for himself and for all the people that need them, too, and this is nothing to be ironic about.

Antigone

Offline

 

#8 2016-06-05 21:05:58

flop25
Piwigo Team
2006-07-06
6965

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

don't take it personally! that was of course directed against their tech support and their thinly veiled accusation. And I'm pointing out their lack of precision; even in a domain I don't know much I always expect a solid technical explanation of what was wrong and not accusations against third party parts, weather or government. They were fast so they seems to be used to have such issues with their config
And of course thanks for sharing the solution


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#9 2016-06-24 10:41:05

Walt
Guest

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

I'm beginning to believe that the 2.8 upgrade wasn't functional when released and Piwigo has no real solutions.  Cutting to the chase, I have followed all of your "Instructions" . I got past the upload problem and then all of my pics had the triangle error.  Auto back up failed.  Then site locked up on the upgrade.php file.  I'm in the process of deleting everything from my domain and reinstalling a clean copy of 2.8.1.  Now other forums say that doesn't work. 

How do I reinstall my 5055 pictures in the proper directory structure after my reinstall?

No bullshit "I've already answered that" answers.  Please.

 

#10 2016-06-26 12:54:25

flop25
Piwigo Team
2006-07-06
6965

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

Walt wrote:

I'm beginning to believe that the 2.8 upgrade wasn't functional when released and Piwigo has no real solutions.  Cutting to the chase, I have followed all of your "Instructions" . I got past the upload problem and then all of my pics had the triangle error.  Auto back up failed.  Then site locked up on the upgrade.php file.  I'm in the process of deleting everything from my domain and reinstalling a clean copy of 2.8.1.  Now other forums say that doesn't work. 

How do I reinstall my 5055 pictures in the proper directory structure after my reinstall?

No bullshit "I've already answered that" answers.  Please.

?
This post is about the case of Antigone whose hosting provider has enabled the mod_security in a bad way (that module is anyway quite useless) without any feedback for the client when the module is blocking something internally. Nothing to do with the update. at all

Now Walt if you could post a link to your thread where you explained your issue or registered on the forum so we could see easier where and what you posted, that would be more useful for everyone . You can either continue to moan and whinge, or try to solve the problem in a constructive way.


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#11 2016-07-09 06:43:27

Walt
Guest

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

But I Love it when you moan and whine.  Anyway.  My tricky self had a another gallery running 2.7.4 so most of my pictures are there.  When I upload a new picture I get the triangle exclamation point. My browser has been firefox for years.

Now I get this

http://luckypuppy.bravehost.com/GALLERY … ecent_pics


What is the symbol trying to tell me. 

When I clicked to see the picture lo and behold I got this! Yay.

http://luckypuppy.bravehost.com/GALLERY … ategory/12

I've disabled all of my plug ins.

 

#12 2016-08-18 16:52:43

cally6008
Member
2015-03-03
19

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

update for antigone

thanks for posting this as it explains why i couldnt upload either

my hosts said ...

The application firewall is blocking the request as it considers your application vulnerable:

[Thu Aug 18 12:10:32.550656 2016] [:error] [pid 5036] [client 86.164.185.245] ModSecurity: Access denied with code 403 (phase 2). Match of "eq 1" against "&SESSION:pwg" required. [file "/usr/local/apache/conf/modsec_vendor_configs/comodo_apache/32_Apps_OtherApps.conf"] [line "2585"] [id "241783"] [rev "1"] [msg "COMODO WAF: CSRF vulnerability in Piwigo before 2.6.2 (CVE-2014-4614)||www.tracingequines.co.uk|F"] [hostname "xxx"] [uri "/photos/ws.php"] [unique_id "V7WluFvF5rkAABOsDhQAAAAG"]

"COMODO WAF: CSRF vulnerability in Piwigo before 2.6.2 (CVE-2014-4614)"


If anyone from Piwigo happens to read this, I do think you need to look into errors that members are posting and work out why

Offline

 

#13 2016-08-18 17:23:14

flop25
Piwigo Team
2006-07-06
6965

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

hello cally6008
as you can easily see by searching CVE-2014-4614, the message refers to https://cve.mitre.org/cgi-bin/cvename.c … -2014-4614 which is http://piwigo.org/bugs/view.php?id=0003055 and so was fixed in 2014

So it sounds like the ModSecurity makes a false positive

and to answer directly to

If anyone from Piwigo happens to read this, I do think you need to look into errors that members are posting and work out why

the details you gave was exactly what I -we- was waiting for and that's the kind of answer I expect from a professional webhosting. Unfortunately the one of Antigone was not one of them.

To conclude on that, we will try to change our code to bypass that block, and probably report here https://github.com/SpiderLabs/owasp-modsecurity-crs if i'm not mistaken


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#14 2016-10-03 22:14:49

Derrick
Guest

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

I was able to uplaod again once I logged into my cpanel and turned off ModSecurity for my subdomain which holds my Piwigo.

 

#15 2016-10-03 22:52:10

Derrick
Guest

Re: Can't upload any images after update to 2.8.1, gets stuck uploading

I logged back into my cpanel and turned it back on and all is well. Able to upload.

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact