Announcement

#1 2017-06-16 23:28:31

elsatobias
Member
2012-07-11
13

ImageMagick GPS php error after update to 1.2

Hello all,

first of all I would like to give my feedback, that the plugin worked great with the inital 1.0 release and I got my GPS information after import.

After updating the plugin to 1.2 version, I got following php error

Notice: Undefined index: imagemagick_gps in /Web/Piwigo/plugins/ImageMagick_GPS/include/imagemagickgps.class.inc.php on line 31

Warning: Cannot modify header information - headers already sent by (output started at /Web/Piwigo/plugins/ImageMagick_GPS/include/imagemagickgps.class.inc.php:31) in /Web/Piwigo/include/page_header.php on line 101

In "Show EXIF data" tab of the plugin page I also get:

Warning: read_exif_data(XYZ.jpg): IFD data bad offset: 0xFFFFFD10 length 0x0EBA in /Web/Piwigo/plugins/ImageMagick_GPS/admin/read.php on line 78

As my php knowledge of php is not even base level, can someone are more General error, that ZeBe has to fix or is it a Special error as of my configuration.

I can deliver further information, if requested.

Thanks in advance
Tobi

Piwigo version: 2.9.1
PHP version: 5.5.38
MySQL version: 5.1.73
Piwigo URL: http://

Edit: Added error message of plugin tab page

Last edited by elsatobias (2017-06-16 23:34:23)

Offline

 

#2 2017-06-17 16:53:51

ZeBe
Member
Bavaria
2017-06-06
16

Re: ImageMagick GPS php error after update to 1.2

Hello tobi,

many thanks for your feedback.

The warning displayed in the 'Show exif data' tab is correct. It comes direct from the php function 'read_exif_data'.  It is dependent on the exif data of your picture. I get this warning for pictures from my canon DLSR with MAKERNOTE and GPS data embedded. The exif data of pictures from my LG smartphone can be read without any warnings. Probably is this the PGP bug that GPS data are not read out. Probably it would be better when i give a hint on this tab that the displayed warning/errors comes direct from php function 'read_exif_data'.

When did you get the 'Notice: Undefined ...' and the 'Warning: Cannot ...'?
Direct after the update of the plugin?
Can you change the settings in the configuration tab?
Are the settings the same after a new visit of the configuration tab?

This is my first PHP project and I am not a PHP expert. Most of my PHP knowledge is from reading source files of other plugins and some infos from stackoverflow.

ZeBe

Added 'MAKERNOTE'

Last edited by ZeBe (2017-06-17 17:04:44)

Offline

 

#3 2017-06-19 22:45:02

ZeBe
Member
Bavaria
2017-06-06
16

Re: ImageMagick GPS php error after update to 1.2

Hello Tobi,

i released version 1.3, which should fix the error/warning at installation.

ZeBe

Offline

 

#4 2017-06-20 20:01:48

elsatobias
Member
2012-07-11
13

Re: ImageMagick GPS php error after update to 1.2

Hello ZeBe,

sorry for my late reply. I had not the time to care about my Piwigo. Although you posted your update, I will answer your questions. By the way, I could not update, but had to deinstall your plugin and reinstall it from scratch. I have not investigated, what the problem was.

So, I got the 'Notice: Undefined ...' message right after installation of version 1.2, and I had the message on top of all pages. The update fixed this message.

I think you are right with the 'Warning: Cannot ...' message. But I get this warning even with my older pictures, and some months/year(s) ago, the php import worked fine with GPS data (with the same camera). So perhaps there was a revision of the read_exif_data function.

Unfortunately I now get the error message

Warning: Cannot modify header information - headers already sent by (output started at /Web/Piwigo/plugins/ImageMagick_GPS/admin/read.php:1) in /Web/Piwigo/include/page_header.php on line 101

when I enter the "Show exif data" tab of your plugin (Version 1.3).
I think you should delete the space in front of the "<?php" header in read.php.

I would like to say thank you for your work so far and the fast error corrections.

Greetings
Tobi

Edit: Added the solution for the error message

Last edited by elsatobias (2017-06-20 20:16:07)

Offline

 

#5 2017-06-21 21:31:38

ZeBe
Member
Bavaria
2017-06-06
16

Re: ImageMagick GPS php error after update to 1.2

Hello Tobi,

on my webspace with PHP version 7.0.19 there is no warning. So i don't know how i can reproduce the warning you have. I removed the leading space in read.php like you suggested and i hope this will solve it.

Greetings
  ZeBe

Offline

 

#6 2017-06-22 12:12:21

elsatobias
Member
2012-07-11
13

Re: ImageMagick GPS php error after update to 1.2

Hello ZeBe,

I googled the error message and found a hint, that nothing has to be in front of "<?php". I edited the mentioned file and the error was gone.

I will try your updated package, when I am back home.

Thanks a lot
Tobi

Offline

 

#7 2017-06-22 20:01:21

elsatobias
Member
2012-07-11
13

Re: ImageMagick GPS php error after update to 1.2

Hello ZeBe,

I just updated to version 1.4 and I got no error or warning messages.

Greetings
Tobi

Offline

 

#8 2017-06-24 21:46:35

ZeBe
Member
Bavaria
2017-06-06
16

Re: ImageMagick GPS php error after update to 1.2

Hello Tobi,

many thanks for your testing.

Greetings
  ZeBe

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact