Announcement

  •  » Extensions
  •  » WARNING! Do not install the Automatic Oversize extension!

Notice: Undefined offset: 854 in /var/www/piwigo.org/forum/include/parser.php on line 509

Notice: Undefined offset: 854 in /var/www/piwigo.org/forum/include/parser.php on line 510

#1 2018-03-24 18:25:43

erAck
Only trying to help
2015-09-06
1415

WARNING! Do not install the Automatic Oversize extension!

Hello/Hi/Greetings,

Do not install [extension by ] (to support the [extension by lexming] Versa theme) if you already have [extension by plg] Automatic Size installed. Automatic Oversize declares some same function as Automatic Size which leads to a fatal error and wrecks your Piwigo installation completely unusable, including the admin area, so you are doomed if you don't have shell or ftp access to remove plugins/auto_oversize/

Error is:

Code:

Fatal error: Cannot redeclare asize_picture_content() (previously declared in .../plugins/automatic_size/main.inc.php:25) in .../plugins/auto_oversize/main.inc.php on line 103

For the Versa theme see also [Forum, post 170327 by erAck in topic 27821] [Theme] Versa

@plg:
Automatic Oversize seems to be more or less a copy+adjust of your Automatic Size, couldn't the functionality be added there instead?


Running Piwigo at https://erack.net/gallery/

Offline

 

#2 2018-03-24 19:23:53

flop25
Piwigo Team
2006-07-06
7037

Re: WARNING! Do not install the Automatic Oversize extension!

yes it's much better to enhance automatic size from https://github.com/plegall/Piwigo-automatic_size


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2018-10-25 04:41:10

lexming
Member
2017-03-19
3

Re: WARNING! Do not install the Automatic Oversize extension!

Thank you for the feedback and reporting those errors.

- I apologise for the confusion created with the Automatic_Oversize plug-in. I should have made it clearer that it was a drop-in replacement for Automatic_Size. Enhancing Automatic_Size with the functionality of Automatic_Oversize is certainly a better solution. Therefore, I already removed the latter from the repository to avoid further problems and I will send a Pr to Automatic_Size as soon as I have a first working patch.

Offline

 
  •  » Extensions
  •  » WARNING! Do not install the Automatic Oversize extension!

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact