Announcement

#1 2019-04-12 19:56:01

bcain
Member
2019-04-12
5

403 Error only when changing Options -> General

Hello,

I've just installed Piwigo to finally get off of Gallery.  The site is basically static.  I'm trying to update some basic settings, but I'm getting a 403 error ONLY on the options->general tab.  All the other tabs under options seem to work fine, and best I can tell all the other functionality works.

I know this is likely a permissions issue on my server, but nothing is jumping out at me that looks wrong about the permissions.

I'm hoping someone knows which file I need to look at to correct this error.

Thanks!

Bryan

Piwigo version: 2.9.5
PHP version: 5.6
MySQL version: 5.6.43
Piwigo URL: http://

Offline

 

#2 2019-04-14 19:34:07

snerbel
Member
2019-04-14
4

Re: 403 Error only when changing Options -> General

I'm battling this issue as well, after installing over the weekend.

I had some success turning off modsecurity on my site, and then just turning it back on, and I was able to save settings.

However, later, save settings would result in the 403 error again. Today, my little trick isn't working any more. :-(

I've checked folder permissions, and everything seems to be set at 755.

Offline

 

#3 2019-04-15 21:27:53

bcain
Member
2019-04-12
5

Re: 403 Error only when changing Options -> General

I've gone through everything I can see and it's all at least 644, but the fact that I can change the image size settings but not the user registration settings really ought to point to a specific file being wrong.

And of course, just to make things more fun, if I try to troubleshoot for too long my web host temporarily blocks my IP because their firewall software doesn't like the number of 403's I'm ringing up.

If it makes a difference, I installed via softaculous installer provided by my webhost.

Offline

 

#4 2019-04-16 14:11:53

snerbel
Member
2019-04-14
4

Re: 403 Error only when changing Options -> General

I deleted the installation and re-installed. Now I get 403 on login. :-(

Offline

 

#5 2019-04-16 15:13:02

bcain
Member
2019-04-12
5

Re: 403 Error only when changing Options -> General

Well, definitely not trying that.  Thanks for taking that bullet for me.

Offline

 

#6 2019-04-16 16:09:22

bcain
Member
2019-04-12
5

Re: 403 Error only when changing Options -> General

Managed to disable ModSecurity and test without getting firewalled; still getting 403s for general options.

Offline

 

#7 2019-04-16 19:29:19

snerbel
Member
2019-04-14
4

Re: 403 Error only when changing Options -> General

deleted install, and reinstalled with modsecurity off, then turned it back on. was able to login, but options still will not save. My limited expertise is exhausted

Offline

 

#8 2019-04-16 22:22:44

bcain
Member
2019-04-12
5

Re: 403 Error only when changing Options -> General

Well, I don't have a real answer, but I was able to update the settings that I needed to update by directly editing the contents of table piwi0v_config via phpmyadmin.  That's not perfect, but for me, given that this gallery is basically an archive rather than in active use, that's good enough.

Offline

 

#9 2019-04-18 02:48:24

snerbel
Member
2019-04-14
4

Re: 403 Error only when changing Options -> General

That's a good alternative... There are only 12-13 thing to change here. It's a bit of a pain, but doable, considering that there shouldn't be a need to regularly make these configuration changes.

Nice tip! Happy Piwigo'ng.

Offline

 

#10 2019-05-05 23:41:11

klexotic
Member
2019-05-05
1

Re: 403 Error only when changing Options -> General

Hello,
       I had face same error. Solution is to ask your hosting provider to shut off ModSecurity and it will be working fine.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact