Announcement

  •  » Extensions
  •  » [resolved] Did anyone successfully upload mp4 by VideJS

#1 2019-04-24 04:25:25

Foto
Member
2019-04-22
11

[resolved] Did anyone successfully upload mp4 by VideJS

Hi,

I put a have test.mp4 under galleries. The size of test.mp4 is about 350M, and I haved max the upload size to 1000M in pho.ini.

While sync I got following error:

Warning:  array_merge(): Argument #1 is not an array in /var/www/localhost/htdocs/piwigo/plugins/piwigo-videojs/admin/admin_sync.php on line 53

Notice:  Undefined index: output in /var/www/localhost/htdocs/piwigo/plugins/piwigo-videojs/admin/admin_sync.php on line 66

Warning:  array_merge(): Argument #1 is not an array in /var/www/localhost/htdocs/piwigo/plugins/piwigo-videojs/admin/admin_sync.php on line 78

Any advice? Thx

Piwigo version: 2.9.5
PHP version:
MySQL version:
Piwigo URL: http://

Offline

 

#2 2019-05-05 02:57:04

JohnAnderson
Member
2014-10-09
7

Re: [resolved] Did anyone successfully upload mp4 by VideJS

It’s not the size of the mp4. I had this same problem repeatedly with videojs 2.9. I never did get it to work. After spending hours on it, and researching the forms & github, I decided to revert back to videojs 2.8b. That works fine.

Deactivate videojs, then delete it, in the plugins admin panel.  Go to GitHub and either get the zip file for the 2.8b release, or clone it if you know how to do that.  Move the zip to your ../galleries/plugins folder. It should then appear in the plugins admin panel with the option to install it.

Sorry that is the best solution I could find. Maybe someone smarter than I will have a better idea!

Offline

 

#3 2019-05-14 05:19:44

Foto
Member
2019-04-22
11

Re: [resolved] Did anyone successfully upload mp4 by VideJS

Thanks JohnAnderson, I will try!

Offline

 

#4 2019-05-16 13:14:08

Foto
Member
2019-04-22
11

Re: [resolved] Did anyone successfully upload mp4 by VideJS

Well infact mp4 files works well in videojs, which cloned from github ( git://github.com/xbgmsharp/piwigo-videojs.git)

Here is my setup:

In LocalFiles Editor: local/config/config.inc.php

/* https://github.com/xbgmsharp/piwigo-vid … -configure */
$conf['upload_form_all_types'] = true;
$conf['sync_chars_regex'] = '/^[a-zA-Z0-9-_. ]+$/';
$conf['show_exif'] = true;
$conf['show_exif_fields'] = array(
  'Make',
  'Model',
  'ExifVersion',
  'Software',
  'DateTimeOriginal',
  'FNumber',
  'ExposureBiasValue',
  'FILE;FileSize',
  'ExposureTime',
  'Flash',
  'ISOSpeedRatings',
  'FocalLength',
  'FocalLengthIn35mmFilm',
  'WhiteBalance',
  'ExposureMode',
  'MeteringMode',
  'ExposureProgram',
  'LightSource',
  'Contrast',
  'Saturation',
  'Sharpness',
  'bitrate',
  'channel',
  'date_creation',
  'display_aspect_ratio',
  'duration',
  'filesize',
  'format',
  'formatprofile',
  'codecid',
  'frame_rate',
  'latitude',
  'longitude',
  'make',
  'model',
  'playtime_seconds',
  'sampling_rate',
  'type',
  'resolution',
  'rotation',
  );

1. I place my photos in a another larger disk partition, so I make soft link to the piwigo/galleries, but not copy.
2. The best way of  synchronisation is the "Quick local synchronisation" entered from Home->mainmenu-> administration

Here is my final solution for mov file (by my iphone):

1. Rename mov to mp4 file directly.
   I don't to transcode mov to mp4, because it will lose all the gps data. so I just keep it for one day.

2. "Quick local synchronisation" , by now it is not enough, you will find all the mp4(mov)  photo is just a video logo.

3. In plugin Photos->the Batch Manager, select the mp4 files(renamed from mov) , and from the "Action" button, select "Videos":
   Be sure to select "Poster->add film effect", otherwise you wont play it.
   Also, for me, set "Poster-> Create a poster at position in second" to 1, default is 4, but some of my mov are less than 4 seconds and will cause error.

by now, all my videos including mov mp4 works.

btw don't set player to video.js v7, doesn't work. videojs.v6/v5 works well.

About 504 gateway time-out, just use `top` to check if the exiftool precession is finished.

Last edited by Foto (2019-05-16 13:47:36)

Offline

 
  •  » Extensions
  •  » [resolved] Did anyone successfully upload mp4 by VideJS

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact