Announcement

#1 2019-10-11 20:23:06

Nigel-Aves
Member
2015-09-22
39

upgrade to 2.10 failed ....

Hello/Hi/Greetings,

Unfortunately upgrade did NOT work. The PIWIGO I was upgrading was totally uptodate.

Using Chrome browser - Version 77.0.3865.90 (Official Build) (64-bit)

Linux Server
Operating system     CentOS Linux 7.6.1810
Apache version     2.4.6
PHP versions     7.2.10
MySQL version     5.5.60

Greated with message : "Some Checksums are missing."

Compute 2753 missing checksums

Get the following error message >> error 501 : Method name is not valid

Found people in past had a similar problem. followed the instructions found.

Combine JS / CSS set to off

Purge compiled templates

Same problem.

Changed to Modus to see if that helps, did as above, did not help.....

Still using Modus and also happens on my prefered theme "Elegant" (Not a fan of Modus, I much prefer album list on screen. Pull down not good when you have 100+ albums as my other sites have.)

Go into any gallery that has albums in it and you get the following ...

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 119

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

ect ect .....

Offline

 

#2 2019-10-12 11:07:16

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13496

Re: upgrade to 2.10 failed ....

Hi Nigel-Aves,

Some upgrades are missing.

Open upgrade.php in your web browser (instead of index.php).

Offline

 

#3 2019-10-12 16:06:21

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

Just ran upgrade.php ... following message ....

No upgrade required, the database structure is up to date
← back to gallery


It's really strange as I have never had an issue when upgrading PIWIGO in the past.

Nigel.

Offline

 

#4 2019-10-15 04:41:37

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

Just tried the 2.10.1 and the checksum issues now seems to be resolved.

But I'm still seeing this message when I open an album that has sub-albums


Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 119

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

Notice: Undefined index: display_fromto in /home/serendipity/public_html/include/category_cats.inc.php on line 315

Offline

 

#5 2019-10-15 05:54:30

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6992

Re: upgrade to 2.10 failed ....

Hi :-)

your site/upgrade.php ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#6 2019-10-15 06:17:35

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

ddtddt ....

I did try that after plg suggested it ...

Following message ....

piwigo wrote:

No upgrade required, the database structure is up to date
← back to gallery

Offline

 

#7 2019-10-15 09:37:41

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13496

Re: upgrade to 2.10 failed ....

Can you go in your database manager and give us the result of these 2 SQL queries :

Code:

select * from piwigo_config where param = 'display_fromto';

and

Code:

select * from piwigo_upgrade order by applied desc limit 5;

Currently upgrade.php says the database is up to date, because you should have upgrade 156 registered in your piwigo_upgrade table, but on the other side it seems you don't have display_fromto in your config table, which should have been added by upgrade 153. So I wonder what is going wrong in your database.

Offline

 

#8 2019-10-15 16:38:44

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

Here are the results .... doesn't look good!

Output from SQL command select * from piwigo_config where param = 'display_fromto'; ..

No data returned

Output from SQL command select * from piwigo_upgrade order by applied desc limit 5; ..

id     applied                             description
152     2017-06-17 10:54:41     [migration from 2.8.0 to 2.9.1, 0.001 s] add 5 parameters to show/hide icons (edit/caddie/repressentative)
151     2017-06-17 10:54:41     [migration from 2.8.0 to 2.9.1, 0.001 s] add "picture_sizes_icon" and "index_sizes_icon" parameters
150     2017-06-17 10:54:41     [migration from 2.8.0 to 2.9.1, 1.544 s] add history_id_from+history_id_to in history_summary table
149     2017-06-17 10:54:39     [migration from 2.8.0 to 2.9.1, 0.513 s] add last_visit+last_visit_from_history in user_infos table
148     2016-03-08 21:33:05     [migration from 2.7.0 to 2.8.0, 0.353 s] add auth_key_id in history table

Offline

 

#9 2019-10-16 10:03:29

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13496

Re: upgrade to 2.10 failed ....

I'm going to need a dump of your database to understand what can be wrong. Some other users have the same problem and I would like to understand so that it can be correctly fixed. My email is "plg" on the the domain name of this forum.

Offline

 

#10 2019-10-16 15:35:16

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

On it's way ....

Offline

 

#11 2019-10-17 16:30:31

FOTW
Member
2019-10-08
1

Re: upgrade to 2.10 failed ....

Im experiencing the same errors. If another database dump would be helpful, please let me know

Offline

 

#12 2019-10-18 17:29:07

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13496

Re: upgrade to 2.10 failed ....

@Nigel-Aves thank you for the database dump. I have imported it in a fresh new database and configured my Piwigo to use it. Here is what I see when I open upgrade.php :

https://piwigo.org/forum/showimage.php?pid=174754&filename=Screen+Shot+2019-10-18+at+17.28.02.png

then

https://piwigo.org/forum/showimage.php?pid=174754&filename=Screen+Shot+2019-10-18+at+17.28.14.png

Conclusion : on my computer, Piwigo detects there are missing upgrades that need to be applied.

Offline

 

#13 2019-10-18 18:45:26

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

... and thereby hangs the problem because when I run upgrade.php I get the message ...

No upgrade required, the database structure is up to date
← back to gallery

I did notice that on line 172  of the file I sent it has this entry,

('c13y_ignore','a:2:{s:7:\"version\";s:6:\"2.10.1\";s:4:\"list\";a:0:{}}'

if this is the trigger for upgrade it would mean that PIWIGO always thinks it's up-to date.

Offline

 

#14 2019-10-18 20:22:08

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

I don't know if this helps or not. I restored the web site to the 2.9.0 version.

I decided to do a dump of the database and received this message ..

Fatal error: Uncaught Error: Call to undefined function mysql_select_db() in /home/serendipity/public_html/admin/include/mysqldump.php:75 Stack trace: #0 /home/serendipity/public_html/admin/include/mysqldump.php(66): MySQLDump->setDatabase('piwigo-serendip...') #1 /home/serendipity/public_html/admin/include/updates.class.php(481): MySQLDump->__construct('piwigo-serendip...', '/home/serendipi...', false, false) #2 /home/serendipity/public_html/admin/updates_pwg.php(106): updates::dump_database(false) #3 /home/serendipity/public_html/admin/updates.php(43): include('/home/serendipi...') #4 /home/serendipity/public_html/admin.php(312): include('/home/serendipi...') #5 {main} thrown in /home/serendipity/public_html/admin/include/mysqldump.php on line 75

went back to php 5.4.16

Tried to dump database and had this (rather unhelpful) message.

Unable to dump database.


I did try to run the update again (using php 5.4.16).... it errored out with a mis-configuration message.

The Apache error log contained the following ...

[Fri Oct 18 12:13:23.511407 2019] [fcgid:warn] [pid 9643] [client 192.168.1.50:62772] mod_fcgid: read data timeout in 31 seconds, referer: https://serendipity.soft-focus-imaginin … ge=updates
[Fri Oct 18 12:13:23.511538 2019] [core:error] [pid 9643] [client 192.168.1.50:62772] End of script output before headers: admin.php, referer: https://serendipity.soft-focus-imaginin … ge=updates

Offline

 

#15 2019-10-18 20:36:09

Nigel-Aves
Member
2015-09-22
39

Re: upgrade to 2.10 failed ....

Even MORE information ..... and this might be a good clue. Starting point PIWIGO Version 2.9.0

I now tried PHP 7.0.27

UPGRADE WORKED ......

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2021 · Contact